Menu

VBA : comment remettre a zéro une cellule lorsqu'elle dépasse une valeur définie

Messages postés
3
Date d'inscription
mardi 27 novembre 2018
Dernière intervention
27 novembre 2018
- - Dernière réponse : Patrice33740
Messages postés
7443
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
9 décembre 2018
- 27 nov. 2018 à 16:08
Bonjour,

J'ai besoin d'aide car j'ai un fichier Excel a réaliser pour mon alternance.
Sur ce fichier, je rentre le nombre de pièces fabriqué. dans une cellules j'obtient la somme des pièces.
Lorsque cette cellules dépasse les 10 000 et les 20 000 j'aimerais avoir un message d'alerte qui s'affiche une seul fois me disant "maintenance préventive" et lorsqu'elle dépasse 30 000 un message d'alerte me disant "maintenance complète" et la remise a zéro de cette cellule.
Comment faire ?

Merci de votre aide.

Bien cordialement
Léo
Afficher la suite 

Votre réponse

1 réponse

Messages postés
7443
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
9 décembre 2018
0
Merci
Bonjour,

Pour les messages :
=SI(OU(A1=10000; A1=20000); "maintenance préventive";SI(A1=30000; "maintenance complète";""))
Par contre, la remise à zéro ne peut pas se faire automatiquement avec Excel !
Il faut employer une macro VBA, est-tu sûr de vouloir cela ?
Si oui, voila un excellent cours gratuit pour débutant :
ftp://ftp-developpez.com/bidou/Cours/VBA/formationVBA.pdf
leobleu12
Messages postés
3
Date d'inscription
mardi 27 novembre 2018
Dernière intervention
27 novembre 2018
-
Pour le message est tu sur que cela va permettre de l'afficher qu'une seul fois ?

Oui pour la remise a zéro je pensais passer par la VBA et pour les messages je pensais aussi passer par de la VBA...qu'en penses tu ?
Patrice33740
Messages postés
7443
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
9 décembre 2018
-
yaka
leobleu12
Messages postés
3
Date d'inscription
mardi 27 novembre 2018
Dernière intervention
27 novembre 2018
-
Ca ne fonctionne pas car lorsque je rentre mes pièces fabriqué par jour et ça ne tombe pas forcement sur la valeur exact qui est 10 000, 20 000 ou 30 000. le message dois s'affiché des que je dépasse c'est valeur par exemple j'ai ma somme qui est a 9500, je saisie 1000 pièces fabriqué et la il faut que ca m'affiche "maintenance préventive" car j'ai dépassé la valeur 10 000
Patrice33740
Messages postés
7443
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
9 décembre 2018
-
Ans ce cas, il faut passer par le VBA
Commenter la réponse de Patrice33740