Menu

Reherche d'une valeur en fonction de 3 critères

Actidom 5 Messages postés jeudi 6 septembre 2018Date d'inscription 10 septembre 2018 Dernière intervention - 7 sept. 2018 à 06:24 - Dernière réponse : PapyLuc51 1751 Messages postés dimanche 3 mai 2009Date d'inscription 13 novembre 2018 Dernière intervention
- 11 sept. 2018 à 17:14
Bonjour,

Peu familier des formules sur Excel, j'ai besoin de vos lumières :

j'ai un tableau de prix pour des portes

Les informations dans ce tableau sont les suivantes :
marque, $C$13:$N$13 (RWD en C13, Lipbled F13, Prum I 13, Dana L13)
largeur, $C$14:$N$14 (800, 900 et 1000 pour chacune des marques)
hauteur, $B$15:$B$20 (2000, 2100, 2200, 2400, 2700, 3000)
prix, $C$15:$N$20


En C24 je saisis la hauteur, en D24 la marque, en E24 la largeur et j'obtiens le prix en F24

la formule en F24 est la suivante :
=INDEX(val;EQUIV(C24;Hauteur;0);EQUIV(D24;Marque;0)+EQUIV(E24;Largeur;0)-1)

Dans un monde idéal toutes les hauteurs ont des valeurs rondes : 2000, 2100, 2200, 2400, 2700 et 3000
Et, c'est bien connu, toutes les largeurs sont de 800, 900 et 1000

Dans la vraie vie les dimensions sont indisciplinées.

Je voudrais adapter ma formule pour qu'elle me renvoie un prix de porte pour toutes les hauteurs jusqu'à 2000, un prix pour toutes hauteurs de 2001 à 2100, de 2100 à 2200, de 2201 à 2400, de 2401 à 2700 et de 2701 à 3000
Idem bien sur pour les largeurs jusqu'à 800, de 801 à 900 et de 901 à 1000.

Quelle serait la formule la plus pertinente à utiliser ?
Comment s'écrirait t elle dans mon exemple ?

Y a-t-il mieux et (peut-être) moins compliqué ?

Merci d'avance pour votre aide.
Afficher la suite 

Votre réponse

10 réponses

Meilleure réponse
Vaucluse 22974 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 12 novembre 2018 Dernière intervention - Modifié par Vaucluse le 7/09/2018 à 18:06
1
Merci
Re


je n'ai pas trop compris le tableau que vous vouliez faire.
Voyez si, par rapport à vos tableaux, cette proposition peut vous inspirer (voir les annotations)
et revenez si besoin de complément ou si ça ne convient pas (mais alors dites nous pourquoi)
https://mon-partage.fr/f/iArQJ0ru/
crdlmnt

Merci Vaucluse 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 27666 internautes ce mois-ci

Actidom 5 Messages postés jeudi 6 septembre 2018Date d'inscription 10 septembre 2018 Dernière intervention - 10 sept. 2018 à 12:52
Bonjour Vaucluse,

Eh ben pour quelqu'un qui n'a pas bien compris, la solution proposée est quand même pile poil la réponse à ma question.
Dans une autre version que celle de PapyLuc.
L'avantage de la diversité des réponses, c'est que je peux maintenant modestement explorer quelques nouvelles fonctions.
Merci pour tout le soin apporté à ma demande, merci pour l'accueil également : un forum est une grande première pour moi...
Une belle journée
A bientôt
Commenter la réponse de Vaucluse
Meilleure réponse
Mike-31 16519 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 novembre 2018 Dernière intervention - Modifié par Mike-31 le 7/09/2018 à 17:44
1
Merci
Bonsoir,

J'avais préparé un exemple en attendant qu'Actidom se manifeste, certainement une autre proposition
avec
=RECHERCHEH(E24;INDIRECT(D24);EQUIV(C24;B14:B20;0);0)
peut être en complétant comme cela pour gérer les erreurs
=SIERREUR(RECHERCHEH(E24;INDIRECT(D24);EQUIV(C24;B14:B20;0);0);"")

https://www.cjoint.com/c/HIhpNOw5hwj
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...

Merci Mike-31 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 27666 internautes ce mois-ci

Actidom 5 Messages postés jeudi 6 septembre 2018Date d'inscription 10 septembre 2018 Dernière intervention - 10 sept. 2018 à 12:56
Mike-31,

Merci pour la solution proposée. Elle confirme le début de ma réflexion et répond en grande partie à ma question.
Je l'avais également envisagée comme ça sans pour autant savoir la formuler.
Je reste sensible à toute la peine que tu t'es donnée et t'en remercie très sincèrement.
Une belle journée
A bientot
Mike-31 16519 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 12 novembre 2018 Dernière intervention - 10 sept. 2018 à 13:12
Re,

il te suffit de nommer les plages exemple C14:E20 nommée RWD idem pour les autres plages en respectant l'orthographe de chaque nom et appliquer une simple formule de RECHERCHEV en F24 et le tour est joué
=SIERREUR(RECHERCHEH(E24;INDIRECT(D24);EQUIV(C24;B14:B20;0);0);"")
Commenter la réponse de Mike-31
Meilleure réponse
PapyLuc51 1751 Messages postés dimanche 3 mai 2009Date d'inscription 13 novembre 2018 Dernière intervention - 8 sept. 2018 à 07:35
1
Merci
Bonjour

Ma petite participation ;

J'ai complété la formule initiale par une recherchev pour déterminer la valeur de C24 et E24 après avoir ajouté deux tableaux de concordance des dimensions.

https://www.cjoint.com/c/HIifBUSkaIS

Cordialement

Merci PapyLuc51 1

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 27666 internautes ce mois-ci

Actidom 5 Messages postés jeudi 6 septembre 2018Date d'inscription 10 septembre 2018 Dernière intervention - 10 sept. 2018 à 12:48
Merci PapyLuc51. Merci beaucoup. Au prix de 2 tableaux supplémentaires, une solution 100% utilisable. Qui en plus parait si simple maintenant, et si compliquée quand on n'a que son ignorance pour avancer.
La communauté est vraiment une belle idée.
Re merci
Une belle journée à toi
A bientot
PapyLuc51 1751 Messages postés dimanche 3 mai 2009Date d'inscription 13 novembre 2018 Dernière intervention > Actidom 5 Messages postés jeudi 6 septembre 2018Date d'inscription 10 septembre 2018 Dernière intervention - 11 sept. 2018 à 17:14
Bonjour,

Merci du retour, si c'est le cas marquer le fil en résolu

Cordialement
Commenter la réponse de PapyLuc51
Vaucluse 22974 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 12 novembre 2018 Dernière intervention - 7 sept. 2018 à 06:53
0
Merci
Bonjour
pour faciliter la compréhension du sujet, déposer votre modèle ici, en y rajoutant quelques explications sur ce que vous attendez
http://mon-paratage.fr
et revenez coller le lien créé sur le site
à vous lire
crdlmnt
Actidom 5 Messages postés jeudi 6 septembre 2018Date d'inscription 10 septembre 2018 Dernière intervention - 7 sept. 2018 à 16:48
https://mon-partage.fr/f/SNlA0Ubp/
Pour les attentes, voir le mail svp.
Merci pour votre aide
Commenter la réponse de Vaucluse