Menu

Recopier du texte suivant une valeur....

rom - 14 févr. 2018 à 10:12 - Dernière réponse :  rom
- 14 févr. 2018 à 11:30
Bonjour,
Je m'excuse pour le titre je ne n'arrive pas à synthétiser mon problème.
J' ai envoyer un questionnaire pour savoir si les personnes voulais s'inscrire à une liste de diffusion.
J'ai un tableau avec dans la première colonne une adresse email, et les autres colonnes correspondent à mes différentes listes avec dans chaque case: "Recevoir de l'information" ou "Participer" ou "Accueillir" et des fois plusieurs réponses séparées par des virgules.
J'aimerais pouvoir recenser toutes les adresses mails qui ont répondu au moins "Recevoir de l'information".
J'ai penser faire un test logique et recopier l'adresse de la première colonne à la place de la réponse
=SI(B2="Recevoir des informations :";=A2)
mais ça ne marche pas. Je comprends pourquoi ça ne marche pas mais mes connaissance en excel sont assez limités. Pourriez vous m'apporter votre aide SVP?
Merci
Afficher la suite 

Votre réponse

5 réponses

PHILOU10120 4972 Messages postés lundi 16 avril 2012Date d'inscription 21 mai 2018 Dernière intervention - 14 févr. 2018 à 10:54
0
Utile
Bonjour Rom

Essayer ceci

=SI(B2="Recevoir des informations :";A2;"")
Commenter la réponse de PHILOU10120
0
Utile
Oui merci j'ai trouvé! je m'obstinais à mettre =A2.....
mais cela mais ça ne m'arrange qu'à moitié car quand les réponses sont multiples, ça ne marche pas....
CAD quand B2 indique "Recevoir des informations, Participer, Accueillir" ça ne fonctionne pas...
Commenter la réponse de rom
JeCherche24 46 Messages postés samedi 10 février 2018Date d'inscription 19 février 2018 Dernière intervention - 14 févr. 2018 à 11:01
0
Utile
Bonjour,

Attention au texte de l"énoncé.
"Recevoir des informations :" ne sera jamais égal à "Recevoir de l'information".


Un exemple du fichier en entrée pourrait nous aider.
Commenter la réponse de JeCherche24
PHILOU10120 4972 Messages postés lundi 16 avril 2012Date d'inscription 21 mai 2018 Dernière intervention - Modifié par PHILOU10120 le 14/02/2018 à 11:37
0
Utile
Bonjour Rom

=SI(ou(B2="Recevoir des informations :";B2="Participer";B2="Accueillir");A2;"")

Peut être comme-ci

=SI(B2="Recevoir des informations :";A2;Si(B2="Participer";A2;si(B2="Accueillir";A2;"")))

=SI(B2="Recevoir des informations : , Participer ";A2;"")))


=SI(B2="Recevoir des informations : , Participer , Accueillir";A2;"")))


Attention le texte doit être identique en tout point au texte de la formule.
Pour les réponses utiliser une liste déroulante comme cela il n'y pas d'erreur de frappe ou un libellé différent


Commenter la réponse de PHILOU10120
0
Utile
Pour le texte je ne peux pas avoir d'erreur vu que c'est un tableur issu des réponses à cocher dans mon questionnaire, de ce côté la pas de problème.
Je ne suis pas membre donc je ne peux pas poster d'image. le tableau de JeCherche24 est fidèle au mien.
J'aimerais remplacer les cases ou il y inscrit "Recevoir des informations" par la case de la colonne 1 de la ligne correspondante (l'adresse).
J'ai plusieurs colonnes identiques à la colonne B qui correspondent à plusieurs lites.
Si(B2="Recevoir des informations";A2) fonctionne uniquement quand il n'y a pas d'autres réponses dans la case.
Quand il y à "Recevoir des informations, Participer, etc..." cela ne fonctionne pas...
Commenter la réponse de rom