Menu

Calcul de taux de retour [Résolu]

Sebast - 3 févr. 2018 à 20:40 - Dernière réponse :  Sebast
- 3 févr. 2018 à 21:23
Bonjour,

Je travaille à mon compte et je cherche à calculer le taux de retour de mes devis effectués pour 4 ou 5 gros clients déterminés. Je me suis donc fait un tableau regroupant mes devis en ligne, et pour chaque devis, j'ai en colonne A le n° du devis, en colonne B le client et en colonne C l'état du devis (Accepté, refusé ou en attente).
Je cherche donc à savoir pour le client 1, le % de devis acceptés, refusés ou en attente, pareil pour le client 2, 3, 4 et 5.
J'arrive bien à compter le nbre de devis effectués pour le client 1 : NB.SI(B1:B100;"Client 1"), mais je bute sur la façon de faire un comptage sur deux critères de colonnes différentes.

Auriez-vous une idée sur la question pour me dépanner SVP ?



Afficher la suite 

Votre réponse

4 réponses

Vaucluse 21989 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 mai 2018 Dernière intervention - Modifié par Vaucluse le 3/02/2018 à 20:55
0
Utile
Bonjour

la formule ,à adapter:

=NB.SI.ENS(B:B;"nom client";C:C;"accepté")

vous pouvez bien sur remplacer les textes par les adresses de cellule qui les contiennent. par exemple avec la liste des clients dans une colonne de D2 à D10 et les termes accepté; refusé; en attente en titre de E1à G1
la formule devient alors en E2:*

=NB.SI.ENS(B:B;$C2;C:C;D$2)

place les signes $ aux bons endroits et vous pouvez "tirer" cette formule sur tout le tableau en lignes et colonnes
et pour avoir le taux de chaque client, il suffit de diviser par le nombre de fois ou le nom du client apparait en A
soit:
=NB.SI.ENS(B:B;$C2;C:C;D$2)/NB.SI(B:B;$C2)

Par ailleurs, voyez aussi du coté des tableaux croisés dynamiques qui devraient vous permettre de résoudre plus facilement ce sujet

crdlmnt




Oh YES ! Trop fort !
Je n'avais pas vu que cette fonction existait. Merci Vaucluse !!! C'est très sympa
Vaucluse 21989 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 20 mai 2018 Dernière intervention - 3 févr. 2018 à 20:56
Pas de quoi
si cela vous convient, merci de passer le sujet en résolu (roue dentée sous le titre du fil)
bonne route
crdlmnt
Je ne trouve pas de roue dentée ou d'autre moyen de le signaler, mais c'est effectivement résolu, merci beaucoup !
Commenter la réponse de Vaucluse