Menu

Fonction si cumulative avec plusieurs critères [Résolu]

Looping38 61 Messages postés samedi 22 octobre 2016Date d'inscription 6 juillet 2018 Dernière intervention - 11 déc. 2017 à 12:25 - Dernière réponse : ccm81 8520 Messages postés lundi 18 octobre 2010Date d'inscription 18 juillet 2018 Dernière intervention
- 11 déc. 2017 à 16:38
Bonjour Le Forum.
Je ne connais pas la formule à appliquer à cette demande :
J'ai un tarif de base en A1
J'ai un département en A2 issu d'un non du gestionnaire de nom
Le tarif doit être majoré de 10% si le département est soit 75, 77, 78, 91, 92, 93, 95.

La formule que j'essaye d'utiliser est = SI(OU(A2=75;A2=77;A2=78;A2=91;A2=92;A2=93;A2=95);A1*1,1;A1)

Le résultat n'indique pas d’erreur; mais n'applique pas le coef 1.1 sur un des départements 75, 77, 78, 91, 92, 93, 95.

Où est-ce que je me trompe?

Merci d'avance





Afficher la suite 

Votre réponse

4 réponses

Looping38 61 Messages postés samedi 22 octobre 2016Date d'inscription 6 juillet 2018 Dernière intervention - 11 déc. 2017 à 12:44
0
Merci
Complément : Lorsque je saisi directement 75 dans la cellule A2, cela marche...
Je penses avoir un problème avec l'utilisation d'une cellule d'une autre feuille du même classeur et/ou de l'utilisation des Nom du gestionnaire de nom...

Encore merci de vos contributions.
Commenter la réponse de Looping38
ccm81 8520 Messages postés lundi 18 octobre 2010Date d'inscription 18 juillet 2018 Dernière intervention - 11 déc. 2017 à 14:52
0
Merci
Bonjour

Es tu sûr que le résultat obtenu dans A2 (J'ai un département en A2 issu d'un non du gestionnaire de nom) est numérique ?
Sans le fichier, difficile d'aller plus loin.

Cdlmnt
Looping38 61 Messages postés samedi 22 octobre 2016Date d'inscription 6 juillet 2018 Dernière intervention - 11 déc. 2017 à 16:03
Bonjour CCM81.
J'ai regardé ce point, et le format de la cellule est bien de type nombre.
Pour solutionner mon problème, j'ai dû mettre le N° de départements entre guillemets "75"
Donc le revois de cellule se faisait uniquement sous forme de texte car sinon les départements 01 à 09 ne seraient pas pris en compte ...
Merci tout de même pour ton retour.
Si tu avait une solution pour convertir une donnée d'une cellule issue d'une autre sous forme de valeur acceptant le 0 en début, je suis preneur.
Cordialement,
Commenter la réponse de ccm81
ccm81 8520 Messages postés lundi 18 octobre 2010Date d'inscription 18 juillet 2018 Dernière intervention - 11 déc. 2017 à 16:38
0
Merci
Ce n'est pas parce que le format de la cellule est de type nombre qu'elle contient une valeur numérique. Tu la mets au format standard, si elle se cale à gauche, c'est du texte, si elle se cale à droite c'est un nombre.

Tu avais aussi comme possibilité pour ta formule
= SI(OU(A2*1=75;A2*1=77; ....

Cdlmnt
Commenter la réponse de ccm81