Menu

Ajustement de la fonction ARRONDI [Résolu]

max33d - 4 mai 2017 à 10:48 - Dernière réponse : Vaucluse 21899 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention
- 9 mai 2017 à 10:49
Bonjour à tous,

J'aimerais savoir si il est possible de "modifier" la fonction ARRONDI pour un cas précis.
Je m'explique :
- Il faudrait que la fonction arrondisse au nombre inférieur lorsque les chiffres après la virgule vont de 1 à 5 et au nombre supérieur lorsque les chiffres après la virgule vont de 6 à 9.
Exemple : 6.1 --> 6
6.5 --> 6
6.8 --> 7
Dans la fonction ARRONDI actuelle 6.5 est arrondit à 7.
J'espère avoir été clair, merci de votre aide !

Max
Afficher la suite 

6 réponses

Répondre au sujet
yclik 1286 Messages postés vendredi 25 juillet 2014Date d'inscription 25 avril 2018 Dernière intervention - 4 mai 2017 à 10:54
0
Utile
Bonjour
=SI(A2>6,5;ARRONDI(A2;0);ARRONDI.INF(A2;0))
Commenter la réponse de yclik
0
Utile
Bonjour,

Merci de votre réponse.
J'ai mis un exemple pour 6, 6.5, 6.8 mais les valeurs peuvent varier de 0.1 à 10.
Commenter la réponse de max33d
Vaucluse 21899 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - 4 mai 2017 à 11:03
0
Utile
Bonjour
pour adapter ça à une valeur variable dans une cellule A1:

=SI(A1-ENT(A1)=0,5;ARRONDI.SUP(A1;0);ARRONDI(A1;0))

crdlmnt
Commenter la réponse de Vaucluse
yclik 1286 Messages postés vendredi 25 juillet 2014Date d'inscription 25 avril 2018 Dernière intervention - 4 mai 2017 à 11:06
0
Utile
2
re
=SI(A2-ENT(A2)>0,5;ARRONDI(A2;0);ARRONDI.INF(A2;0))
Vaucluse 21899 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 26 avril 2018 Dernière intervention - 9 mai 2017 à 10:49
Pas de quoi, je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de yclik