Menu

Décimales sur moyenne [Résolu/Fermé]

mkway27 - 13 févr. 2017 à 19:29 - Dernière réponse : Vaucluse 22244 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 24 juin 2018 Dernière intervention
- 16 févr. 2017 à 11:20
Bonjour,

je suis à la recherche d'une fonction me permettant d'avoir le bon format sur une cellule , si joint les explications

A1 0,06
A2 0,06
A3 0,06
A4 0,06
A5 0,06
A6 0,05
A7 0,05
A8 0,05
A9 0,08

A10 MIN ( a1:a9) 0,05
A11 max(a1:a9) 0,08
A12 moyenne(a1:a9) 0,058888889

Je souhaiterai que le format de la cellule A12 (moyenne) est le même nombre de décimale que la cellule A1 sachant que les valeurs des cellules A1 à A9 peuvent être différentes , soit pas de décimale , soit 3, 4 ou 5 décimales.

J'ai cherché un peu partout sur les forums mais je sèche complètement. Votre aide me sera très précieuse.
Merci par avance

Mick



Afficher la suite 

6 réponses

Vaucluse 22244 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 24 juin 2018 Dernière intervention - 13 févr. 2017 à 19:43
0
Merci
Bonjour
avec arrondi?

=ARRONDI(MOYENNE(A1:A9);2)

ou si le nombre de décimales en A1 est variable:

=ARRONDI(MOYENNE(A1:A9);NBCAR(STXT(A1;TROUVE(",";A1)+1;20)))

cette option pourra "raccourcir" les décimales, mais pas en rajouter en 0

crdlmnt
micky27 7 Messages postés samedi 4 juin 2016Date d'inscription 16 février 2017 Dernière intervention - 16 févr. 2017 à 11:10
Bonjour,

merci pour la formule qui m'a permis de l'adapter à mon besoin.
A+
Vaucluse 22244 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 24 juin 2018 Dernière intervention > micky27 7 Messages postés samedi 4 juin 2016Date d'inscription 16 février 2017 Dernière intervention - 16 févr. 2017 à 11:20
Ok je passe le sujet en résolu
Bonne route
crdlmnt
ccm81 8491 Messages postés lundi 18 octobre 2010Date d'inscription 23 juin 2018 Dernière intervention - Modifié par ccm81 le 14/02/2017 à 11:38
0
Merci
Bonjour à tous

On peut aussi envoyer l'artillerie lourde et une macro (conserve la valeur)
http://www.cjoint.com/c/GBokoHzKL2f

Cdlmnt
Raymond PENTIER 46126 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 24 juin 2018 Dernière intervention - 14 févr. 2017 à 00:10
-1
Merci

Bonjour Mick.

Tu te crées des soucis inutiles ...
Il te suffit de modifier le format de cellule quand c'est nécessaire !
micky27 7 Messages postés samedi 4 juin 2016Date d'inscription 16 février 2017 Dernière intervention - 16 févr. 2017 à 11:08
Bonjour,

merci pour le conseil mais ce n'était pas la manip que je cherchais. J'ai grace à tous ces conseils trouvé la solution.
A+