Call to a member function query() on null in [Résolu/Fermé]

Messages postés
172
Date d'inscription
dimanche 23 février 2014
Statut
Membre
Dernière intervention
29 juillet 2017
- - Dernière réponse : chrisee
Messages postés
172
Date d'inscription
dimanche 23 février 2014
Statut
Membre
Dernière intervention
29 juillet 2017
- 22 mars 2016 à 00:29
Salut,
J’ai créé un petit site web qui marche bien en local, mais une fois en ligne j’ai un problème au niveau de mon livre d’or j’ai ce message :
Fatal error: Call to a member function query() on null in /home/sites/hebfree.org/chrislis/public_html/chat.php on line 22
Et voici la ligne qui pose problème :


require_once('admin/bd.inc.php');
$req=$connexion->query('SELECT * FROM lo ORDER BY id ASC');
Afficher la suite 

1 réponse

Messages postés
26066
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
8 août 2019
1742
-2
Merci
Bonjour,

Vérifies le code que tu as dans :
require_once('admin/bd.inc.php'); 

Je pense que tu as mal renseigné les variables qui te permettent de t'authentifier sur ta BDD ( infos fournies par ton hébergeur...)
chrisee
Messages postés
172
Date d'inscription
dimanche 23 février 2014
Statut
Membre
Dernière intervention
29 juillet 2017
6 -
J'ai mis des * pour cacher certains trucs

<?php
try{
$bd=new PDO('mysql:host=localhost;dbname=****','****','****',array(PDO::MYSQL_ATTR_INIT_COMMAND=>'SET NAMES utf8'));//Le array c'est pour convertir les caracteres en utf-8
}
catch(PDOException $erreur)
{
echo "Erreur: ".$erreur->getMessage();
}
?>
Pitet
Messages postés
2378
Date d'inscription
lundi 11 février 2013
Statut
Membre
Dernière intervention
2 février 2018
394 -
Du coup, la variable qui contient la connexion à la base de données est $bd et non $connexion
chrisee
Messages postés
172
Date d'inscription
dimanche 23 février 2014
Statut
Membre
Dernière intervention
29 juillet 2017
6 > Pitet
Messages postés
2378
Date d'inscription
lundi 11 février 2013
Statut
Membre
Dernière intervention
2 février 2018
-
Merci beaucoup,mon probleme etait resolu,j'avais oublie de mettre $bd