Menu

Trop d'arguments sur une fonction Excel ?? [Fermé]

Messages postés
596
Date d'inscription
mardi 25 septembre 2007
Statut
Membre
Dernière intervention
18 avril 2016
- - Dernière réponse : Raymond PENTIER
Messages postés
49110
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 juin 2019
- 16 déc. 2009 à 01:18
Salut à tous !

Tout d'abord je tiens à signaler que je suis un noob sur excel.
J'ai fait cette fonction :
=SI(H5>19;SI(J5="x";"";SI(L5="";SI(M5="";"x";"");"");"")

Et là Exel 2003 me dit que j'ai mis trop d'arguments pour cette fonction.
J'ai lu qu'on pouvait mettre jusqu'à 7 SI imbriqués, en tout moi j'en ai que 4...
Comment faire pour que ça passe ?

Merci d'avance.
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
1593
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
654
3
Merci
bonsoir,

la fonction SI fonctionne de la façon suivante (important pour les imbrications) :
=SI(test;'valeur si vrai';'valeur si faux')
une imbrication se fait en mettant d'autres fonctions SI "à la place" d'une des deux valeurs :
=SI(test1,'valeur1 si vrai';SI(test2;SI(test3;valeur3 si vrai';'valeur3 si faux');valeur2 si faux')) par exemple
il faut donc faire très attention aux ) notamment...
En l'occurrence, il y en un de trop et cette fonction donnera un résultat écrite sous cette forme :
=SI(H5>19;SI(J5="x";"";SI(L5="";SI(M5="";"x";"");""));"")
Cependant, ce n'est pas pour autant qu'il s'agit du "bon" résultat escompté : cela dépend de la bonne analyse du déroulement logique des SI, ALORS, SINON...

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 43026 internautes nous ont dit merci ce mois-ci

Messages postés
49110
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 juin 2019
10041
1
Merci
Bonjour Kopros.

Gord21 a raison : tu n'as que 3 parenthèses fermantes pour 4 ouvrantes ...

dobo69 t'a fait une analyse très complète.
En faisant abstraction de la première condition SI H5>19, l'intérieur de ta formule est
=SI(J5="x";""; SI(L5="";SI(M5="";"x";"");"") ) où le dernier argument ;"" est de trop.
Mais surtout, la dernière observation de dobo69 mérite que tu y prêtes attention.
En effet, telle que tu l'as écrite, ta formule fonctionne ainsi :
* Si H5<=19 ► afficher ""
* Si H5>19 et J5="x" ► afficher ""
* Si H5>19 et J5<>"x", il suffit que L5 ou M5 soit différent de "" pour afficher ""
* Si à la fois H5>19, J5<>"x", L5="" et M5="" ► afficher "x".
En résumé "x" ne serait affiché que si l'on avait à la fois H5>19 et J5<>"x" et L5="" et M5="".
Est-ce bien ce que tu souhaitais ?
Messages postés
919
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013
260
0
Merci
Bonsoir,
Si j'ai bien compté, il manque ;"") à la fin de ta formule.