WORD Séparateur de milliers champs fusionné [Résolu/Fermé]

bibike - 17 oct. 2008 à 16:17 - Dernière réponse :  DJENANE
- 18 août 2017 à 16:50
Bonjour,

J'ai crée un publipostage sous Word, afin de faire une relance clients.

Ma BDD est faite sous Excel elle est coupée en trois onglets, selon le type de relance la lettre est différente.

J'ai un champ qui indique le montant de la dette dans la lettre, c'est cool il apparait bien sauf qu'il n'est pas mis en forme.

Dans ma BDD pourtant ce champs est inscrit : "10 658,40 €" j'aimerais que sous word il conserve le séparateur de milliers, et l'euro, hors sous word il s'affiche "10658,4".

En faisant alt+F9 j'ai pu écrit dans la macro (c'est comme ca que l'on dit ??) ce code "/# "## ###,## €"}"

L'€ s'affiche, mais mon chiffre qui était 10 658.40 €, se réduit en "106.58 €" il me le décale, m'en bouffe la moitié, et ne me sépare toujours pas les milliers, j'ai eu beau chercher sur le site faqworld et sur bon nombre de site sur internet, je ne trouve pas réponse à mon problème.

Si j'utilise l'assistant publipostage je dois pouvoir avoir cette mise en forme mais je ne peux pas refaire mon tableau triple sous word, et vu la longueur j'aimerais bien éviter de devoir en arriver là.

Si quelqu'un peut m'aider, je suis tout ouïe.

D'avance merci pour votre lecture et vos réponses.
Afficher la suite 

12 réponses

m@rina 13942 Messages postés mardi 12 juin 2007Date d'inscriptionContributeurStatut 20 janvier 2018 Dernière intervention - 18 oct. 2008 à 00:59
+14
Utile
1
Bonjour,

Word se fiche du formatage d'Excel, il faut effectivement lui imposer un formatage correct

le commutateur numérique du champ (et non le code de la macro car il n'y a pas de macro...) est mal fait. Tu dois mettre :

\# "## ###,00 €"

Par contre, j'ai l'impression que tu fais un mélange avec le séparateur de décimales (point ou virgule ??). Ce dernier doit être conforme aux options régionales et linguistiques.

m@rina
Cette réponse vous a-t-elle aidé ?  
je vous remercie de m'avoir bien aider,
je ne vous cache que j'ai perdu plus d'une journée avant de trouver ton astuce. et de mon coeur je te souhaite que Dieu te récompense
+4
Utile
27 Ctrl Maj Espace 600 = 27 600
+2
Utile
1
Slt à tous

VOICI LA SOLUTION SUR WORD 2007 :

1- ALT + F9

2 - tapez le nom du champ à fusionner (ici : NomChamp) comme suit :

{ MERGEFIELD NomChamp \# "# ### ##0,00" \* MERGEFORMAT }

3- ALT + F9
Merci bcp
0
Utile
1
Salut m@rina merci pour ta réponse !

Désolé de mon erreur de vocabulaire (macro/code/bidule).

J'avais essayé aussi le \# "## ###,00 €"

Mais ça ne fonctionne pas non plus, par contre au niveau virgule et point, ça peut venir de là, je dois mettre une virgule ou un point sous ma BDD Excel ?

Merci.
Salut,
ça marche ! il faut juste mettre à jours les champs en faisant clique droit sur la macro.
m@rina 13942 Messages postés mardi 12 juin 2007Date d'inscriptionContributeurStatut 20 janvier 2018 Dernière intervention - 18 oct. 2008 à 20:52
0
Utile
Bonjour,

Dans Excel, tu ne dois rien mettre du tout. Tu dois utiliser le format nombre pour formater ton nombre comme tu le souhaites, sachant que le format dépend, comme je l'ai mentionné, des options régionales et linguistiques. Si l'on change de formatage dans les options, le fichier Excel sera mis automatiquement à jour avec le format correspondant.

Dans un champs Word, on va pouvoir grâce au commutateur numérique choisir le séparateur des milliers (espace ou point), mais il faut quand même que ça reste conforme aux opions régionales et linguistiques.

m@rina
0
Utile
1
Bonjour Marina,

Merci de ta réponse, j'ai mis dans les options Excel, le même séparateur de milliers (à savoir un espace) et le même séparateur de décimales que dans le code inscrit dans mon publipostage Word, et cela fonctionne à merveille.

Merci beaucoup.

Bonne fin de journée.
-2
Utile
A toutes fins utiles, considérez également :
http://www.coursbardon-microsoftoffice.fr/word2007/tableaux-3.htm