Signaler

Séparateur de décimales openoffice vista [Résolu/Fermé]

Posez votre question questioninfo 160Messages postés samedi 20 octobre 2007Date d'inscription 5 septembre 2017 Dernière intervention - Dernière réponse le 10 nov. 2017 à 21:37 par rc
Bonjour,

J'utilise un pc portable sous vista avec openoffice.
Je souhaite utiliser le point en lieu et place de la virgule (facilité de saisie) lors de la saisie de nombres avec décimales pour faire des calculs.
Comment peut-on remplacer la virgule qui marque la décimale par un point sans que ma cellule considère cela comme étant une erreur.

Il m'avait été indiqué que dans les options, onglet International, je pouveais choisir le symbole qui sera utilisé comme séparateur de décimale. Malheureusement je ne trouve pas : onglet inetrnational.

Merci pour votre aide.
Utile
+3
plus moins
Bonjour,

Ca se trouve dans Outils > Options > Paramètres linguistiques > Langues.
Il faut choisir Interface utilisateur "par défaut", puis la version du français qu'on désire pour les autres. Le point sera utilisé en lieu et place de la virgule.
Abadien- 26 janv. 2012 à 17:45
cela ne fonctionne pas !!!
Non2 5110Messages postés mercredi 19 décembre 2007Date d'inscription ContributeurStatut 15 juillet 2015 Dernière intervention - 27 janv. 2012 à 10:44
Bonjour Abadien,

Ce topic a déjà près de quatre ans, et je ne suis plus avec OOo. Je ne saurais donc plus répondre. Par contre, ce truc est toujours valable avec LibreOffice.
Utile
+0
plus moins
Merci pour ton message,

Malheureursement chez moi ça ne fonctionne pas.
J'ai suivi au pas à pas tes consignes.
Dont interface utilisateur par défaut, environnement linguistique Français (France), Touche séparateur de décimales : cochée ou pas cela ne change rien.
J'ai fermé openoffice, relancé : aucun changement.
A titre d'exemple lorsque je saisis 2.5 j'obtiens 02/05/08
si je saisis =2.5 j'obtiens 39570

????
Merci si tu as une explication
Utile
+0
plus moins
Est-ce qe ça ne dépend pas aussi des options régionales de Windows ?

dans l'aide OO:
Outils - Options - Paramètres de langue - Onglet Langues
Touche séparateur de décimales - Identique à l'environnement linguistique
Spécifie que la touche séparateur de décimales définie dans votre système sera utilisée lorsque vous appuierez sur la touche correspondante du clavier numérique.
Si cette option est cochée, le caractère qui s'affiche après "Identique à l'environnement linguistique" est inséré lorsque vous appuyez sur la touche du clavier numérique. Si cette option n'est pas cochée, le caractère inséré est celui que fournit le logiciel de votre pilote de clavier.
Utile
+0
plus moins
Bonjour à tous,

Désolé pour le retard, j'ai eu pas mal d'occupations. Bien sûr, ça dépend des options régionales dans l'OS. Désolé si je ne l'ai pas précisé, mais ça m'était apparu évident.

De plus, il faut prendre conscience que le fonctionnement d'OOo est particulier : contrairement aux autres suites bureautiques tous OS confondus (msOffice, kOffice, ...) OOo utilise le même signe (point ou virgule) quelle que soit l'application proposée. C'est (avis personnel) le plus gros inconvénient d'OOo.

Si le point est utilisé, il considérera qu'un point est entré même dans le tableur, et si les options régionales utilisent une virgule comme séparateur décimal, il faut taper la virgule dans le clavier alphanumérique, pas dans le pavé numérique.
Inversement, si la virgule est utilisée dans le pavé numérique, il utilisera le caractère virgule même dans le traitement de texte, ce qui rend l'utilisation du pavé numérique énervant dans un cas ou dans l'autre.

C'est un vieux débat qui énerve les "puristes" pour lesquels chacun devrait apprendre à se servir correctement du clavier, contrairement aux utilisateurs conventionnels qui voudraient une utilisation plus "instinctive" de celui-ci.

Pour la date entrée avec 2.5 : il faut donc inscrire la virgule au pavé alphanumérique, ce qui permet de reconnaître le 2,5 entré comme un nombre plutôt que comme une date. Il y a peut-être aussi (je n'ai pas essayé) la possibilité de changer le format de cellule.

Personnellement, étant sous GNU/Linux, j'ai pu résoudre ce problème d'une façon assez disgrâcieuse mais efficace grâce à un script bash. Par contre, sous Windows, je ne sais pas comment palier à la situation.

Au cas où ça pourrait aider quelqu'un, voici le contenu de ce script que j'ai nommé PointVirgule.sh dans /usr/bin :

#!/bin/bash
val=`xmodmap -pke | grep "keycode 91 = KP_Delete KP_Decimal"`
echo $val
if [ -n "$val" ]
then
xmodmap -e 'keycode 91 = KP_Delete comma'
else
xmodmap -e 'keycode 91 = KP_Delete KP_Decimal'
fi
Utile
+0
plus moins
et avec la variable LC_NUMERIC

The definition starts with the string LC_NUMERIC in the first column.
The following keywords are allowed:
decimal_point
followed by the string that will be used as the decimal delimiter when formatting numeric quantities.
Utile
+0
plus moins
Merci pour vos réponses à tous,
J'avais bien au préalable modifié les options régionales de Windows, mais sans succés.
Vous me fournissez l'explication comme quoi il n'y a pas vraiment de solutions.
C'est déjà bien de le savoir cela évite de se perdre un peu partout.
Merci encore pour vos réponses très sympa.
Utile
+0
plus moins
Merci Dubcek, je ne connaissais pas cette histoire de variable LC_NUMERIC, je suis un peu trop neuf sous Nunux.
Je vais farfouiner là-dedans, j'ai déjà trouvé mes premières infos en français :
http://forum.ubuntu-fr.org/viewtopic.php?id=195324
http://forum.ubuntu-fr.org/viewtopic.php?id=81122
pour ceux que ça intéresserait.
Utile
+0
plus moins
oui, man locale donne les détails
Utile
+0
plus moins
Merci, je n'ai rien à y changer, mais ça peut être utile un jour ou l'autre.
Pour Questioninfo, qui est sous Vista, y a-t'il un équivalent Windows ?
ilan- 1 déc. 2008 à 18:09
J'sais pas sous windows, mais sous ooo pour linux avec le français comme langage par défaut, il suffit de selectionner l'ensemble du tableau puis format>cellules>choisir "tout" dans categorie et "general" dans format puis "Anglais -Royaume Uni)" dans langue et toutes tes "," se transforment en ".".
Utile
+0
plus moins
Voila j'avais le meme problème que toi et si tu ne l'as toujours pas résolu, j'ai peut-être trouvé une solution en fouillant dans les divers formus. Il faut tout simplement choisir anglais dans les parametres linguistiques que tu trouves dans outils- options- parametre linguistiques -langues et ensuite il faut modifier la monnaie par défaut tu choisis euro si c'est ce que tu utilise. J'ai essayé et cela à l'air de marcher. Bonne chance
sabrina- 25 oct. 2010 à 14:51
Merci pour l'astuce sa a l'air de marcher pour moi aussi.
Michel26- 3 nov. 2010 à 17:01
Le pb est identique dans Lotus Symphony, la suite bureautique libre de Lotus proposée par IBM.
C'est marrant que cela se produise sur ces logiciels Open Source !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !