Firefox : on casse tout et on vous emm...de

djg13 7 Messages postés vendredi 29 décembre 2017Date d'inscription 30 décembre 2017 Dernière intervention - 29 déc. 2017 à 03:19 - Dernière réponse : little boy62 2973 Messages postés lundi 11 novembre 2013Date d'inscription 10 janvier 2018 Dernière intervention
- 30 déc. 2017 à 21:00
Bonjour,



Téléchargement de la version 57 demandé par FFX ==> de nombreuses extensions ne marchent plus !!!! Même pas de message préliminaire pour avertir le peuple que la Wermacht passe à l'attaque : scandaleux! J'ai downgradé et s'il le faut, avant de retourner sur SAFARI, je reste sur celle-là !
Afficher la suite 

13 réponses

Répondre au sujet
little boy62 2973 Messages postés lundi 11 novembre 2013Date d'inscription 10 janvier 2018 Dernière intervention - 29 déc. 2017 à 20:44
+1
Utile
1
Salut.

Les voilà: Adblock Plus, uBlock Origin, MultiRow Bookmarks Toolbar Plus, Show Parent Folder, Tab Mix Plus et deux autres extensions très utiles qui me permettent de ne pas avoir à m'identifier sur un serveur de références scientifiques.

En fait FFX me supprime les extensions qui font que j'ai choisit ce navigateur (elles n'existent pas telles quelles ailleurs). Je me barre chez Chrome ou Safari dès que je ne pourrai plus m'en servir (si trop de failles de sécurité...).


Tu peux facilement trouver des remplaçants ^^

Comme toi, j'ai été déçu que certaines des extensions installés était KO.
Mais j'ai trouvé des remplaçants faisant le même job, voire mieux dans certains cas. :)

------------------------

D'ailleurs :
1. Adblock plus dernière version est compatible FF57.
2. uBlock Origin dernière version est compatible FF57.

Tiens, pourquoi avoir les deux ?
Personnellement, à l'utilisation, je préfère uBlock Origin, ADBP est pour moi beaucoup moins paramétrable.

------------------------

Le développeur de MultiRow Bookmarks Toolbar Plus ne désire pas continuer son développement, comme pas mal d'autres.

Peut-être que tu peux trouver un remplaçant, tout dépend des fonctions souhaitées.

Regarde ici :
https://addons.mozilla.org/fr/firefox/addon/bookmarksdropdown/

Mais j'avoue, je n'ai pas trouvé beaucoup d'alternative.

------------------------

Pour Tab Mix Plus, je l'ai jamais utilisé. J'utilisais un autre, Multiple Tab Handler (https://addons.mozilla.org/en-US/firefox/addon/multiple-tab-handler/).

Mais depuis qu'ils l'ont revu pour la rendre compatible, l'intérêt s'est dissipé. Plus de clic droit sur onglet.

je l'ai donc remplacé par FoxyTab https://addons.mozilla.org/fr/firefox/addon/foxytab/

------------------------


Bref, avant, j'étais sceptique face à cette version, car je ne pensais pas trouver des alternatives aux précédentes extensions...

Mais le fait est que j'ai appris à m'en passer, à en utiliser d'autres.


++





djg13 7 Messages postés vendredi 29 décembre 2017Date d'inscription 30 décembre 2017 Dernière intervention - 29 déc. 2017 à 23:52
Merci pour tes infos, je vais regarder ça de près.
Commenter la réponse de little boy62
dsy73 9038 Messages postés dimanche 22 août 2010Date d'inscriptionContributeurStatut 9 janvier 2018 Dernière intervention - 29 déc. 2017 à 04:47
0
Utile
4
Salut, plutôt que le downgrade qui laisse des failles de sécurité, il est préférable de prendre la version ESR de Firefox : https://www.mozilla.org/en-US/firefox/organizations/
Elle est actuellement en 52.5.3 et contient évidemment tous les patchs de sécurité.
djg13 7 Messages postés vendredi 29 décembre 2017Date d'inscription 30 décembre 2017 Dernière intervention - 29 déc. 2017 à 05:01
en fait je suis passé sur la version ESR 53.0.2 qui marche bien comme avant. Je me demandais quelle était la dernière version ESR qui fonctionnerait bien avec mes extensions avant leur version catastrophe 57 ... Merci pour le message.
dsy73 9038 Messages postés dimanche 22 août 2010Date d'inscriptionContributeurStatut 9 janvier 2018 Dernière intervention - 29 déc. 2017 à 20:16
La dernière version ESR est 52, pas 53 : https://www.mozilla.org/en-US/firefox/organizations/

Tant que Firefox ESR ne passe pas en 57+ alors elle reste compatible avec l'ancienne API pour les addons. J'ai l'impression que cela se passera en 2018 (cf lien précédent).
djg13 7 Messages postés vendredi 29 décembre 2017Date d'inscription 30 décembre 2017 Dernière intervention - 30 déc. 2017 à 00:06
J'avais lu que la version ESR offrait plus de compatibilités avec les addons qui ne seraient plus supportés par FFX. D'après ce que tu dis, 52.5.3 est la dernière version ESR. La version que j'utilise (53.0.2) n'est dpnc pas ESR, cependant elle fonctionne très bien avec mes extensions. Donc FFX 56 est donc la dernière version (non ESR) qui devrait supporter mes extensions, j'ai bon ?
Merci pour le lien.
dsy73 9038 Messages postés dimanche 22 août 2010Date d'inscriptionContributeurStatut 9 janvier 2018 Dernière intervention - 30 déc. 2017 à 07:04
Oui c'est ce que j'ai compris aussi.
Commenter la réponse de dsy73
_Ritchi_ 18315 Messages postés samedi 17 mars 2007Date d'inscriptionContributeurStatut 10 janvier 2018 Dernière intervention - 29 déc. 2017 à 18:10
0
Utile
5
Bonjour djg13,

Firefox me propose la mise à jour 57.0.1.
Aussi, avant de l'accepter, j'aurais aimé connaître les extensions qui ne marchaient plus chez toi: serait-ce possible d'en avoir la liste ?

Ritchi
djg13 7 Messages postés vendredi 29 décembre 2017Date d'inscription 30 décembre 2017 Dernière intervention - 29 déc. 2017 à 18:45
Pas de soucis.

Les voilà: Adblock Plus, uBlock Origin, MultiRow Bookmarks Toolbar Plus, Show Parent Folder, Tab Mix Plus et deux autres extensions très utiles qui me permettent de ne pas avoir à m'identifier sur un serveur de références scientifiques.

En fait FFX me supprime les extensions qui font que j'ai choisit ce navigateur (elles n'existent pas telles quelles ailleurs). Je me barre chez Chrome ou Safari dès que je ne pourrai plus m'en servir (si trop de failles de sécurité...).

Je me demande bien pourquoi ils ont décidé de prendre une décision aussi stupide!
dsy73 9038 Messages postés dimanche 22 août 2010Date d'inscriptionContributeurStatut 9 janvier 2018 Dernière intervention - 29 déc. 2017 à 20:12
Les raisons sont expliquées :
- Porting add-ons to and from other browsers should be easier.
- Reviewing add-ons for addons.mozilla.org (AMO) should be easier.
- Compatibility with multiprocess Firefox (Electrolysis).
- Changes to Firefox's internal code should be less likely to break add-ons.
- WebExtensions APIs should be easier to use than the existing Firefox XPCOM/XUL APIs.
- WebExtensions APIs should maintain acceptable security and privacy standards.
https://wiki.mozilla.org/WebExtensions
djg13 7 Messages postés vendredi 29 décembre 2017Date d'inscription 30 décembre 2017 Dernière intervention - 30 déc. 2017 à 00:09
Merci, on verra à l'usage...
_Ritchi_ 18315 Messages postés samedi 17 mars 2007Date d'inscriptionContributeurStatut 10 janvier 2018 Dernière intervention - 30 déc. 2017 à 13:31
Il est fort probable que les créateurs de ces extensions éditent rapidement une mise à jour qui soit compatible avec le nouveau Firefox.
En tout cas merci pour ce retour
little boy62 2973 Messages postés lundi 11 novembre 2013Date d'inscription 10 janvier 2018 Dernière intervention - 30 déc. 2017 à 21:00
Fort probable, oui et non.

Certains enterrent leurs extensions, trop de changement de codage. :/
Commenter la réponse de _Ritchi_