Signaler

Datedif + si [Résolu]

Posez votre question geo34 - Dernière réponse le 9 nov. 2017 à 11:27 par geo34
Bonjour,

Bonjour je veux compter le nombre de jours d'une date1 a une date2:

si date de sortie vide
Date du jour (AQ2) - date accompagnement (AC4)
si non
Date de sortie(AI4) - date d'entré (W4)

=SI(AI4="";(DATEDIF(AQ2-AC4;"D"));(DATEDIF(AI4-W4;"D")))

Ca fonctionne pas, une idée ^^ ?
Utile
+0
plus moins
Bonjour,
Pourquoi utiliser Datedif
une soustraction entre deux date te donnera le Nb de jour
geo34- 9 nov. 2017 à 11:08
Ah oui xD

=SI(AZ4="";AQ2-AT4;AZ4-W4)

mais j'ai un résultat improbable 43048, c'est parque si la cellule est vide ça me met 1900 de base ?

Dans se cas la si de base tte mes cellules sont vides mais si elles contienne des donnée c'est bon je peux ajouter si tout vide ="" ?
Répondre
Vaucluse 20708Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 21 novembre 2017 Dernière intervention - 9 nov. 2017 à 11:19
Bonjour
si vous avez 1900 de base c'est que votre résultat est 0 Excel par défaut affiche le 0 janvier 1900 dans une cellule égale à 0.
vous pouvez masquer ce type de résultat via les options avancées Excel en décochant "afficher un 0 dans les cellules de valeurs nulle"
quant au 43408 c'est probablement le résultat du nombre de jours entre la date de fin et 0, et qui correspond pour Excel en fait à la valeur num de la date de fin
Pour éliminer ça , vous pouvez peut être selon vos besoins écrire:
=SI(OU(AZ4="";AT4=0;AZ4=0);"";AQ2-AT4;AZ4-W4)
crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,

essaye comme cela
=SI(AI4="";DATEDIF(AC4;AQ2;"D");DATEDIF(W4;AI4;"D"))

ou simplement comme cela
=SI(AI4="";AQ2-AC4;AI4-W4)

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Donnez votre avis
Utile
+0
plus moins
Re,

43048 correspond à la date d'aujourd'hui 09/11/2017

tu dois avoir un problème de formatage de tes cellules

peux tu anonymiser ton fichier et le mettre à notre disposition
1) Clic sur ce http://cjoint.com/
2) Clic sur Parcourir pour sélectionner ton fichier
3) Clic sur le bouton Créer le lien
4) Un lien en bleu souligné sera généré en haut de page, sélectionne clic droit "Copier"
5) reste plus qu'a le "Coller" dans une réponse avec quelques explications.
Donnez votre avis
Utile
+0
plus moins
Merci pour vos réponses, M-12/Mike-31/Vaucluse.

Je vais réussir a me débrouiller maintenant.

vous êtes au top !
Donnez votre avis
Utile
+0
plus moins
Re,

comme tu veux, alors je passe le statut de la discussion en résolu
geo34- 9 nov. 2017 à 11:27
vi, c'est bon merci
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !