Signaler

=SI(ESTNA(RECHERCHEV 3 feuilles [Résolu]

Posez votre question surplus 634Messages postés mardi 17 août 2010Date d'inscription 14 septembre 2017 Dernière intervention - Dernière réponse le 14 sept. 2017 à 23:50 par surplus
Bonjour,
j ai un soucis avec un fichier
je n arrive pas du tout a combiner la formule
=SI(ESTNA(RECHERCHEV
dans mon fichier je voudrais qu'en entrant un code couleur la reference s'affiche dans les 3 lignes en dessous provenant des trois autres feuilles "bombes","pinceaux","Stickers" référence se trouvant en colonne C.
Je vous joins mon fichier http://dl.free.fr/fk2dLe7EV
merci de votre aide
Utile
+0
plus moins
Bonjour,

Maintenant tu as sierreur qui évite de faire faire 2 fois le même calcul à excel.
=sierreur(ta_formule;"blabla sur erreur")
eric
surplus 634Messages postés mardi 17 août 2010Date d'inscription 14 septembre 2017 Dernière intervention - 11 sept. 2017 à 21:20
Bonjour
excuse moi mais j ai pas compris cela donnerait quoi concrètement dans mon cas
=SIERREUR(RECHERCHEV(C5;Stickers!$A$2:$C$44;2;3);0)
m affiche toujours 0
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonsoir à tous les deux

En C8 :
=SIERREUR(RECHERCHEV($C$5;bombes!$B$2:$C$124;2;FAUX);0)
En C9 :
=SIERREUR(RECHERCHEV($C$5;Pinceaux!$B$2:$C$140;2;FAUX);0)
et en C10 :
=SIERREUR(RECHERCHEV($C$5;Stickers!$B$2:$C$44;2;FAUX);0)

Bien mettre la cellule C5 en Format Texte de même que les colonnes B des feuilles suivantes

Cdlmnt
Via

surplus 634Messages postés mardi 17 août 2010Date d'inscription 14 septembre 2017 Dernière intervention - 11 sept. 2017 à 22:03
bonsoir
merci ça marche impec
Cdlmt
Répondre
Donnez votre avis
Utile
+0
plus moins
bonsoir
excusez moi mais je réfléchis après
Pourquoi ça affiche les données de la colonne C ?
qu'est ce qui le défini? dans la formule on a
=sierreur(recherchev($c$5;bombes!$b$2:$c$124;2;FAUX);0)
en fait la colonne A:A NE NOUS SERT à rien on part des données colonne B mon erreur était de prendre la plage A:C
si j ai bien compris
Donnez votre avis
Utile
+0
plus moins
Oui tout a fait, on fait une recherche dans la matrice $b$2:$c$124 (la recherche se fait toujours dans la 1ere colonne de la matrice) et on renvoie la valeur de la Xeme colonne comportant lesdonnées que l'on cherche (ici la 2, donc C)

surplus 634Messages postés mardi 17 août 2010Date d'inscription 14 septembre 2017 Dernière intervention - 11 sept. 2017 à 23:19
bonsoir
bien compris mon erreur
Merci encore
Répondre
surplus 634Messages postés mardi 17 août 2010Date d'inscription 14 septembre 2017 Dernière intervention - 14 sept. 2017 à 23:50
bonsoir
excuse moi de te relancer mais j ai un soucis que je ne comprends pas du tout
j ai changé mon tableau ca fonctionne bien j ai mis mes données de référence en colonne "A" au lieu de "B" avant ce qui me donne
=SI(C5="";"";SIERREUR(RECHERCHEV($C$5;bombes!$A$2:$B$581;2;FAUX);"Non fournie"))
cela affiche les données qui sont en colonne "B"
ma question pourquoi en marquant
=SI(C5="";"";SIERREUR(RECHERCHEV($C$5;bombes!$A$2:$B$581;3;FAUX);"couleur inconnue"))
je n obtiens pas les valeurs en colonne "C"?
je tourne en rond je ne vois pas du tout le problème
merci
j ai trouve désolé
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !