Calcule a partir de plusieurs tarif [Résolu]

florence17 - 11 sept. 2017 à 18:44 - Dernière réponse :  florence17
- 13 sept. 2017 à 09:06
Bonjour,
je suis voudrais faire un tableau mais je bloque sur une formule avec des heures

voici : de 1h à 7h56 le tarif est 2.65€
de 7h56 à 9h le tarif est 2.68€
de 9h à 10h le tarif 3.01€
de 10 h à 11h le tarif 3.35€
de 11h à 12h le tarif 3.68€
au dela de 12h le tarif 4.02€
et je voudrais que le prix s'affiche automatiquement en fonction des heures faitent
merci pour votre aide


Afficher la suite 

14 réponses

Répondre au sujet
fabien25000 265 Messages postés mercredi 5 octobre 2016Date d'inscription 16 octobre 2017 Dernière intervention - 11 sept. 2017 à 18:55
0
Utile
1
Bonjour,
Vous pouvez partager votre fichier anonymisé et sans données confidentielle avec votre travail déjà réalisé et le résultat attendu et les explications qui vont avec sur cjoint.com -> créer un lien -> le copier et le coller ici
merci beaucoup mais j'ai fini par trouver voici se que je voulez désolé de mettre mal exprimer
=SI(ET(K11<7,96;K11>=0,01);2,65;SI(ET(K11<9;K11>=7,96);2,68;SI(ET(K11<10;K11>=9);3,01;SI(ET(K11<11;K11>=10);3,35;SI(ET(K11<12;K11>=11);3,68;SI(K10>=12;4,02;"-"))))))
Commenter la réponse de fabien25000
via55 8931 Messages postés mercredi 16 janvier 2013Date d'inscription 16 janvier 2018 Dernière intervention - 11 sept. 2017 à 18:59
0
Utile
7
Bonjour

Est ce que le tarif est conditionné par l’heure de départ ou bien si 2 tarifs peuvent s’appliquer en même temps exemple arrivée à 7 h et sortie à 9h application des 2 premiers tarifs ?

Ce serait bien de poster un exemple de ton fichier excel sur cjoint.com, faire créer un lien le copier et revenir le coller ici

Cdlmnt
Via


florence17 > via55 8931 Messages postés mercredi 16 janvier 2013Date d'inscription 16 janvier 2018 Dernière intervention - 11 sept. 2017 à 19:13
le montant doit apparaître dans la colonne L11 dans indemnité entretien merci beaucoup
via55 8931 Messages postés mercredi 16 janvier 2013Date d'inscription 16 janvier 2018 Dernière intervention > florence17 - 11 sept. 2017 à 19:16
OK mais pour l'exemple que tu donnes arrivée 9h départ 19 h quel est le tarif applicable ? 3,53 ?
florence17 > via55 8931 Messages postés mercredi 16 janvier 2013Date d'inscription 16 janvier 2018 Dernière intervention - 11 sept. 2017 à 19:19
oui
pour 10 h de travail on applique 3.35€
florence17 > florence17 - 11 sept. 2017 à 19:53
http://www.cjoint.com/c/GIlrZGGdPS4
Commenter la réponse de via55
Raymond PENTIER 44834 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 16 janvier 2018 Dernière intervention - 11 sept. 2017 à 19:09
0
Utile
Bonjour.

Faire un tableau des tarifs :
     A        B
1 01:00 0,00
2 07:56 2,65
3 08:59 2,68
4 09:59 3,01
5 10:59 3,35
6 11:59 3,68
7 4,02

Saisie de l'heure en D1, tarif correspondant en E1 avec la formule
=SI(D1<A1;B1;SI(D1<A2;B2;SI(D1<A3;B3;SI(D1<A4;B4;SI(D1<A5;B5;SI(D1<A6;B6;B7))))))
Commenter la réponse de Raymond PENTIER
Vaucluse 21041 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 16 janvier 2018 Dernière intervention - 11 sept. 2017 à 19:59
0
Utile
Bonjour
une première approche ici, mais qui, pour le moment ne traite le sujet que si l'heure de début et plus petite que l'heure de fin.

(c'est à dire qu'en cas de chevauchement avec cette option, il faudrait créer une ligne pour avant 24:00 et une ligne pour après)

Si ce n'est pas possible comme ça, il faudra creuser un peu plus (et même beaucoup)

https://mon-partage.fr/f/vcttQ0Xs/

revenez si besoin

crdlmnt
Commenter la réponse de Vaucluse
via55 8931 Messages postés mercredi 16 janvier 2013Date d'inscription 16 janvier 2018 Dernière intervention - 11 sept. 2017 à 20:33
0
Utile
Re,

Ton fichier en retour :
http://www.cjoint.com/c/GIlsA5oHRh2

Un tableau en feuille2 donne le tarif suivant les heures (si les tarifs changent il n'y a qu'à modifier ce tableau et pas les formules)
Une RECHERCHEV vient chercher le bon tarif dans le tableau

Amélioration apporté à ta 1ere feuille pour qu'elle soit adaptable automatiquement :
En H9 on rentre le 1er jour du mois, ici 01/09/17, le format personnalisé de la cellule l'affiche en texte
Dans la colonne B la 1ere cellule reprend cette date mais l'affiche en quantième de mois. Les cellules suivantes incrémente de 1 les dates (formule plus complète à partir du 29 pour ne rien afficher si on dépasse le mois en cours)
La colonne A reprend les mêmes dates qu'en B mais avec affichage du jour en texte

Une mise en forme conditionnelle colore en bleu les lignes des samedis et dimanches

Cdlmnt
Via
Commenter la réponse de via55
Commenter la réponse de florence17