[Résolu] Lien symbolique DD externe vers /var/www/html. [Résolu]

Eito79 6 Messages postés samedi 12 août 2017Date d'inscription 21 septembre 2017 Dernière intervention - 12 août 2017 à 14:48 - Dernière réponse : zipe31 35174 Messages postés dimanche 7 novembre 2010Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention
- 13 août 2017 à 08:31
Bonjour,



Voila déja plusieurs jours, que je cherche en vain a mettre mes fichiers d'app web sur mon disque dur externe pour bosser dessus.

Seulement a chaque fois que j'essaie d'afficher la page via http://127.0.0.1, apache ne trouve ni le lien symbolique que j'ai fait :

ln -s /media/user/dd-externe/www-dev /var/www/html/www-dev


et quand je rentre directement l'adresse dans la navigateur (http://127.0.0.1/www-dev) je me retrouve avec une belle erreur 403 FORBIDDEN.
J'ai regardé pas mal de topic qui traite du sujets, mais soit ils sont trop vieux, soit cela ne fonctionne pas.
J'ai tenter également le tuto concernant l'ajout d'un répertoire avec lamp. Cela ne fonctionne pas...
J'ai tenter la configuration avec un virtualhost: idem
J'ai tenter la configuration avec des alias : idem.
J'ai tenter de faire en modifiant directement le fichier apache2.conf et d'ajouter une directory : idem (Je precise que l'option FollowSymLinks est activée)
J'ai tenter en mettant les droits a www-data sur mon DD-Externe : idem (Que ce soit en graphique ou avec chown) (Que ce soit a la racine du lien symbolique ou sur le lien lui même).
J'ai tenter même des chmod 777 pour voir si sa allais fonctionner : nada.


Forbidden

You don't have permission to access /www-dev) on this server.
Apache/2.4.18 (Ubuntu) Server at 127.0.0.1 Port 80



Du coup je suis un peu bloqué la et j'aimerais bien un coup de main. Si vous avez des idées je suis preneur.


Résolu, j'appliquais un chmod sur => /media/user/dd-externe <= depuis le début alors qu'il fallait le faire sur /media/user.
Afficher la suite 

1 réponse

Répondre au sujet
zipe31 35174 Messages postés dimanche 7 novembre 2010Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 13 août 2017 à 08:31
0
Utile
Salut,

Merci du retour.

Je recopie ta solution ici pour que ce soit plus clair :
Résolu, j'appliquais un chmod sur => /media/user/dd-externe <= depuis le début alors qu'il fallait le faire sur /media/user.


PS. Je réponds aussi histoire de pouvoir passer le post en résolu, sinon sans aucune réponse ce n'est pas possible ;-)
Commenter la réponse de zipe31