Signaler

Savoir si une colonne à fin variable est pleine [Résolu]

Posez votre question mod77 1190Messages postés vendredi 10 juillet 2009Date d'inscription 21 juin 2017 Dernière intervention - Dernière réponse le 14 juin 2017 à 09:20 par mod77
Bonjour,

J'ai une colonne qui se remplie petit à petit avec des chiffres.
Je sais que j'attends N remplissages grâce au nombre N en "A4".

J'ai essayé la fonction NBVAL sur la feuil mais je ne sais pas comment indiquer la fin de la colonne.

nbval(P3, Q6: (Q6+[A4]))


et lorsque j'atteins "0" alors je dois mettre en vert le fond de O3 et marquer "Terminé!"

Quelqu'un peut-il m'aider svp?



Savoir dire NON est un devoir et une force! N'ayez pas peur! L'union fait la force!

Passez en résolu si ça l'est!
Afficher la suite 
Utile
+0
plus moins
bonsoir,
si je comprends bien, tu veux détecter que le nombre de chiffres d'une cellule, disons Q6, est au moins égal à la valeur d'une autre cellule, disons A4.
je suggère, pour commencer, de mettre la formule suivante dans une autre celulle, et que tu vérifies ce qui se passe quand tu remplis Q6:
=SI(Q6>=10^(A4-1);"rempli";"...")
mod77 1190Messages postés vendredi 10 juillet 2009Date d'inscription 21 juin 2017 Dernière intervention - 13 juin 2017 à 20:58
c'est une matrice dont je connais le nombre de remplissage final. Il est indiqué en A4.
le nombre de case vide est compté puisqu'au fur et à mesure il diminue jusqu'à zéro.
Et quand il est à zéro le message "Terminé" s'affiche
Répondre
mod77 1190Messages postés vendredi 10 juillet 2009Date d'inscription 21 juin 2017 Dernière intervention - 13 juin 2017 à 21:05
j'ai tenté ceci en" P3" et ça a l'air de fonctionner:
=A4-NBVAL(Q6:Q13)

Ensuite je mets une mise en forme conditionnelle pour passer en vert quand il y a zéro.
Répondre
mod77 1190Messages postés vendredi 10 juillet 2009Date d'inscription 21 juin 2017 Dernière intervention - 13 juin 2017 à 22:44
j'ai fait ceci:

=SI(A4-NBVAL(Q6:Q156)=0;"Terminé !";A4-NBVAL(Q6:Q156))


mais j'ai eu une fois seulement, un message comme quoi " il y a redondance d'une formule dans une formule" ou "appelle d'une fonction dans une autre" , je ne sais plus vraiment mais ensuite excel s'est fermé et là ça m'iquiète.

Est-ce que cela peut venir de ma ligne de code ci-dessus, svp?
Répondre
yg_be 2545Messages postés lundi 9 juin 2008Date d'inscription 22 juin 2017 Dernière intervention - 14 juin 2017 à 07:46
je ne vois rien d’inquiétant dans la formule.
Répondre
mod77 1190Messages postés vendredi 10 juillet 2009Date d'inscription 21 juin 2017 Dernière intervention - 14 juin 2017 à 09:20
D'accord! merci yg_be.

Puis-je avoir ton avis aussi sur cette question
"Sélection par default d'un bouton de commande activX" stp?

merci
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !