Menu

Créer un tableau à partir de deux dates [Résolu]

Scratina - 17 mai 2017 à 14:43 - Dernière réponse :  Scratina
- 18 mai 2017 à 13:45
Bonjour,

J'ai cherché sur le forum mais n'ai pas trouvé de réponse à ma question.

J'aimerais créer un tableau automatiquement à partir de deux dates. Je m'explique : j'entre la date de début de mon évènement en F1 et celle de fin en H1. J'aimerais qu'Excel crée automatiquement un tableau avec le nombre de ligne correspondant (une ligne pour un jour).
Exemple : j'entre le 17/05/17 en F1 et le 25/05/17 en H1. J'aimerais qu'Excel écrive 17/05/17 en A2, 18/05/17 en A3... jusqu'à 25/05/17 en A10. Et si on pouvait enlever les dimanches, ce serait la cerise sur le gateau !

Merci pour votre aide
Afficher la suite 

5 réponses

Répondre au sujet
michel_m 15040 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 23 février 2018 Dernière intervention - Modifié par michel_m le 17/05/2017 à 16:06
0
Utile
Bonjour

en A2
=F1
en B2
=SI(LIGNE()<=H$1-F$1+2;A2+1;"")
à tirer vers le bas

https://mon-partage.fr/f/m9VlxpCn/

 Michel
Commenter la réponse de michel_m
0
Utile
1
Merci pour votre réponse rapide !
ça a marché, merci beaucoup :)
Pas moyen d'enlever les dimanches du coup ?
michel_m 15040 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 23 février 2018 Dernière intervention - 18 mai 2017 à 09:09
Pas moyen d'enlever les dimanches du coup ?

Oups! j'avais oublié : je regarde tout à l'heure
Commenter la réponse de Scratina
michel_m 15040 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 23 février 2018 Dernière intervention - Modifié par michel_m le 18/05/2017 à 11:08
0
Utile
1
Mine de rien, le dimanche était piégé! ;o)

mettre la colonne au format "date"
en A2
=SI(JOURSEM(F1)=1;F1+1;F1)
en A3
=SI(A2="";"";SI(A2+1>H$1;"";SI(JOURSEM(A2+1)=1;A2+2;A2+1)))
à tirer vers le bas

la bête:
https://mon-partage.fr/f/9He68CUV/

 Michel
Merci beaucoup, ça marche impec' !
Commenter la réponse de michel_m