Signaler

Recherche d'un mot dans une liste et affichage de celui-ci

Posez votre question andykx - Dernière réponse le 17 févr. 2017 à 09:07 par michel_m
Bonjour,

Alors voila mon problème, j'ai réalisé sous excel un système permettant de chercher dans une liste de mots définie un mot en particulier et regarder si ce mot est présent dans chaque phrase de mon fichier excel.

Voici ma fonction pour exemple :

=SUMPRODUCT((COUNTIF(A1;"*"&$F$1:$F$8&"*"))*1)

Cependant je n'arrive pas à afficher le mot que je trouve dans ma phrase dans une cellule sous excel, donc peut-être serait-il plus simple de le faire en VBA ? Je ne m'y connais pas du tout donc j'aimerais un peu d'aide.

J'espère que vous m'aurez compris, merci.

Cordialement.
Afficher la suite 
Utile
+0
moins plus
Bonjour

par formule

le mot cherché en A1

la phrase en C2
=NB.SI(C2;"*" & A1 &"*")

andykx- 16 févr. 2017 à 08:53
Je ne comprend pas pourquoi vous m'indiquez cela ?

Mon code qui est en haut fonctionne très bien, cependant je ne sais pas comment afficher le mot qui est trouvé dans une cellule, mon véritable problème est ici.

Merci quand même ! ;)
Répondre
Donnez votre avis
Utile
+0
moins plus
Bonjour le fil, bonjour le forum,

Moi ce que je n'ai pas compris c'est le mot afficher. Qu'est-ce que tu veux dire ? Le mettre en évidence (gras, couleur différente) ? la phrase (cellule ou ligne) entière ? le mot uniquement ?
Pas très clair tout ça...
Après, une solution VBA est envisageable mais en sachant où se trouvent les données avec précision.
andykx- 16 févr. 2017 à 09:38
Bonjour ThauTheme,

Ce que je veut dire par afficher c'est que lorsque je trouve le mot dans la cellule ou se situe ma phrase, il me renvoie 1 dans la cellule à droite de la phrase, cependant ce que j'aimerais c'est qu'il me renvoie le mot qu'il à trouvé dans la phrase.

J'espère avoir été clair je ne sais pas comment faire plus simple.
Répondre
Donnez votre avis
Utile
+0
moins plus
Re et bonjour Thautheme

Peut -^tre + clair quand m^me....

tu as une liste de mots dans peut-^tre F1:F8 (?)

et dans une cellule comportant une phrase t'aimerais afficher le mot de ta liste présent dans la phrase ?

andykx- 16 févr. 2017 à 11:41
Oui c'est exact j'ai une liste dans F1:F8.

Oui voila c'est ça.
Répondre
Donnez votre avis
Utile
+0
moins plus
Avec une fonction personnalisée
Option Explicit
'-------
Function afficher_mot(liste As Range, phrase As String)
Dim separe, cptr As Byte
separe = Split(phrase)
For cptr = 0 To UBound(separe)
If Application.CountIf(liste, "*" & separe(cptr) & "*") > 0 Then
afficher_mot = separe(cptr)
Exit Function
End If
Next
afficher_mot = ""
End Function


la maquette de W
https://mon-partage.fr/f/XUdbR0GL/
Donnez votre avis
Utile
+0
moins plus
BRAVO DE CREER DES DOUBLONS POUR LA MEME QUESTION !

TRISTE MENTALITE

Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !