Remise octroyée [Résolu]

peps - 10 janv. 2017 à 15:29 - Dernière réponse : ccm81 8202 Messages postés lundi 18 octobre 2010Date d'inscription 11 décembre 2017 Dernière intervention
- 11 janv. 2017 à 12:24
Bonjour,

Pourriez vous m'éclairez je bloque sur cette formule
Une remise est octroyée :
si le nombre de jour de location est inférieur à 15 jours aucune remise
si le nombre de jour est compris entre 15 jour et 45 jours remise de 4%
si le nombre de jour est compris entre 45 et 60 jours remise de 7%
si le nombre de jour est supérieur à 60 jours remise de 10%

Merci

Cordialement

Afficher la suite 

7 réponses

Répondre au sujet
PHILOU10120 4706 Messages postés lundi 16 avril 2012Date d'inscription 11 décembre 2017 Dernière intervention - 10 janv. 2017 à 17:01
0
Utile
2
Bonjour Peps

Essayer cette formule en A1 le nombre de jours du séjour à tester

=SI(A1<=15;0;SI(ET(A1>15;A1<=45);4%;SI(ET(A1>45;A1<=60);7%;10%)))
Utilisateur anonyme - 10 janv. 2017 à 23:10
 
Bonjour Philou,

Dans ta formule, il ne faut pas mettre à chaque fois les 2 bornes d'un intervalle,
et c'est facile de l'éviter (voir mon message #3) ! Donc tu ne dois pas mettre :

a) ET(A1>15;A1<=45)
b) ET(A1>45;A1<=60)

Cordialement.  :)
 
PHILOU10120 4706 Messages postés lundi 16 avril 2012Date d'inscription 11 décembre 2017 Dernière intervention > Utilisateur anonyme - 11 janv. 2017 à 08:23
Bonjour Albkan

Le résultat du calcul est-il bon ? donc c'est le but avoir une réponse exacte.
Dans Excel il y a souvent plusieurs possibilités pour arriver au résultat
Parfois j'oublie d'optimiser le calcul, mais il n'y a pas de quoi en faire un fromage
Le but du site est d'apporter de l'aide pas de polémiquer.
Chacun reste libre de faire à sa manière, toutes les idées sont bonnes à exploiter.
Rien ne vous empêche de faire d'autres propositions.
Commenter la réponse de PHILOU10120
ccm81 8202 Messages postés lundi 18 octobre 2010Date d'inscription 11 décembre 2017 Dernière intervention - Modifié par ccm81 le 10/01/2017 à 17:48
0
Utile
2
Bonjour

Essaies ceci
=SI(A2<=15;0;SI(A2<=45;4%;SI(A2<=60;7%;10%)))

RQ. La situation peut être vue autrement
Par exemple pour 30j on pourrait faire
0% sur les 15 premiers et 4% sur les 15 suivants
etc ...
ça permettrait d'avoir un montant continu
C'est à toi de voir

Cdlmnt
Utilisateur anonyme - 10 janv. 2017 à 23:26
 
Bonjour ccm81,

L'énoncé indique : « inférieur à 15 jours » et pas « inférieur ou égal à 15 jours ».
Alors pourquoi as-tu mis A2<=15 ?

Suite à la 1ère condition, il faut comprendre ainsi les autres conditions :

a) compris entre 15 jours inclus et 45 jours exclu
b) compris entre 45 jours inclus et 60 jours exclu
c) supérieur ou égal à 60 jours => 60 jours inclus

Cordialement.  :)
 
ccm81 8202 Messages postés lundi 18 octobre 2010Date d'inscription 11 décembre 2017 Dernière intervention - 11 janv. 2017 à 12:24
> albkan
la demande
si le nombre de jour de location est inférieur à 15 jours aucune remise
si le nombre de jour est compris entre 15 jour et 45 jours remise de 4%

pour moi, laisse planer un doute
si tu lis inférieur à 15 jours on a bien < 15 OK
mais
compris entre 15 jours et 45 jours ça donnerait selon ton interprétation 15 < x < 45,
(il n'y a pas d'entier compris entre 2 et 3 si mes souvenirs sont bons) sinon il y aurait écrit de 15 à 45 jours (éventuellement compris)
Donc, les < ou <= sont laissés à l'appréciation du demandeur

Cdlmnt
Commenter la réponse de ccm81
Utilisateur anonyme - 10 janv. 2017 à 21:11
-3
Utile
Bonjour peps,

Si tu as en A1 ton nombre de jours de location, mets par exemple
en B1 cette formule pour le calcul de ta remise :

=A1*SI(A1<15;0;SI(A1<45;4;SI(A1<60;7;10)))%

Cordialement.  :)
Commenter la réponse de Utilisateur anonyme