Signaler

Table de routage sur routeur [Résolu]

Posez votre question beny - Dernière réponse le 25 nov. 2016 à 09:37
Bonjour,

J’essaye de configurer ma table de routage sur mon routeur, mais je dois oublier quelque chose.
Mon routeur doit faire le lien entre un routeur web et mon réseau local.
Sur mon routeur, j’ai deux interfaces : int0(10.0.0.254) et int1(192.168.1.254)

int0 est relié au routeur web et int1 est relié à mon réseau local.
Le routeur web a une ip 172.16.0.254

J’ai défini les routes statiques ainsi :
Destination | next-hop | interface
0.0.0.0 | 172.16.0.254
192.168.1.0 | | int1
10.0.0.0 | | int0
0.0.0.0 |10.0.0.254

D’une machine sur le réseau local, je fais un ping sur int1 et int0 sans aucun problème.
Du routeur je fais un ping sur int0 et int1 sans aucun problème non plus.
Par contre avec une machine locale impossible d’atteindre l’interface du routeur web et je n’arrive pas à aller sur le net.

Quelle route statique je devrais rajouter pour aller sur le web ?

Merci
Afficher la suite 
Utile
+1
moins plus
Salut,
c'est mal parti,
il faut que les routeurs soient reliés par un lien dans le même réseau IP sur les deux, sauf si c'est un lien point à point, auquel cas, on peut router sur l'interface directement.
Donc il faut changer l'adresse sur int0 pour la mettre dans le même réseau que 172.16.0.254 (172.16.0.253 par exemple) si le réseau est 172.16.0.0/24 au lieu de 10.0.0.254
il faudra aussi une route du même genre inversée dans l'autre sens.

Ajouter un commentaire
Utile
+0
moins plus
Salut,
Après modification de l’interface int0 en 172.16.0.253, j’ai modifié la table de routage :
Destination | next-hop | interface
0.0.0.0 | 172.16.0.254
0.0.0.0| 172.16.0.253
0.0.0.0| 192.168.1.254
172.16.0.0| | int0
192.168.1.0 | | int1

Depuis mon routeur, j’ai fait des ping :
Routeur -> 192.168.1.254 c’est ok
Routeur -> 172.16.0.253 c’est ok
Routeur -> 172.16.0.254 c’est ok
Routeur -> ip de google c’est ok

Depuis un PC connecté sur int1, les ping :
PC -> 192.168.1.254 c’est ok
PC -> 172.16.0.253 c’est ok
PC -> 172.16.0.254 ce n’est pas ok
PC -> ip de google ce n’est pas ok
Sur la config du PC, j’ai mis une IP fixe avec comme passerelle int1(192.168.1.254) et les DNS donnés par le fournisseur.
Si je passe l’IP du PC en 172.16.0.x et que je connecte via un switch sur int0, tout fonctionne.

Je ne vois toujours pas quelle route j’ai oubliée…
Une idée ?
Merci
brupala 65847Messages postés lundi 16 juillet 2001Date d'inscription ModérateurStatut 8 décembre 2016 Dernière intervention - 24 nov. 2016 à 14:43
0.0.0.0 | 172.16.0.254
OK route par défaut normale
0.0.0.0| 172.16.0.253
A supprimer une seule route par défaut
0.0.0.0| 192.168.1.254
A supprimer une seule route par défaut, en plus c'est faux

172.16.0.0| | int0
192.168.1.0 | | int1

OK Connexions directes.
Après,
Est ce que ton routeur internet connait la route vers 192.168.1.0/24 ?
il faut qu'il sache le joindre,
ou alors, pas de route et tu fais du nat dans ton routeur, auquel cas, le routeur internet verra le réseau 192.168.1.0/24 en 172.16.0.253
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bizarrement, pour la route 0.0.0.0| 192.168.1.254 si je l'enlève, depuis le routeur, je ne peux plus pinger l'adresse ip de google. Cela m'a étonné: mettre cette route pour pouvoir pinger une ip externe.

Bref, je vais tenter un NAT car je n'ai pas la main sur le routeur distant.
A suivre
brupala 65847Messages postés lundi 16 juillet 2001Date d'inscription ModérateurStatut 8 décembre 2016 Dernière intervention - 24 nov. 2016 à 15:03
ça ne tient pas debout en effet ...
Surtout que l'info est fausse.
Tu es sur que tu n'inverses pas lan et wan ?
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Je te confirme que lorsque je supprime la route 0.0.0.0| 192.168.1.254, je ne peux plus pinger l'ip de google.
Peut être que cela vient de mon routeur(exotique ?!) ou du routeur distant...

Pour la solution, j'ai mis en place le NAT en IP Masquerading et ca fonctionne parfaitement. J'ai supprimé la fameuse route et je n'ai gardé que les 3 routes initiales.

Pouce en l'air pour Brupala :)
Merci
brupala 65847Messages postés lundi 16 juillet 2001Date d'inscription ModérateurStatut 8 décembre 2016 Dernière intervention - 25 nov. 2016 à 09:37
Vraiment exotique ton machin ... :-(
Je passe en résolu.
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !