Posez votre question Signaler

Connexion internet machine virtuelle VMWare

jc44 1Messages postés vendredi 25 novembre 2005Date d'inscription 27 avril 2007Dernière intervention - Dernière réponse le 13 oct. 2008 à 10:15
Bonjour.
J'ai installé VMWare sur un PC sous XP en réseau qui utilise un proxy distant (avec authentification login/pwd) pour se connecter à internet.
Paramètre de la vrai carte réseau du host (XP)
IP de la machine Host (XP) = 192.168.1.8
masque sous-réseau= 255.255.255.0
passerelle = 192.168.1.33
Proxy distant pour la connexion internet : "proxy.ftcom.com" avec identification "moncompte@masoc.fr" et pwd
Puis j'ai crée une machine virtuelle Linux (Ubuntu) hébergé sur ce PC XP.
Je ne souhaite pas que le machine virtuelle utilise une adresse IP du réseau et donc j'ai paramétré l'ethernet de la machine virtuel en "Host-Only" (j'ai aussi essayé en "NAT").
Je ne sais pas si ce que je veux faire est possible.
En mode "Only-Host" (interface réseau virtuel VMnet1):
J'ai installé "FreeProxy" sur le XP afin que la VM Ubuntu puisse utiliser la connexion net du XP (rappel : cette dernière passe par un proxy externe "proxy.ftcom.com" avec identification "moncompte@masoc.fr" et pwd).
A partir de ma VM Ubuntu, j'arrive à pinguer le host et ceci aussi bien avec son adresse IP de l'interface VMnet1 (192.168.61.1) qu'avec son IP de sa carte réseau réel (192.168.1.8).
J'ai paramétré le réseau de la VM Ubuntu avec:
adresse IP= 192.168.61.10
masque sous-réseau= 255.255.255.0
passerelle=192.168.61.1 (= IP de l'interface VMnet1)
Quant à FireFox, je l'ai paramétré en définissant manuellement le proxy 192.168.61.1 (= IP de l'interface VMnet1)
Le problème c'est que quand je lance FireFox sous Ubuntu j'ai le message d'erreur comme quoi le proxy a refusé la connexion.
Je ne suis pas sûr de ma config de "FreeProxy".
J’ai paramétré "FreeProx" de la manière suivante (est-ce correct ?):
Local binding = IP réseau XP (192.168.1.8)
Remote binding= IP interface VMnet1 (192.168.61.1)
Proxy server = proxy.ftcom.com (mais je ne vois pas où indiquer le code user et pwd !!!)
En mode "Nat" (interface réseau virtuel VMnet8) :
FreeProxy ne serait pas nécessaire.
L’interface réseau virtuel VMnet8 à l’adresse ip 192.168.159.1
J’ai paramétret la VM Ubuntu ainsi :
IP=192.168.159.10
Masque=255.255.255.0
Passerelle= rien puis même ip que celle de la vrai carte réseau du host sous XP (192.168.1.33)
Résultat : j’arrive à pinguer l’ip de l’interface VMnet8 (192.168.159.1) mais pas l’ip réel du host (192.168.1.78  network unreachable)
Quand à FireFox je lui ai dis d’utiliser la proxy externe (proxy.ftcom.com) mais il dit qu’il ne le trouve pas.
N’étant pas calé en réseau, n’hésitez pas à m’apporter vos lumières…
Lire la suite 
Réponse
+5
moins plus
Bonjour,

ton proxy ne serait pas regle pour n'autoriser qu'une plage d'adresse IP à l'utiliser? Ce qui expliquerait qu'il te refuse la connexion en "host only".
Ajouter un commentaire
Annonces
 
moins plus
Ce document intitulé «  Connexion internet machine virtuelle VMWare  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.