Posez votre question Signaler

[Debian, mySQL] Mot de passe root :s

jalfr 17Messages postés samedi 20 janvier 2007Date d'inscription 11 novembre 2007 Dernière intervention - Dernière réponse le 3 avril 2007 à 20:46
Bonjour à tous!
Voila mon souci: je ne connais pas le mot de passe root de mySQL et je n'arrive donc pas à me connecter à mysql via le shell ou phpmyadmin...
cause: DirectAdmin n'a pas référencé le mot de passe mysql dans ses fichiers de config -_-
Est-ce que quelqu'un sait comment soit changer le mot de passe de "root" ou soit créer un nouvel utilisateur qui a tout les privilièges ??
Merci d'avance! (bon app aussi!)
Julien
Lire la suite 
Réponse
+1
moins plus
Si tu vois quelque chose de genre
lami20j@debian:~$ mysql -u root -p
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 15 to server version: 5.0.21-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>
alors c'est bon tu es connecté
il te reste à établir un mot de passe (tu dois taper ce qui est en gras)
mysql> set password for root@localhost=password('***********************');
--
lami20j
Ajouter un commentaire
Réponse
+1
moins plus
Salut,
apt-get install mysql-server
--
lami20j
Ajouter un commentaire
Réponse
+1
moins plus
Bonsoir!

l'installe de mysql-server ne change rien :s
Je vais réinstaller le serveur je crois, ça ira plus vite et ça sera plus simple... mais bon l'avoir régler sans en arriver là aurait donner + d'expérience...

Mais bon... tant pis! Merci à tous pour votre aide!!

bonne soirée,
Julien.
Ajouter un commentaire
Réponse
+0
moins plus
Salut,

Lire la doc officielle...

;-))
Ajouter un commentaire
Réponse
+0
moins plus
Salut,

tape
mysql -u root -p

quand le mot de passe sera demander ne saisie rien, appuie sur la touche Entrer pour voir
Ajouter un commentaire
Réponse
+0
moins plus
Re!

Merci pour vos réponses!

Quand j'éxécuter: "mysql -u root -p"
J'ai: "ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)"
Ajouter un commentaire
Réponse
+0
moins plus
regarde ici galere a n en plus finir avec l acces a mysql#11
Ajouter un commentaire
Réponse
+0
moins plus
Re!

Merci lami20j!
J'ai néanmois un petit souci:

Lorsque je fais:

web1:~# mysqld_safe --skip-grant-tables --skip-networking &
[1] 25200
web1:~# -bash: mysqld_safe: command not found


D'où vient ce "bash: mysqld_safe: command not found"

Désolé de vous poser toutes ces questions mais mysql c'est vraiment pas mon truc :s

Merci d'avance!
Ajouter un commentaire
Réponse
+0
moins plus
Pourtant mysqld_safe ce trouve dans ce paquet
De toute façon il faut retenir la méthode puisqu'elle te permettra la connexion si jamais le mot de passe est perdu.

fait un apt-cache search mysql pour et installe tous les paquets
fait aussi un locate mysqld_safe pour voir
Ajouter un commentaire
Ce document intitulé «  [Debian, mySQL] Mot de passe root :s  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.