{Gentoo 2008] et le SON ! [Résolu/Fermé]

Signaler
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Bonjour,

j'ai suivi le tuto ci-dessous :
http://www.gentoo.org/doc/en/alsa-guide.xml

après installation de la Gentoo : pas de son !

gentoo ~ # uname -r
2.6.25-gentoo-r7
gentoo ~ #


ok !
mon USE dans le fichier /etc/make.conf :

USE="X ipv6 pam tcpd nls unicode dbus -gnome -kde hal startup-notification
-xcreensaver -debug -xprint python file-icons menu-plugin pcre trash-plugin cups -alsa -minimal -oss"

gentoo ~ # lspci -v | grep -i audio
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
gentoo ~ #


bon ben on install alsa :

gentoo ~ # emerge alsa-utils


on configure :

gentoo ~ # alsaconf


on règle les volumes :

gentoo ~ # alsamixer


adding ALSA to the boot runlevel :

gentoo ~ # rc-update add alsasound boot

la commande fonctionne mais je suis pas convaincu ....


mon user est bien dans le groupe "audio"
ok ! on install le plugin Adobe Flash Player !
ok ! un petit saut sur le site les zouzous de France 5 pour tester le son ! ok , ça marche !


quelques vérifs :
gentoo ~ # cat /proc/asound/cards
0 [SI7012 ]: ICH - SiS SI7012
SiS SI7012 with ALC655 at irq 18

gentoo ~ # cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.16rc2 (Thu Jan 31 16:40:16 2008 UTC).
gentoo ~ #


à faire : lecture d'un CD audio + installer logiciel (vlc, totem, etc ...) !
à voir : oss non installé !

9 réponses

Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
ok ! quelques messages d'erreur à propos d'oss :

redfox@gentoo ~ $ dmesg | grep oss
Modules linked in: snd_pcm_oss(+) snd_mixer_oss nvidia(P) snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm snd_timer snd snd_page_alloc sis900
[<f884b790>] snd_register_oss_device+0xf0/0x147 [snd]
[<f888a4d1>] register_oss_dsp+0x35/0x61 [snd_pcm_oss]
[<f888c470>] snd_pcm_oss_register_minor+0x2c/0x119 [snd_pcm_oss]
[<f8822075>] alsa_pcm_oss_init+0x75/0x80 [snd_pcm_oss]
[<f884b790>] snd_register_oss_device+0xf0/0x147 [snd]
[<f888a4d1>] register_oss_dsp+0x35/0x61 [snd_pcm_oss]
[<f888c470>] snd_pcm_oss_register_minor+0x2c/0x119 [snd_pcm_oss]
[<f8822075>] alsa_pcm_oss_init+0x75/0x80 [snd_pcm_oss]
ALSA sound/core/seq/oss/seq_oss.c:231: can't register device seq
redfox@gentoo ~ $


autre info :

redfox@gentoo ~ $ cat /proc/asound/oss/sndstat
Sound Driver:3.8.1a-980706 (ALSA v1.0.16rc2 emulation code)
Kernel: Linux gentoo 2.6.25-gentoo-r7 #1 SMP Sun Sep 21 12:10:27 CEST 2008 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
SiS SI7012 with ALC655 at irq 18

Audio devices:
0: SiS SI7012 (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
31: system timer

Mixers:
0: Realtek ALC655 rev 0
redfox@gentoo ~ $
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
gentoo log # /etc/init.d/alsasound restart
* WARNING: you are stopping a boot service.
* Storing ALSA Mixer Levels ... [ ok ]
* Killing processes using ALSA ... [ ok ]
* Unloading ALSA modules ... [ ok ]
* Loading ALSA modules ...
* Loading: snd-card-0 ... [ ok ]
* Loading: snd-mixer-oss ... [ ok ]
* Loading: snd-pcm-oss ... [ ok ]
* Loading: snd-seq-oss ...
FATAL: Error inserting snd_seq_oss (/lib/modules/2.6.25-gentoo-r7/kernel/sound/core/seq/oss/snd-seq-oss.ko): Device or resource busy [ ok ]
* Restoring Mixer Levels ... [ ok ]
gentoo log #

le truc rigolo : mozilla-firefox (version 2) s'est refermé d'un coup !!

bon j'arrête pour ce soir, @ suivre .....
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
ok ! en fait j'ai omis ceci :

(Assurez-vous qu'OSS est désactivé.)
Open Sound System   --->
   < > Open Sound System (DEPRECATED)

source : http://www.gentoo.org/doc/fr/alsa-guide.xml
probablement le pourquoi du message d'erreur !


MPLAYER ?
j'essaierai bien de compiler mplayer avec mencoder à partir des sources (comme ici) :
http://linuxhelp.150m.com/installs/mplayer.htm
ou alors, plus simplement :
http://gentoo-wiki.com/HOWTO_Emerge_MPlayer#Choosing_your_USE_flags

<EDIT : je savais bien que j'avais "étudié le son" sous la gentoo, ici :
http://www.commentcamarche.net/forum/affich 4592643 gentoo lecteur cd dvd son
EDIT>
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
arfff ! déjà tard pour m'attaquer au son ! N'anmoins, apparemment la recompilation semble avoir donné quelque chose de plus "propre" :
gentoo ~ # /etc/init.d/alsasound restart
 * WARNING:  you are stopping a boot service.
 * Storing ALSA Mixer Levels ...                                          [ ok ]
 * Killing processes using ALSA ...                                       [ ok ]
 * Unloading ALSA modules ...                                             [ ok ]
 * Loading ALSA modules ...
 *   Loading: snd-card-0 ...                                              [ ok ]
 *   Loading: snd-mixer-oss ...                                           [ ok ]
 *   Loading: snd-pcm-oss ...                                             [ ok ]
 *   Loading: snd-seq-oss ...                                             [ ok ]
 * Restoring Mixer Levels ...                                             [ ok ]
gentoo ~ # 


je me colle une discussion très intéressante :
[solved] snd_hda_intel: no sound
http://forums.gentoo.org/viewtopic-t-712287.html
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
102
je dis ça comme ça mais pourquoi dans ton make.conf t'as -alsa ?
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
pourquoi dans ton make.conf t'as -alsa ?

de quel fichier "make.conf" est-il question ?
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
102
ben dans les USE FLAGS de ton /etc/make.conf

-alsa en flag ça enlève le support alsa pour tout les paquets qui le tolèrent, t'as sans doute une bonne raison, mais je demande juste...
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
ben j'ai ceci :
redfox@gentoo ~ $ cat /etc/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /etc/make.conf.example for a more detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="-O2 -march=i686 -pipe"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="i686-pc-linux-gnu"
MAKEOPTS="-j2"
USE="X ipv6 pam tcpd nls unicode dbus -gnome -kde hal startup-notification 
-xcreensaver -debug -xprint python file-icons menu-plugin pcre trash-plugin cups alsa -minimal oss"
INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="nvidia"
FEATURES="ccache"
redfox@gentoo ~ $


je pense que c'est ok ! je ne suis pas spécialiste non plus !
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
102
oui c'est bon!

dans le 1er post tout en haut il y avait -alsa je me demandais pourquoi.

je pense que tout est OK dans ta config, le son fonctionne bien maintenant?
bob031
Messages postés
8214
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
455
dans le 1er post tout en haut il y avait -alsa je me demandais pourquoi

excellente remarque ! j'avais pas vu, d'ou ma question à propos de make.conf
pas la moindre idée du pourquoi -alsa -oss avant ! encore une question à me poser !

sinon comme indiqué dans un de mes posts suivants, le son semble fonctionner correctement (son ok via applicaton flash/firefox).
je n'ai pas encore essayé la lecture d'un CD audio, etc .....c'est la prochaine étape !

merci quand même !