INDEX EQUIV ou Recherchev [Résolu]

-
Bonjour,

Ma situation est : j'ai 3 feuilles dans mon tableau (base de donnée, feuille 1 et feuille 2). Dans ma base de donnée, j'ai 4 colonnes (matricule, utilisateurs, extrait, date). Dans ma base de donnée, j'ai plusieurs matricule identique mais a des dates différentes. Dans ma feuille 1, j'ai 3 colonnes (Matricule, Utilisateurs, Extrait) et une cellule qui contient une date en A1, je souhaiterai avoir l'extrait dédié à un numéro de matricule avec la date mentionné dans A1 uniquement. Pouvez vous m'aider svp !
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
24573
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2019
4824
1
Merci
Bonjour (et bonsoir Djidji)

un fichier serait effectivement le bien venu
En attendant on peut tenter, si bien sur, il n'y a pas deux fois le même matricule à la même date
base de données, Feuil1! ligne 2 à ligne 1000
  • colonne A matricule
  • colonne B utilisateurs
  • colonne C extrait
  • Colonne D date

feuille édition
  • en A1 date
  • en A2 matricule
  • en B2 pour trouver l'utilisateur:

=SIERREUR(RECHERCHEV(A2;Feuil1!$A$2:$D$1000;2;0);"")
  • en C2 pour trouver l'extrait à la date en A1:

=SIERREUR(INDEX(Feuil1!$C$2:$C$1000;EQUIV($A$1&A2;Feuil1!A$2:$A$1000&Feuil1!$D$2:$D$1000;0));"")

attention, formule matricielle à enter avec la touche enter en maintenant les touches ctrl et shift enfoncées
elle doit s'afficher automatiquement entre accolades dans la barre de formule
formule assez lourde, bien limiter les plages aux nombres de lignes utiles (ici 2 à 1000)
Note importante
sachant que Excel considère les dates comme des nombres à 5 chiffres, mieux vaut utiliser le nom (donc colonne B dans EQUIV au lieu de A) s'il y a risque de confusion avec les dates

crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62878 internautes nous ont dit merci ce mois-ci

SUPER ! ça marche, merci beaucoup pour votre aide !! si c'est pas trop vous demandez, je pourrais avoir une explication détaillée sur la construction de la formule ? j'aimerai en comprendre le sens. surtout la partie de la formule ou il y a &"-"&. j'aimerai connaitre son rôle dans la formule
Vaucluse
Messages postés
24573
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2019
4824 -
Base de la formule:

=INDEX(plage;N°de ligne dans la,plage;N°de colonne dans la plage)
le N° de colonne n'est pas utile si INDEX n'a qu'une colonne
fonction EQUIV(valeur; liste valeur;0)
ressort le N° de ligne dans la plage et donc dans notre cas, répond au besoin de INDEX avec la matricule
le 0 à la fin de la formule est un code fonctionnel Excel pour spécifier le type de recherche
Il y a ici des valeurs à coupler (matricule et date, pour ressortir le N° de ligne)
on couple donc le matricule avec la date pour aller chercher dans les colonnes qui, les contiennent en les couplant
le"_" est une précaution, car vous avez des matricules numériques, alors que la date que cherche Excel est aussi un nombre à 5 chiffres. Il peut donc y avoir des confusions
en couplant matricule&"_"&date, on sépare les deux pour éliminer le risque

pour mieux comprendre vous pouvez essayez de décomposer les items dans des cellules séparées:
=INDEX(colonne et entrez un N° de ligne)
=EQUIV(A2;BDD!A:A;0)
=A2&"_"&A1


J'espère avoir été assez clair, ce n'est pas très facile par mail

bonne soirée
Merci beaucoup !! oui c'est assez clair !! bonne soirée à vous et encore merci
Vaucluse
Messages postés
24573
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2019
4824 -
ok,
Vaucluse
Messages postés
24573
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2019
4824 -
ok, alors je passe le sujet enrésolu
Bonne route
crdlmnt
Commenter la réponse de Vaucluse
Messages postés
2485
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
11 octobre 2019
278
0
Merci
Bonjour,

Un fichier (test ou non), complété par des explications exhaustives, mis sur https://www.cjoint.com/ permettrait de répondre plus précisément à ta question


Crdmt
Bonjour,

voici le lien de mon tableau

https://www.cjoint.com/c/IJerlAvOSSL
En gros, je souhaite avoir l'extrait qui correspond à la matricule indiqué dans la colonne A11 et correspondant à la date indiqué dans a1, depuis la base de donné.
Commenter la réponse de DjiDji59430