Cumul de nombre impair

- - Dernière réponse : Raymond PENTIER
Messages postés
49850
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 septembre 2019
- 28 août 2019 à 22:27
Bonjour,

maintenant je voudrais indiquer le nombre de cellule impair dune ligne et afficher ce total dans la cellule
attenante la ligne de calcul; est ce possible sur plusieurs lignes?
merci pour vos réponses
Configuration: Windows / Edge 17.17134
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
2456
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
13 septembre 2019
272
1
Merci
Bonjour à tous,

Essaye
=SOMMEPROD(--(MOD(A1:H1;2)=1)) pour le résultat sur une plage A1:H1
que tu peux descendre sur plusieurs lignes.

A adapter suivant ta plage

Crdlmt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 60200 internautes nous ont dit merci ce mois-ci

je n arrive pas a faire trier
merci
bsr je n arrive pas a faire fonctionner
cordialement
Raymond PENTIER
Messages postés
49850
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 septembre 2019
10642 -
Trier quoi ? Faire fonctionner quoi ?

J'attire ton attention sur le fait qu'il y a DEUX signes moins accolés, devant MOD !
= S O M M E P R O D ( - - ( M O D ( A 1 : H 1 ; 2 ) = 1 ) )
Commenter la réponse de DjiDji59430
Messages postés
24377
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 septembre 2019
4759
0
Merci
Bonjour
en variante si le deux tirets ne fonctionnent pas:
=SOMMEPROD(( MOD(A1:H1;2)>0)*1)
mais en principe les deux fonctionnent
voir ici
https://mon-partage.fr/f/plS3Uvxl/
crdlmnt
super merci les gars pour le total des nombres impairs ça fonctionne super
maintenant si vous pouviez m'aider dans mon autre demande se serait super un grand merci d'avance
Vaucluse
Messages postés
24377
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 septembre 2019
4759 -
suffit de formuler la demande, dans un nouveau fil pour ne pas se perdre
Raymond PENTIER
Messages postés
49850
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 septembre 2019
10642 -
La fonction SOMME.PROD ne s'applique qu'à une seule plage à la fois.
Il te faudrait donc effectuer une addition ; c'est simple, mais ça peut devenir fastidieux s'il y a plusieurs dizaines (ou centaines, ou milliers) de lignes !
=SOMMEPROD(--(MOD(A1:H1;2)=1)) + SOMMEPROD(--(MOD(A2:H2;2)=1))+ SOMMEPROD(--(MOD(A3:H3;2)=1)) + SOMMEPR ...
Mais il est plus simple de recopier vers le bas la formule saisie en J1; puis de faire la somme de la colonne J ...
Commenter la réponse de Vaucluse