Calculer le montant des heures de travail selon un barème

- - Dernière réponse : PapyLuc51
Messages postés
2131
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 octobre 2019
- 3 juin 2019 à 08:18
Bonjour,

J'ai eu du mal à résumer ma question dans le titre mais je vais tâcher d'être plus clair...

A1 = heure de départ
A2 = heure de fin
A3 = total des heures
A4 = prix des heures

le barème est le suivant :
1ère heure = 30 euros
2ème heure = 25 euros
3ème heure = 25 euros
heures suivantes = 20 euros
puis l'autre difficulté c'est que je fonctionne au 1/4 d'heure.

Exemple : si j'ai travaillé pendant 4h15 ça coûtera = 30 + 25 + 25 + 20 + 20*0.25 = 105 euros

A votre avis, en A4 que devrai-je utiliser comme formule?

Je vous remercie d'avance et bon weekend!
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
2131
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 octobre 2019
429
1
Merci
Bonjour,

A1 et A2 au format heure hh:mm

Pour mieux calculer il faut que le total des heures soit en nombre décimal

en A3 au format nombre à deux décimales

=(A2*24)-(A1*24)

en A4 au format nombre à deux décimales

=SI(A3>0;SI(A3<=1;30*A3;SI(A3<=2;30+(25*(A3-1));SI(A3<=3;30+25+(25*(A3-2));SI(A3>3;30+25+25+(20*(A3-3));""))));"")

et si les tarifs sont inscrits dans des cellules à part par exemple K1=30 K2=25 K3=20

=SI(A3>0;SI(A3<=1;K1*A3;SI(A3<=2;K1+(K2*(A3-1));SI(A3<=3;K1+(K2*(A3-1));SI(A3>3;K1+(K2*2)+(K3*(A3-3));""))));"")

Cordialement

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62906 internautes nous ont dit merci ce mois-ci

Grand merci, la formule fonctionne parfaitement !
PapyLuc51
Messages postés
2131
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 octobre 2019
429 > Tony -
La question semble résolue alors!!!

Cordialement
PapyLuc51
Messages postés
2131
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 octobre 2019
429 > Tony -
Bonjour Tony

Petites rectifications sur mes formules que j'ai réduites

Pour éviter les nombres négatifs sur A3

=SI(OU(A1="";A2="");"";(A2*24)-(A1*24))

de ce fait pour éviter l'erreur #VALEURS sur A4

=SI(A3<>"";SI(A3<=1;30*A3;SI(A3<=3;30+(25*(A3-1));SI(A3>3;30+25+25+(20*(A3-3));"")));"")

=SI(A3<>"";SI(A3<=1;K1*A3;SI(A3<=3;K1+(K2*(A3-1));SI(A3>3;K1+(K2*2)+(K3*(A3-3));"")));"")

Comme tu peux le voir j'ai supprimer la condition A3<=2 qui ne sert à rien finalement puisque la deuxième et la troisième heure sont au même prix

Cordialement
Commenter la réponse de PapyLuc51