Menu

SI contient texte, et/ou texte et/ou texte, faire la somme ?

- - Dernière réponse : Vaucluse
Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
- 15 avril 2019 à 12:49
Bonjour,

J'essaye de faire une formule mais je suis pas sûr que ça soit possible.

J'ai une cellule, mettons A1, avec du texte genre "IDD, APP, OTS", plusieurs sigles dedans.

Je veux obtenir une formule dans une cellule qui me permet de faire la somme des textes,
Par exemple si IDD=1, APP=2 et OTS=3 ; et si la cellule ne contient que IDD et OTS, elle me fera la somme de 1 + 3 en se basant sur le texte.

J'ai réussi a obtenir le résultat en cachant des colonnes mais c'est cracra... ^^;

Si vous voyez comment faire, je vous remercie !
Afficher la suite 

Votre réponse

2 réponses

Messages postés
75
Date d'inscription
mercredi 10 avril 2019
Statut
Membre
Dernière intervention
19 avril 2019
3
0
Merci
Bonjour Zanzatora,

Utilise une nouvelle feuille pour se genre de calcul, beaucoup, plus lisible et plus simple de manipulation si il y a de futur évolution au sein de ton fichier.

Cdt

Dani
Commenter la réponse de DaniBdt
Messages postés
23867
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 avril 2019
5763
0
Merci
Bonjour
sous réserve que chaque texte valorisé soit à compter en un seul exemplaire dans une cellule A1 par exemple:
=SI(NB.SI(A1;"*IDD*")*1+NB.SI(A1;"*APP*")*2+NB.SI(A1;"*OTS*")*3
crdlmnt
Commenter la réponse de Vaucluse