Fonction ou signe "Compris dans" [Résolu]

Messages postés
9
Date d'inscription
mercredi 20 février 2019
Statut
Membre
Dernière intervention
1 mars 2019
- - Dernière réponse : Vaucluse
Messages postés
24291
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 août 2019
- 20 févr. 2019 à 10:59
Bonjour,

J'essaye de faire une sorte de tableau automatisé lié à plusieurs autres feuilles et j'ai actuellement un soucis.
Je suis sur la feuille 1 et j'aimerai que A2 affiche "part description" si A1 est compris dans la colonne A de ma feuille 2, est-ce possible ?
Car si je mets "=SI(A1=Feuil1!Colonne1;"PartDescription";"Rien") cela ne fonctionne pas, car A1 n'est pas égal à TOUTE ma colonne, mais est juste compris dedans.
Un signe doit exister pour remplacer le "=" mais impossible de trouver l'info !

Donc si une âme charitable à une réponse à me fournir, je suis preneur, merci ! ^^

Paul
Afficher la suite 

2 réponses

Messages postés
1679
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
21 août 2019
396
0
Merci
bonjour
une proposition à adapter

=SI(NB.SI(A2:A10;"aa")=NBVAL(A2:A10);"tout";"non")
MaTraK420
Messages postés
9
Date d'inscription
mercredi 20 février 2019
Statut
Membre
Dernière intervention
1 mars 2019
-
Je te remercie pour ta reponse ! Je crois cependant que je ne me suis pas bien fait comprendre.

En réalité je dois faire une feuille qui servira d'outil afin d'aller chercher des infos dans d'autres feuilles qui sont des tableaux de plusieurs milliers de ligne. En gros, je veux pouvoir aller sur ma feuille "outil", rentrer une information qui serait présente dans la colonne A d'une des autres feuilles, et pouvoir faire apparaitre la ligne correspondante présente dans le tableau correspondant, ainsi que l'intitulé de chaque colonne, car tous mes tableaux ont des intitulés différents.
Pour avoir la ligne j'utilise des recherchev, mais c'est pour les intitulés que c'est compliqué. J'aimerai pouvoir rentrer l'info dont je recherche la ligne, mais avoir l'intitulé de ces lignes qui apparait juste au-dessus, avec une fonction SI disant que si la donnée que je rentre est présente sur la première colonne du premier tableau, j'aurais l'intitulé de cette colonne présente dans ce tableau et ainsi de suite avec tous les intitulés.

Je sais que je viens d'ecrire un roman mais j'espère que je suis un peu plus clair comme ça ^^
MaTraK420
Messages postés
9
Date d'inscription
mercredi 20 février 2019
Statut
Membre
Dernière intervention
1 mars 2019
-
C'est bon j'utilisais juste mal les formules, merci beaucoup ^^
Commenter la réponse de yclik
Messages postés
24291
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 août 2019
4721
0
Merci
Bonjour
moi je vois en A2, selon la demande:

=SI(NB.SI(Feuil2!$A:$A;A1);"part description";"rien")
crdlmnt
MaTraK420
Messages postés
9
Date d'inscription
mercredi 20 février 2019
Statut
Membre
Dernière intervention
1 mars 2019
-
Merci beaucoup, mais cela ne m'aide malheureusement pas ^^"
En gros c'est simple : Il faut que j'ai une cellule dans laquelle je peux rentrer une info, et lorsque c'est fait j'ai la ligne correspondante qui apparait et qui est présente dans un des mes tableaux (je rentre une recherchev par cellule présente dans la ligne de mon tableau, et ce dans chaque cellule de ma feuille outil) et chaque info de cette ligne à un intitulé que je dois voir apparaitre au dessus. Sachant que la "feuille outil" va chercher dans plusieurs "feuilles tableau", les intitulés ne sont pas les mêmes et doivent donc changer des que je change l'info présente dans ma cellule de base.
MaTraK420
Messages postés
9
Date d'inscription
mercredi 20 février 2019
Statut
Membre
Dernière intervention
1 mars 2019
-
Oh pardon, tu avais raison çca marche, c'est juste que j'utilisais mal ta formule, merci ^^
Vaucluse
Messages postés
24291
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 août 2019
4721 -
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt
Commenter la réponse de Vaucluse