Recherche de données sur plusieurs feuilles Excel

- - Dernière réponse : didibonf
Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
- 8 janv. 2019 à 12:46
Bonjour Communauté CCM,

Je rencontre le problème suivant :
J'ai un fichier Excel sur lequel se trouve 4 feuilles (Entreesav, Suivisav, BOSE et Alpines).
Entreesav est un tableau qui grâce à quelques manipulations me permet de faire des enregistrements uniques reportés sur ma fiche Suivisav.

Suivisav est en quelque sorte, un récap. de la feuille Entreesav, mais je souhaite y reporter également des informations qui peuvent être soit, sur ma feuille BOSE soit Alpine.

En effet, sachant que toutes les cellules grises ne doivent pas être modifiées car elles sont soit remplies à la main ou déjà automatisées.
Je voudrais qu'à partir de mon N° Dépôt SAV et mon N° Série les tableaux se remplissent automatiquement dans les deux sens.

(Information importante : Le N° de Dépôt SAV est un N° unique mais le N°Série peut revenir plusieurs fois dans mes tableaux car je peux le recevoir plusieurs fois pour réparation).

Ci-après le lien dossier : https://www.cjoint.com/c/IAhqvw1tGVW

Je n'arrive pas à trouver les bonne formules, j'ai essayé de nombreuses formule recherchev, h, sierreur mais pas de solution...
Pouvez-vous m'aider svp ?
Merci à tous.
Afficher la suite 

1 réponse

Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
46
0
Merci
Bonjour,
Je pense que le problème vient des fonctions recherchev utilisée.
Par exemple dans la feuille BOSE en H2 tu as :
=SI(A2="";"";RECHERCHEV(I2;SAV;5;FAUX))
La fonction recherchev va chercher la valeur I2 dans la première colonne des données SAV et renvoyé la valeur de la cinquième colonne. Or I2 correspond à un numéro de série et non au numéro de dépôt. Essaye : =SI(A2="";"";RECHERCHEV(A2;SAV;5;FAUX))
didibonf
Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
46 -
ok dans ce cas il faut délaisser le recherchev et se tourner vers index(equiv…) :
=SI(A2="";"";INDEX(SAV;EQUIV(BOSE!$I2;Suivisav!$F:$F;0);5))
Ca ne fonctionne pas ça m'affiche #N/A
didibonf
Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
46 -
Tu as bien une valeur en I2 feuille BOSE qu’on retrouve en colonne F feuille Suivisav ?
didibonf
Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
46 -
Commenter la réponse de didibonf