#Value [Résolu/Fermé]

Signaler
Messages postés
24
Date d'inscription
jeudi 31 mai 2018
Statut
Membre
Dernière intervention
2 avril 2019
-
Sulphide
Messages postés
24
Date d'inscription
jeudi 31 mai 2018
Statut
Membre
Dernière intervention
2 avril 2019
-
Bonjour,
Bonjour , Il n'y a pas de question bête (j'espère) .
J'obtient des #value! dans mes cellules quelle est la formule à incorporais pour éviter ce problèmes qui par la suite ce répercute sur les autres liaison du programme .

voila la formule a rectifier = AH18*AG18 (donne la #Value)

Merci de votre aide & support.

Eric

8 réponses

Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1 103
Bonjour

Peux-tu joindre un extrait de ton fichier ?
Pour transmettre un fichier, il faut passer par un site de pièce jointe tel que cjoint.com

Va sur ce site : http://cjoint.com
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse..
Crdlt
Sulphide
Messages postés
24
Date d'inscription
jeudi 31 mai 2018
Statut
Membre
Dernière intervention
2 avril 2019

Merci jc80 , ci joint le lien : https://www.cjoint.com/c/HHqp6E3Fz0T
Messages postés
24
Date d'inscription
jeudi 31 mai 2018
Statut
Membre
Dernière intervention
2 avril 2019

Bonjour voila le lien du document .

https://www.cjoint.com/c/HHqp6E3Fz0T

Cordialement.

Eric
Messages postés
17012
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
28 janvier 2020
3 775
Bonjour,

Évite au maximum les cellules fusionnées qui ne font pas bon ménage avec les formules et tu as compliqué inutilement tes formules colonne AG ou par exemple tu as
=SI(ESTNA(RECHERCHEV(D8;'Drop-down lists & Tutorial'!$B$8:$C$98;2;0));"";RECHERCHEV(D8;'Drop-down lists & Tutorial'!$B$8:$C$98;2;0))
qui pourrait être remplacée par =SIERREUR(RECHERCHEV(D8;'Drop-down lists & Tutorial'!$B$8:$C$98;2;0);"")
mais elle pourrait encore être améliorée en nommant la plage 'Drop-down lists & Tutorial'!$B$8:$C$98 par exemple List et ta formule deviendrait
=SIERREUR(RECHERCHEV(D8;List;2;0);"")
ce qui change tout, en simplicité, fonctionnement et surtout taille de ton fichier

alors commence par défusionner les cellules fusionnées dans l'onglet Drop-down lists & Tutorial A24:C24 et idem ligne 40, 57 et 99

ensuite sélectionne toujours dans l'onglet Drop-down lists & Tutorial la plage $B$8:$C$98 et dans la barre d'adresse saisir directement List si tu ne sais pas faire une fois la plage sélectionnée dans le ruban onglet Formules, puis Gestionnaire de noms et Nouveau et dans Nom saisir List contrôle que dans Fait référence à la formule automatique soit bien ='Drop-down lists & Tutorial'!$B$8:$C$98 et OK
(au passage dans le gestionnaire supprime les plages nommées Proteins et Type qui sont en erreur et ne servent à rien

puis onglet Day (1) en cellule AG8 colle cette formule que tu incrémenteras vers le bas
=SIERREUR(RECHERCHEV(D8;List;2;0);"")


puis en AI8 soit tu colles cette formule
=SIERREUR(AH8*AG8;"")
ou au choix celle ci =SI(AG8="";"";AH8*AG8)


en AK8 colle cette formule
=SIERREUR((X8+Y8)*AG8;"") ou celle ci =SI(AG8="";"";(X8+Y8)*AG8)


tu incrémentes AG8 et AK8 vers le bas

dans tes colonnes K et L tu as également des erreurs #DIV/0!
que tu peux traiter de la même façon avec la syntaxe SIERREUR(ta formule;"")
ce qui donnerait par exemple en K8 =SIERREUR(SI(ESTVIDE(H8);"";I8/F8);"")
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
24
Date d'inscription
jeudi 31 mai 2018
Statut
Membre
Dernière intervention
2 avril 2019

Merci Mike-31 très vraiment passionnant , par contre je n'y arrive pas ! pourrais tu me faire la correction sur la feuille de calcul car de plus mon Excel est en langue Anglaise (boulot oblige)
Merci & bonne journée.
Eric
Messages postés
17012
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
28 janvier 2020
3 775
Re,

Voila à toi de contrôler et continuer
https://www.cjoint.com/c/HHrfR1xfOoj
Messages postés
24
Date d'inscription
jeudi 31 mai 2018
Statut
Membre
Dernière intervention
2 avril 2019

Je te remercie, Mike-31, pour m'avoir aidée à trouver le temps de faire mes routines et pour ces routines que je continue à faire est a apprendre & comprendre.
Merci aussi pour ton encouragement.
Bonne journée .

Eric
Messages postés
23237
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
28 janvier 2020
5 883
Bonjour,

pour compléter Mike et t'expliquer la cause d'origine, tu as un #VALEUR! quand tu mets un texte alors qu'un nombre est attendu (entre autres).
dans :
=SI(ESTNA(RECHERCHEV(D10;'Drop-down lists & Tutorial'!$B$8:$C$98;2;0));"";RECHERCHEV(D10;'Drop-down lists & Tutorial'!$B$8:$C$98;2;0))

tu mets le texte "" si non trouvé. Avec un 0 excel pourra calculer.
eric
Messages postés
24
Date d'inscription
jeudi 31 mai 2018
Statut
Membre
Dernière intervention
2 avril 2019

merci pour tes bons conseils Eric est bonne journée .