Menu

Paquets cassés dans synaptic [Résolu]

pacorabano 25 Messages postés lundi 20 juin 2016Date d'inscription 19 juillet 2018 Dernière intervention - 26 mars 2018 à 14:09 - Dernière réponse : darkleopard 7913 Messages postés samedi 27 décembre 2014Date d'inscriptionContributeurStatut 19 mai 2018 Dernière intervention
- 27 mars 2018 à 21:23
Bonjour,
j'ai installé la distribution freespire; tout à l'air ok exceptés l'installation d'evolution et de nautilus par synaptic.
Lorsque je sélectionne les éléments et valide l'installation, j'ai un message qui me demande de réparer les paquets cassés.
Je les répare mais j'ai toujours le même problème lorsque je veux installer ces programmes.
J'ai rechargé ma liste, fais sudo apt-get update, puis sudo apt-get upgrade et toujours le même probleme.
Existe t-il une solution pour y remedier?
Merci
Cordialement


Afficher la suite 

Votre réponse

9 réponses

darkleopard 7913 Messages postés samedi 27 décembre 2014Date d'inscriptionContributeurStatut 19 mai 2018 Dernière intervention - 26 mars 2018 à 14:25
0
Merci
hello

essaye ceci eventuellement , des fois que ça réparerais tes paquets
sudo apt-get -f install && sudo apt-get update && sudo apt-get dist-upgrade

pacorabano 25 Messages postés lundi 20 juin 2016Date d'inscription 19 juillet 2018 Dernière intervention - 26 mars 2018 à 14:58
bonjour et merci d'avoir repondu; j'ai fais en terminal mais toujours le même probleme...
merci
darkleopard 7913 Messages postés samedi 27 décembre 2014Date d'inscriptionContributeurStatut 19 mai 2018 Dernière intervention - 26 mars 2018 à 15:46
donnes le retour complet de
sudo apt-get update && sudo apt-get upgrade && sudo apt-get -f install

et le retour de
cat /etc/apt/sources.list


Et pourquoi tu veux installer Nautilus et Evolution.??
Et c'est quel environnement que tu utilises.??
pacorabano 25 Messages postés lundi 20 juin 2016Date d'inscription 19 juillet 2018 Dernière intervention - 26 mars 2018 à 16:16
voilà ce que j'ai lorsque je veux installer evolution :
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
darkleopard 7913 Messages postés samedi 27 décembre 2014Date d'inscriptionContributeurStatut 19 mai 2018 Dernière intervention - 26 mars 2018 à 16:41
donne le retour des 2 commandes.
parce que là on comprend rien, et donc on avance pas.

si je te demande 2 commandes c'est pas pour te faire taper inutilement, c'est pour voir l'étendue des dégats (si il y en a )
Commenter la réponse de darkleopard
pacorabano 25 Messages postés lundi 20 juin 2016Date d'inscription 19 juillet 2018 Dernière intervention - 26 mars 2018 à 17:44
0
Merci
1ere commande :
freespire@freespire-MS-7392:~$ sudo apt-get update && sudo apt-get upgrade && sudo apt-get -f install
[sudo] Mot de passe de freespire :
Atteint:1 http://fr.archive.ubuntu.com/ubuntu xenial InRelease
Atteint:2 http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu xenial InRelease
Atteint:3 http://linux.teamviewer.com/deb stable InRelease
Atteint:4 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease
Atteint:5 http://linux.teamviewer.com/deb preview InRelease
Atteint:6 http://fr.archive.ubuntu.com/ubuntu xenial-security InRelease
Atteint:7 https://repo.skype.com/deb stable InRelease
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
bogofilter bogofilter-bdb bogofilter-common evolution-common
evolution-data-server evolution-data-server-online-accounts
gir1.2-networkmanager-1.0 gir1.2-nma-1.0 gir1.2-timezonemap-1.0
gir1.2-xkl-1.0 hunspell-fr hyphen-fr libaccounts-glib0 libaccounts-qt5-1
libcryptui0a libecal-1.2-19 libedata-cal-1.2-28 libedataserverui-1.2-1
libgeocode-glib0 libgweather-3-6 libgweather-common libpst4
libreoffice-help-fr libreoffice-l10n-fr libsignon-extension1 libsignon-glib1
libsignon-plugins-common1 libsignon-qt5-1 libtimezonemap-data
libtimezonemap1 libytnef0 linux-headers-4.13.0-31
linux-headers-4.13.0-31-generic linux-image-4.13.0-31-generic
linux-image-extra-4.13.0-31-generic mythes-fr seahorse seahorse-daemon
session-migration signon-plugin-password signon-ui signon-ui-service
signon-ui-x11 signond thunderbird-locale-fr
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
bogofilter bogofilter-bdb bogofilter-common evolution-common
evolution-data-server evolution-data-server-online-accounts
gir1.2-networkmanager-1.0 gir1.2-nma-1.0 gir1.2-timezonemap-1.0
gir1.2-xkl-1.0 hunspell-fr hyphen-fr libaccounts-glib0 libaccounts-qt5-1
libcryptui0a libecal-1.2-19 libedata-cal-1.2-28 libedataserverui-1.2-1
libgeocode-glib0 libgweather-3-6 libgweather-common libpst4
libreoffice-help-fr libreoffice-l10n-fr libsignon-extension1 libsignon-glib1
libsignon-plugins-common1 libsignon-qt5-1 libtimezonemap-data
libtimezonemap1 libytnef0 linux-headers-4.13.0-31
linux-headers-4.13.0-31-generic linux-image-4.13.0-31-generic
linux-image-extra-4.13.0-31-generic mythes-fr seahorse seahorse-daemon
session-migration signon-plugin-password signon-ui signon-ui-service
signon-ui-x11 signond thunderbird-locale-fr
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
freespire@freespire-MS-7392:~$


2eme commande
freespire@freespire-MS-7392:~$ cat /etc/apt/sources.list
# deb cdrom:[Xubuntu 16.04.3 LTS _Xenial Xerus_ - Release amd64 (20170801)]/ xenial main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://us.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
# deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://fr.archive.ubuntu.com/ubuntu/ xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

freespire@freespire-MS-7392:~$


voilà j'espere que j'ai fais correctement
merci
darkleopard 7913 Messages postés samedi 27 décembre 2014Date d'inscriptionContributeurStatut 19 mai 2018 Dernière intervention - 26 mars 2018 à 19:14
Ha oui là t'as un sérieux problème, je sais pas ce que t'as fais depuis l'installation, mais c'est complètement en vrac..
Pour que le kernel, libreoffice, thunderbird, soient dans la liste des paquets à enlever, c'est pas normal....

place aux question :
  • De quand date ton installation.??
  • Pourquoi un ppa pour simplescreenrecorder.?? la version dans les dépots ne suffit pas.??
  • Cette distrib freespire, c'est quoi.?? Pourquoi elle.??
  • pourquoi pas ubuntu directement.??
  • c'est quel bureau que t'as.?? Gnome.?? xfce.??
  • Et le dépot de Skype qui a lui tout seul est source de problème varié...


Réponds à toutes les questions, pour savoir où on va.

EDIT :
je me réponds à moi-même, visiblement c'est le bureau Xfce, alors mettre Nautilus et Evolution, je comprends pas trop là.!!!!

Pourquoi eux deux en sachant que tu vas avoir toute la suite Gnome qui va s'installer derrière...

Thunar ne te convient pas pour vouloir le remplacer par Nautilus.??

Evolution ou Thunderbird c'est kiff-kiff, autant garder Thunderbird, il est moins usine à gaz que l'inutile Evolution...

Mais en tout cas, une chose est sure, cette distribution Linux ne m'inspire pas confiance, je vois pas trop son intérêt par rapport à une Xubuntu par exemple..!!!!!!
Commenter la réponse de pacorabano
pacorabano 25 Messages postés lundi 20 juin 2016Date d'inscription 19 juillet 2018 Dernière intervention - 27 mars 2018 à 10:09
0
Merci
c'est exacte, je vais installer ubuntu, c'est plus fiable
merci pour le suivi
bonne journée
darkleopard 7913 Messages postés samedi 27 décembre 2014Date d'inscriptionContributeurStatut 19 mai 2018 Dernière intervention - 27 mars 2018 à 21:23
je pense que oui, parce que là vu les problèmes que t'as, ça va être un festival d'emmerdes dans quelques mois.
tiens nous au courant quand t'aura installer Ubuntu.
Commenter la réponse de pacorabano