Menu

Collecter tous les mercredis et dimanches du mois [Résolu]

doracina 9 Messages postés dimanche 4 février 2018Date d'inscription 6 février 2018 Dernière intervention - 4 févr. 2018 à 20:00 - Dernière réponse : doracina 9 Messages postés dimanche 4 février 2018Date d'inscription 6 février 2018 Dernière intervention
- 6 févr. 2018 à 02:10
Bonjour,
Aimerais collecter que les Mercredi et Dimanche du mois courant et les afficher sous forme de colonnes dans un ordre croissant:
A1 = dates (jj/mm/aa) dans un ordre croissant
B1 = mercredi ou dimanche

Le principe vaudra pour les autres jours de la semaine à définir.

D'avance, merci de votre collaboration



Afficher la suite 

Votre réponse

17 réponses

Meilleure réponse
eriiic 21619 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 25 mai 2018 Dernière intervention - 4 févr. 2018 à 23:33
1
Merci
Bonjour,

avec la 1ère date en A1, mettre en A2 :
=SERIE.JOUR.OUVRE.INTL(A1;1;"1101110") 

et tirer vers le bas.
Tu peux avoir jour et date dans la même cellule avec en format personnalisé : jjjj jj/mm/aaaa
eric

Merci eriiic 1

a aidé 24849 internautes ce mois-ci

doracina 9 Messages postés dimanche 4 février 2018Date d'inscription 6 février 2018 Dernière intervention - 5 févr. 2018 à 09:13
Hello Eriiic,
Bonne idée mais quand je tire vers le bas B1, le reste ne suit pas. B2 et suivant reste identique à B1
Merci pour ton poste et @ bientôt
eriiic 21619 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 25 mai 2018 Dernière intervention - 5 févr. 2018 à 10:54
Ah, chez moi ça marche pas mal :
https://www.cjoint.com/c/HBfj1SYjWHW
eric
doracina 9 Messages postés dimanche 4 février 2018Date d'inscription 6 février 2018 Dernière intervention > eriiic 21619 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 25 mai 2018 Dernière intervention - 6 févr. 2018 à 02:04
Eriiic, super.J'ai mon compte et te remercie infiniment .
Problème résolu.
Grand merci!
Commenter la réponse de eriiic
Meilleure réponse
michel_m 15301 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 25 mai 2018 Dernière intervention - 5 févr. 2018 à 12:24
1
Merci
Bonjour

une autre-une autre-une autre...bon d'accord

année en B1 mois en B2 (chiffre)
1° mercredi
=DATE(B1;B2;8)-JOURSEM(DATE(B1;B2;4))

maquette de W
https://mon-partage.fr/f/Vs7kZB7M/

Merci michel_m 1

a aidé 24849 internautes ce mois-ci

doracina 9 Messages postés dimanche 4 février 2018Date d'inscription 6 février 2018 Dernière intervention - 6 févr. 2018 à 02:10
Merci Michel,
Je l'ai adapté pour avoir soit le mercredi soit le dimanche selon les mois.
Merci , cela a été utile
Grand merci
Commenter la réponse de michel_m
Vaucluse 22045 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 mai 2018 Dernière intervention - Modifié par Vaucluse le 4/02/2018 à 20:59
0
Merci
Bonjour

si vous voulez répéter en B la date de A si c'est un mercredi ou un dimanche:

an B1=

=SI((JOURSEM(A1;2)=3;JOURSEM(A1;2)=7);A1;"")


(mais après réflexion !!)

si vous voulez placer les dates en titre de colonne à partir de B

deux options selon départ

si vous placez en A1 une date qui est un :mercredi ou un dimanche:

en B1 à tirer vers la droite
=SI(JOURSEM(A1;2)=3;A1+4;A1+3)

si par contre votre date en A1 est aléatoire:

en B1:
=SI(JOURSEM(A1;2)>3;A1+7-JOURSEM(A1;2);A1+3-JOURSEM(A1;2))

et ensuite en C1, la formule précédente ajustée sur B1 et tirée vers la droite,soit
=SI(JOURSEM(B1;2)=3;B1+4;B1+3)
crdlmnt

Commenter la réponse de Vaucluse
Patrice33740 6848 Messages postés dimanche 13 juin 2010Date d'inscription 25 mai 2018 Dernière intervention - 4 févr. 2018 à 20:43
0
Merci
Bonjour,

Pas sûr d'avoir compris !

En A1 et en B1 :
=ENT(DATEVAL("31/12/17")+3,5*LIGNE())
à tirer vers le bas.
A1 au format date
B1 au format personnalisé jjjj

Patrice33740 6848 Messages postés dimanche 13 juin 2010Date d'inscription 25 mai 2018 Dernière intervention - 4 févr. 2018 à 23:18
doracina 9 Messages postés dimanche 4 février 2018Date d'inscription 6 février 2018 Dernière intervention > Patrice33740 6848 Messages postés dimanche 13 juin 2010Date d'inscription 25 mai 2018 Dernière intervention - 5 févr. 2018 à 09:31
Je l'ai resté de nouveau; oui, c'est cela mais j'aimerais que cela s’arrête au mois, et en plus que si la date change, la liste se rafraîchit automatiquement.

Merci , c'était quand même utile.
Bonsoir Patrice33740,
Merci du bout de programme mais ne fait pas exactement je que j'espère. Voici autrement
En A1 une date format jj/MM/AAAA
En C1, à tirer vers le bas uniquement les mercredis et dimanches du mois concerné.
En B1, à tirer vers le bas également la date correspondante au mercredis et dimanches concernés.
D'avance merci
Commenter la réponse de Patrice33740
via55 9306 Messages postés mercredi 16 janvier 2013Date d'inscription 25 mai 2018 Dernière intervention - 4 févr. 2018 à 21:04
0
Merci
Bonjour doracina, coucou Vaucluse ☺

Et si tu veux la liste dans l'ordre chronologique des mercredi et dimanche du mois les uns en dessous des autres dans la colonne B :
en B1 la formule : =SI(JOURSEM(DATE(2018;MOIS(AUJOURDHUI());1);2)<4;DATE(2018;MOIS(AUJOURDHUI());1)+3-JOURSEM(DATE(2018;MOIS(AUJOURDHUI());1);2);DATE(2018;MOIS(AUJOURDHUI());1)+7-JOURSEM(DATE(2018;MOIS(AUJOURDHUI());1);2)) qui retourne le 1er mercredi ou le 1er dimanche selon celui qui suit le1er du mois
en B2 la formule : =B1+SI(JOURSEM(B1;2)=3;4;3) donnant le 1er mercredi ou dimanche suivant la date en B1
en B3 la formule : =SI(MOIS(B1+7)=MOIS(B1);B1+7;"") à étirer vers le bas pour avoir les autres mercredis/dimanches du mois

Cdlmnt
Via
C'est exactement ce que je souhaite mais j'ai des des erreurs en ce moment dans la transcription des formules.
Je te tiendrai au courant demain matin. Merci pour ton support et bonne soirée.
doracina 9 Messages postés dimanche 4 février 2018Date d'inscription 6 février 2018 Dernière intervention - 5 févr. 2018 à 09:03
Bonjour Vaucluse,
Il fait exactement ce que je souhaite; seul bémol, quand la date en A1 (01.02.2018) change, le contenu de la colonne en B1 reste inchangé et ne se rafraîchit pas.

Merci de tes efforts.
Vaucluse 22045 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 25 mai 2018 Dernière intervention > doracina 9 Messages postés dimanche 4 février 2018Date d'inscription 6 février 2018 Dernière intervention - 5 févr. 2018 à 10:00
Bonjour
vous ne dites pas quelle configuration vous souhaitez dans les deux proposées
voila un exemple avec quelques remarques
https://mon-partage.fr/f/rUBdatmq/
crdlmnt
doracina 9 Messages postés dimanche 4 février 2018Date d'inscription 6 février 2018 Dernière intervention - 5 févr. 2018 à 21:58
Désolé. La formule ci-dessous approche de mon idée. il faudra:
1) Que la date dans A1 soit aléatoire
2) Que la colonne B1 à Bx soit automatiquement mise à jour


B1 la formule : =SI(JOURSEM(DATE(2018;MOIS(AUJOURDHUI());1);2)<4;DATE(2018;MOIS(AUJOURDHUI());1)+3-JOURSEM(DATE(2018;MOIS(AUJOURDHUI());1);2);DATE(2018;MOIS(AUJOURDHUI());1)+7-JOURSEM(DATE(2018;MOIS(AUJOURDHUI());1);2)) qui retourne le 1er mercredi ou le 1er dimanche selon celui qui suit le1er du mois
en B2 la formule : =B1+SI(JOURSEM(B1;2)=3;4;3) donnant le 1er mercredi ou dimanche suivant la date en B1
en B3 la formule : =SI(MOIS(B1+7)=MOIS(B1);B1+7;"") à étirer vers le bas pour avoir les autres mercredis/dimanches du mois


Le fichier reçu correspond à la version en colonne. Il faudra que la date initiale (A1) soit aléatoire
Merci Vaucluse.
Commenter la réponse de via55
via55 9306 Messages postés mercredi 16 janvier 2013Date d'inscription 25 mai 2018 Dernière intervention - 5 févr. 2018 à 23:12
0
Merci
Bonsoir Doracina

C'est moi qui t'avais indiqué cette formule
Avec A1 en aléatoire remplace la formule en B1 par celle ci :
=SI(JOURSEM(DATE(ANNEE(A1);MOIS(A1);1);2)<4;DATE(ANNEE(A1);MOIS(A1);1)+3-JOURSEM(DATE(ANNEE(A1);MOIS(A1);1);2);DATE(ANNEE(A1);MOIS(A1);1)+7-JOURSEM(DATE(ANNEE(A1);MOIS(A1);1);2))
B2 sans changement
B3 et suivants sans changements

mettre ces cellules en format Date longue

La mise à jour est bien automatique si ton classeur est en calcul automatique et non manuel (Verifier dans le Ruban à Formules et Options de calcul

Cdlmnt
Via

Commenter la réponse de via55