Menu

Combiné Si et RECHERCHE [Résolu]

oreil14 14 Messages postés mardi 5 septembre 2017Date d'inscription 19 mars 2018 Dernière intervention - 5 sept. 2017 à 17:19 - Dernière réponse : Vaucluse 22388 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 juillet 2018 Dernière intervention
- 5 sept. 2017 à 17:48
excel office365

Bonjour,
Débutant sur excel, j'ai besoin de votre aide pour combiné des fonctions: J'avais pensé à SI + RECHERCHE
Mon but est le croisement d'informations:
Sur la feuille2, j'ai des prix et des références.
Sur la feuille1, j'ai des références et des ID mais pas les prix.
J'aimerais qu'il aille chercher les prix de la feuille2 pour les faire correspondre sur la feuille1

Voici ma régle:
Si le contenu de la cellule1 de la colonneB de la feuille1 est égale à une cellule de la colonne A de la feuille2, affiche dans colonneD de la feuille1 le résultat de la colonneD de feuille2 correspondante à la ligne de la cellule trouvée.

Désolé difficile a expliquer... voici le fichier: https://drive.google.com/file/d/0B_3z61z1ncimb184SmdPOEdEUDg/view?usp=sharing

Milles merci pour votre aide!
Afficher la suite 

Votre réponse

5 réponses

Vaucluse 22388 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 juillet 2018 Dernière intervention - 5 sept. 2017 à 17:24
0
Merci
Bonjour

je ne peux pas exploiter votre fichier, mais cette formule devrait aller

dans la cellule résultat

=SI(NB.SI(Feuil2!A:A;B1)=0;"";RECHERCHEV(B1;Feuil2!A:D;4;0))

ou plus directement si Excel >= 2007:

=SIERREUR(RECHERCHEV(B1;Feuil2!A:D;4;0);"")

crdlmnt


oreil14 14 Messages postés mardi 5 septembre 2017Date d'inscription 19 mars 2018 Dernière intervention - 5 sept. 2017 à 17:37
Quelle rapidité!! milles merci. Je vais tester.
(mon lien devrait être accessible maintenant)
Commenter la réponse de Vaucluse
oreil14 14 Messages postés mardi 5 septembre 2017Date d'inscription 19 mars 2018 Dernière intervention - 5 sept. 2017 à 17:40
0
Merci
Alors j'ai oublié une info:
Voici ma régle:
Si le contenu de la cellule1 de la colonneB de la feuille1 est égale à une cellule de la colonne A de la feuille2, affiche dans colonneD de la feuille1 le résultat de la colonneD de feuille2 correspondante à la ligne de la cellule trouvée.

->Puis ceci pour la cellule2 de la colonneB de la feuille1, puis cellule3, etc
oreil14 14 Messages postés mardi 5 septembre 2017Date d'inscription 19 mars 2018 Dernière intervention - 5 sept. 2017 à 17:41
Pardon, j'ai rien dit. Ca marche, c'est super, merci!!!!!!
Vaucluse 22388 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 juillet 2018 Dernière intervention > oreil14 14 Messages postés mardi 5 septembre 2017Date d'inscription 19 mars 2018 Dernière intervention - 5 sept. 2017 à 17:48
Pas de quoi,
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de oreil14