DHCP non fonctionnel sur un router Cisco C891F-K9 [Résolu/Fermé]

Signaler
Messages postés
180
Date d'inscription
jeudi 27 octobre 2016
Statut
Membre
Dernière intervention
1 décembre 2017
-
korke
Messages postés
180
Date d'inscription
jeudi 27 octobre 2016
Statut
Membre
Dernière intervention
1 décembre 2017
-
Bonjour,
Je vous explique pour commencer comment le réseau est arrangé :

appareils concernés :
-1 Router C891F-K9 (Router et switch en même temps) connecté au ISP
-1 switch (non configurable) D-Link DGS-1016D
-1 switch (non configurable) HP Procurve 1410-16g
-1 point d'accès wifi AIR-AP-1852i-A-K9 (avec mobility express)
-Les clients DHCP (ordinateurs)

Pour faire simple, 2 "entreprises" différentes vont se partager un accès à internet. Je vais les appeler ORG1 et ORG2.

Le router C891F-K9 a un port L3, Gigabit 8, et 8 switchports (G0 à 7). La commande "no switchport" ne fonctionne pas, j'ai déjà essayé.


G8 -->ISP
G0 -->Switch D-Link pour ORG1
G1 -->Switch HP pour ORG2
G2 -->Access point qui va servir pour les réseaux wifi (séparés) des 2 entreprises.

Le problème est le suivant : Les différents ordinateurs doivent recevoir leur adresse ip et DNS par DHCP. Le router est le serveur DHCP. En ce moment, tous les ordinateurs reçoivent une adresse APIPA peu importe ce que j'essaie. En assignant une adresse statique à tout le monde, tout fonctione (wifi compris) incluant l'accès à internet donc le problème est vraiment en lien au DHCP.

le port G0 est en access mode pour le VLAN 1 (192.168.1.0 /24).
le port G1 est en access mode pour le VLAN 2 (192.168.2.0 /24).
le port G2 est en mode trunk pour la connexion au point d'accès

VLAN 1 a l'adresse ip suivante : 192.168.1.1 255.255.255.0
VLAN 2 a l'adresse ip suivante : 192.168.2.1 255.255.255.0
VLAN 10 est le "management VLAN" et configuré com native VLAN de la trunk vers l'AP.

Les 2 switchs sont impossible à configurer et on perd la connectivité si les interfaces G0 et G1 du router sont configurés en mode trunk. Ça remarche en remettant les ports en access vlan 1 (G0) et 2 (G1)

Le DHCP a fonctionné et fourni des IP aux clients. 1 des ordinateurs était toujours pris avec une adresse APIPA lorsqu'il était connecté sur le réseau sans fil wlan 1 (ORG1) et avait reçu son IP normalement sur wlan 2 (org2) alors que les deux réseaux wifi étaient configurés de façon identique. J'ai ensuite déplacé (après avoir sauvegardé les config) le router et l'access point pour connecter au WAN et voir si les ordis qui avaient reçu leur DHCP pouvaient au moins se rendre sur internet et voir si, après le router redémarré, le DHCP allait fonctionner.

Non seulement ça n'a pas fonctionné mais à ce moment, tous les ordinateurs se sont retrouvés avec une adresse APIPA. Tout ce que j'ai essayé n'a pas fonctionné et je suis maintenant à court d'idées.
J'ai posté sur les forums de Cisco mais je n'ai toujours pas de réponse qui me permette vraiment d'avancer. Voici le lien si vous pouvez lire l'anglais :
https://supportforums.cisco.com/discussion/13334591/dhcp-no-longer-works-after-router-was-relocated

voici la config du DHCP et des ports / VLAN du router :

no ip dhcp use class
ip dhcp binding cleanup interval 300
ip dhcp excluded-address 192.168.1.50 192.168.1.60
ip dhcp excluded-address 192.168.2.5
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool ORG1
 utilization mark high 20 log
 utilization mark low 2 log
 network 192.168.1.0 255.255.255.0
 subnet prefix-length 24
 default-router 192.168.1.1
 dns-server x.x.x.x x.x.x.x x.x.x.x
!
ip dhcp pool ORG2
 utilization mark high 20 log
 utilization mark low 2 log
 network 192.168.2.0 255.255.255.0
 subnet prefix-length 24
 default-router 192.168.2.1
 dns-server x.x.x.x x.x.x.x x.x.x.x

!
interface BRI0
 no ip address
 encapsulation hdlc
 isdn termination multidrop
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0
 no ip address
 auto discovery qos
!
interface GigabitEthernet1
 switchport access vlan 2
 no ip address
 auto discovery qos
!
interface GigabitEthernet2
 switchport trunk native vlan 10
 switchport trunk allowed vlan 1-3,10,1001-4094
 switchport mode trunk
 no ip address
!
interface GigabitEthernet3
 no ip address
 shutdown
!
interface GigabitEthernet4
 no ip address
 shutdown
!
interface GigabitEthernet5
 no ip address
 shutdown
!
interface GigabitEthernet6
 no ip address
 shutdown
!
interface GigabitEthernet7
 no ip address
 shutdown
!
interface GigabitEthernet8
 ip address dhcp
 ip access-group 1 out
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan2
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan3
 ip address 192.168.3.1 255.255.255.0 ****N'est pas utilisé pour l'instant****
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in


Et voici ce que je reçois du debug ip DHCP server events et debug ip DHCP server packets :
  • Jul 17 19:19:08.675: DHCPD: client's VPN is .
  • Jul 17 19:19:08.675: DHCPD: No option 125
  • Jul 17 19:19:08.675: DHCPD: Sending notification of DISCOVER:
  • Jul 17 19:19:08.675:   DHCPD: htype 1 chaddr 001b.fcf5.9976
  • Jul 17 19:19:08.675:   DHCPD: remote id 020a0000c0a8010100010001
  • Jul 17 19:19:08.675:   DHCPD: circuit id 00000000
  • Jul 17 19:19:08.675: DHCPD: DHCPDISCOVER received from client 0100.1bfc.f599.76 on interface Vlan1.
  • Jul 17 19:19:08.675: DHCPD: Seeing if there is an internally specified pool class:
  • Jul 17 19:19:08.675:   DHCPD: htype 1 chaddr 001b.fcf5.9976
  • Jul 17 19:19:08.675:   DHCPD: remote id 020a0000c0a8010100010001
  • Jul 17 19:19:08.675:   DHCPD: circuit id 00000000

*Jul 17 19:19:08.675: DHCPD: there is no address pool for 192.168.1.1.

L'ordinateur concerné est branché avec fil dans la switch D-Link de ORG1, qui à son tour est branchée dans G0 du router. Pourquoi "there is no address pool for 192.168.1.1" alors que la DHCP pool est bien configurée avec 192.168.1.1 comme default-router et 192.168.1.0 255.255.255.0 comme réseau et vlan 1 bien configuré avec l'IP 192.168.1.1 255.255.255.0 et G0 bien configuré avec switchport access vlan 1?

En passant oui, tout a été redémarré plusieurs fois. À l'aide svp :o

Merci d'avance
Simon

1 réponse

Messages postés
88874
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
20 février 2020
8 828
Salut,
étrange en effet, oui.
à tout hasard,
le prefix length est peut-etre de trop par rapport à ce qui est déjà défini sur network dans les pools dhcp
PS,
je vois que c'est ce qui t'a été conseillé aussi par Kevin à la dernière réponse sur le forum Cisco.

et ... Voili  Voilou  Voila !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 87670 internautes nous ont dit merci ce mois-ci

korke
Messages postés
180
Date d'inscription
jeudi 27 octobre 2016
Statut
Membre
Dernière intervention
1 décembre 2017
21
Ok je te remercie de ta réponse, je vais enlever le prefix-length. Il y était pas au tout début.

Je vous tiens au courant
Simon
korke
Messages postés
180
Date d'inscription
jeudi 27 octobre 2016
Statut
Membre
Dernière intervention
1 décembre 2017
21
Effectivement, le problème venait de ces 2 lignes de commande. Aussitôt que je les ai enlevé tout s'est mis à remarcher... Je me sens un peu stupide hahaha
J'aurais tellement dû essayer ça avant

Merci beaucoup et passe une belle journée :)