Menu

Prise de tête [Résolu/Fermé]

Cédric - 18 oct. 2016 à 04:18 - Dernière réponse :  Cédric
- 19 oct. 2016 à 04:58
Bonjour,

Je m'arrache les cheveux depuis de longues heures et je n'arrive pas a trouver la solution alors je viens demander de l'aide!!

J'ai un tableau excel dans lequel on rentre des valeurs d'un produit qui doivent être comprise entre 4 et 8 PPM.
Au dessus de 8 j'ai la formule suivante pour un message d'alerte:
=SI(D11>8;"PO4 haut, baisser 77271 en tenant compte du PO4 TTH 2";"")

Au dessous de 4 j'ai la formule suivante pour un autre message d'alerte:
=SI(ET(D11<4;D11>-1);"PO4 bas, augmenter 77271 en tenant compte du PO4 TTH 2";"")

Mon problème est que lorsque la cellule ou on rentre la valeur (vous avez deviné c'est D11) est vide j'ai soit le 1er message qui apparait ou le deuxième suivant si j'ai appuyer sur la touche SUPPR ou ESPACE alors que je voudrais que lorsque la case D11 est vide n'avoir aucun message qui apparaissent.

Voila, j'espère avoir été un peu près clair dans mes explications.
Par avance merci a tous et bonne journée
Afficher la suite 

5 réponses

PapyLuc51 1514 Messages postés dimanche 3 mai 2009Date d'inscription 15 juin 2018 Dernière intervention - 18 oct. 2016 à 05:56
0
Merci
Bonjour

Si je comprends bien tu veux que rien ne se passe si D11 est vide par contre si D11 est marqué 0 tu veux que le message s'inscrive ; il faut donc ajouter une condition au début SI(ESTVIDE(D11);""; le reste de ta formule et n'oublie pas de rajouter les parenthèses utiles à la fin,

Autre chose tu peux remplacer D11>-1 par D11>=0

Autre chose encore, si tu veux que l'un ou l'autre message soit inscrit dans la même cellule voilà la formule

=SI(ESTVIDE(D11);"";SI(D11>8;"PO4 haut, baisser 77271 en tenant compte du PO4 TTH 2";SI(ET(D11<4;D11>=0);"PO4 bas, augmenter 77271 en tenant compte du PO4 TTH 2";"")))

Cordialement
Gyrus 3341 Messages postés samedi 20 juillet 2013Date d'inscription 9 décembre 2016 Dernière intervention - 18 oct. 2016 à 10:25
0
Merci
Bonjour Cédric,
Salutations PapyLuc51,

Il me semble plus simple de vérifier que la saisie est numérique :

=SI(ET(ESTNUM(D11);D11>8);"PO4 haut, baisser 77271 en tenant compte du PO4 TTH 2";"")

=SI(ET(ESTNUM(D11);D11<4;D11>-1);"PO4 bas, augmenter 77271 en tenant compte du PO4 TTH 2";"")

A+
Bonjour Gyrus et PapyLuc51 et merci a vous deux pour vos réponses.

Etant actuellement de nuit j'essaierai vos solutions ce soir mais il est vrai que si je peux tout mettre dans la même cellule se serait encore mieux car n'y arrivant pas j'ai doublé mes cellules d'alertes et cela a forcément bien agrandit mon tableau ou j'ai le même problème pour notre produit mais une fois la solution trouvé pour celui-ci je saurai la modifier pour l'appliquer sur ces autres produits.

En tout cas merci pour vos réponses rapide et je vous tient au courant durant la nuit.
Bonne journée
Gyrus 3341 Messages postés samedi 20 juillet 2013Date d'inscription 9 décembre 2016 Dernière intervention > Cédric - 18 oct. 2016 à 12:49
En une seule formule :
=SI(ESTNUM(D11);SI(D11>8;"PO4 haut, baisser 77271 en tenant compte du PO4 TTH 2";SI(ET(D11>-1;D11<4);"PO4 bas, augmenter 77271 en tenant compte du PO4 TTH 2";""));"")

A+
Cédric > Gyrus 3341 Messages postés samedi 20 juillet 2013Date d'inscription 9 décembre 2016 Dernière intervention - 19 oct. 2016 à 04:58
Bonjour,

Nikel je viens d'essayer et ca marche.
En plus le fait de tous mettre dans la même cellule fait que j'ai pu agrandir mes messages d'alerte et je me suis resservi de cette formule sur d'autre produits en changeant, évidemment, les numéros de cellule et intitulés des messages.

Un grand merci a vous.