RECHERCHEV renvoie sur les lignes suivantes le même résultat [Fermé]

Signaler
Messages postés
9
Date d'inscription
mardi 11 mars 2008
Statut
Membre
Dernière intervention
11 mars 2015
-
 dani -
j'ai un tableau avec différentes données, lorsque je fais une recherche j'obtiens le bon résultat en utilisant la formule suivante :
=SI(A19="";"";RECHERCHEV(A19;Article!$A$1:$BS$9505;13))
le résultat est correcte, rien à dire.
Dés que je passe à la ligne suivante en A20 où il n'y a pas de recherche à faire
puisque la cellule est vide par la condition =SI(A20="";""

le résultat affiché est le même que sur la ligne de recherche A19, ainsi que sur les lignes suivantes jusqu'au moment ou il y a une recherche effective.

Je vous remercie à l'avance de m'aider.

4 réponses

Messages postés
2053
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
18 décembre 2019
249
Bonjour
Je pense que le mode de calcul de votre feuille est manuel, il faut le passer en automatique. vérifier les actions suivantes
-Clic sur le bouton office en haut à gauche
-sélectionnez Options excel (en bas)
-sélectionnez "Formules"
-dans le pavé "Mode de calcul" cochez "Automatique"
-Ok
11
Merci

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez Comment Ça Marche

CCM 68937 internautes nous ont dit merci ce mois-ci

Grands mercis !!

D'habitude, les feuilles s'ouvrent en mode de calcul automatique mais je ne n'ai pas songé à vérifier ce paramètre ( ....) !
ça m'a beaucoup aidé, merci!!!
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
450
Re-bonjour,

Désolé, j'ai écrit une bêtise. Je n'ai pas vu que ta plage couvrait les colonnes A à BS (et non pas A à B).
Essaie avec :
=SI(A19="";"";SIERREUR(RECHERCHEV(A19;Article!$A$1:$BS$9505;13;FAUX);""))

A+
marcogd3
Messages postés
9
Date d'inscription
mardi 11 mars 2008
Statut
Membre
Dernière intervention
11 mars 2015

Merci Gyrus pour ta réponse.

elle est excellente (ça fonctionne très bien)

pourrais-tu STP m'expliquer ce que signifie SIERREUR et à quoi correspond les deux guillemets après Faux

Merci d'avance

Marco
Gyrus
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
450 > marcogd3
Messages postés
9
Date d'inscription
mardi 11 mars 2008
Statut
Membre
Dernière intervention
11 mars 2015

Si la recherche n'aboutit pas (cas d'un élément inexistant dans la liste), la fonction RECHERCHEV renvoie une erreur.
La fonction SIERREUR permet de prendre ce cas en compte. La valeur retournée est alors celle qui est entre les deux guillemets après Faux.

A+
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
450
Bonjour,

Tu es sûr de ta formule ?
Tel que notée, la recherche se fait dans un tableau de 2 colonnes (A:B) et renvoie une valeur de la 13ème colonne !

A+
marcogd3
Messages postés
9
Date d'inscription
mardi 11 mars 2008
Statut
Membre
Dernière intervention
11 mars 2015

bonjour Gyrus

oui je suis sûr que c'est la valeur de la treizième colonne qui est renvoyé, mais également sur les lignes du dessous, tant qu'il n'y a pas de recherche!

Merci d'être attentif à mon problème,

Marco
Messages postés
2531
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
27 décembre 2019
292
Bonjour,

Ta formule de recherche est incomplète

=SI(A19="";"";RECHERCHEV(A19;Article!$A$1:$BS$9505;13;0))
gbinforme
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
3769
Bonjour,

0 ou "FAUX" sont tout à fait équivalents comme 1 et VRAI