Comptabiliser un nombre de case avec des chiffres et des lettres [Résolu/Fermé]

Signaler
Messages postés
19
Date d'inscription
mercredi 22 janvier 2014
Statut
Membre
Dernière intervention
30 avril 2017
-
 patauris -
Bonjour,
je voudrais additionner le nombre de case d'une même colonne en sachant qu'il y a des cases avec écrit 71 et d'autres avec 3P et 4P dans excel, quelle formule utiliser pour comptabiliser les cases 71, les cases 3p et 4p en sachant que je peux remplacer à tout moment le cases 71 par 3p ou 4p. Je ferais une case total pour 71 et 2 autres pour 3p et 4p.
merci d'avance pour votre aide.
cordialement

4 réponses

Bonjour

Il faut utiliser la formule Nb.Si
exemple : =Nb.Si(A1:A4;3p) cela te donnera le Nb de fois que 3p se trouve dans la colonne donnée.
Messages postés
87
Date d'inscription
mardi 10 juillet 2012
Statut
Membre
Dernière intervention
16 février 2017

Bonjour,

je n'ai pas très bien compris. Si c'est pour additionner un même nombre de critère, BOUDA08 a raison, il faut utiliser la fonction nb.si

Si c'est pour calculer le nombre de cellule non vide, utiliser la fonction nbval
Messages postés
12262
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
5 mars 2020
2 376
Bonjour,

Une petite erreur dans la formule de BOUDA08... Il faut y ajouter des guillemets pour 3p et 4p. Pas pour 71 :
=NB.SI(A1:A24;"3p")
=NB.SI(A1:A24;"4p")
=NB.SI(A1:A24;71)

Complément : pour avoir le total des 3 :
=NB.SI(A1:A24;"3p")+NB.SI(A1:A24;"4p")+NB.SI(A1:A24;71)

Cordialement,
Franck
Bonjour,
un grand merci à vous pour votre réponse, j'ai essayé et ça marche nickel avec la formule à pijaku.
cordialement.
patauris