Formule recherche d'une partie de texte (variable) dans colonne. [Résolu/Fermé]

Messages postés
44
Date d'inscription
lundi 1 juillet 2013
Statut
Membre
Dernière intervention
21 août 2013
-
Bonjour,

Je suis sur microsoft office 2007.

J'aimerais trouver si les cases d'une colonne contienne une partie de texte, cette partie de texte étant variable, afin que l'on puisse afficher : oui ou non

Pour vous indiquer l'utilisation de mon soucis:

J'aimerais qu'un utilisateur entre un numéro cas, comme par exemple 1333-74-0 dans la case G6 et que cela vérifie si ce numéro cas est contenu dans la colonne S de la feuille 3.

Dans cette feuille trois, chaque case peut contenir plusieurs numéro cas donc la recherche en respectant la case est exclu. exemple de case: -1333-74-0 -6574-54-3

Je ne peut de même pas utiliser des solutions:
=SI(ESTNUM(CHERCHE("v",A2)),"OK", "Non OK") Vérifie que la cellule A2 contient la lettre t (OK)
=ESTNUM(CHERCHE("BD",A3)) Vérifie que la cellule A3 contient BD (VRAI)

Car ici les "" font que ce que l'on cherche est fixe. Moi j'aimerais que cela ce modifie si je tape autre chose que 1333-74-0 Ce qui nest pas le cas ici.

Merci par avance si une personne a une idée.

Cordialement,

Alex

PS: C'est possible en fesant ctrl+f et en mettant sans respecter la case, mais cela n'est pas automatique et il faut changer de feuille.
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
11367
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
19 novembre 2019
1517
1
Merci
Bonjour

Une possibilité exemple: http://cjoint.com/?0GyrOVpd1ga

Si j'ai bien compris ce que tu veux !

Cdlmnt

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 6036 internautes nous ont dit merci ce mois-ci

Messages postés
1513
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
117
0
Merci
Bonjour,

Je vais peut etre paraître bête et cela ne va peut être pas t'aider ou j'aurais mal compris la question.

Mais pourquoi ne mets tu pas ce que tu cherches dans une cellule précise.
ex : en C2, tu mets ce que tu cherches : T
et donc au lieu d'écrire :
=SI(ESTNUM(CHERCHE("v",A2)),"OK", "Non OK") Vérifie que la cellule A2 contient la lettre t (OK)

tu peux écrire :
=SI(ESTNUM(CHERCHE(C2,A2)),"OK", "Non OK") Vérifie que la cellule A2 contient la lettre t (OK)
Messages postés
44
Date d'inscription
lundi 1 juillet 2013
Statut
Membre
Dernière intervention
21 août 2013
0
Merci
Bonjour mélanie, j'avais essayé la possibilité de remplacer "v" par C2 et A2 par ma colonne. Mais cela ne fonctionnait pas, je ne sais pas pourquoi. (erreur avec les ; parenthèses...)

Bonjour via et merci pour ta réponse, cependant j'avais oublié de dire quelquechose, mes valeur des numéros cas sont lié a un autre document.

Ceci implique que si on clic sur la cellule l'on ne trouve pas la valeur mais seulement le chemin d'accès, alors qu'apparaît au repos belle et bien la valeur.

Ta réponse marche cependant trés bien avec les valeurs fixes (pas les chemins d'accés), il faudrait que j'essaye de les copier et coller de cette manière automatiquement.

Merci pour votre aide en tout cas.




Après avoir simplement crée une autre colonne avec =... c'est bien seulement la valeur qui est répercuté donc c'est parfait.

Il m'a juste suffit ensuite dans la formule de via de changer de colonne discriminé.

Résolu! Merci à tout les deux