Menu

Installer le module perl/TK [Résolu/Fermé]

- - Dernière réponse : kavalski2010
Messages postés
2
Date d'inscription
mardi 17 mai 2011
Statut
Membre
Dernière intervention
17 mai 2011
- 17 mai 2011 à 12:58
bonjour
j'ai commencer a programmer sous linux.
je programme avec perl.
quand j'ai voulu programmer des interfaces, on m'a dis que c'est tres sympa et facile avec le module TK, je l'ai donc telecharger mais pendant l'installation il me dis qu'il ne trouve pas le X , je l'ai donc compilé avec le chemin /usr/X11R et cela ne marche pas
(/usr/X11R6 existe )

l'installtion je sui seulement les indications de fichier d'installation qui est avec le module telechargé.
je ne comprend pas se que je fais!
merci de m'avoir aidé.
Afficher la suite 

10 réponses

0
Merci
Bonjour,

Pour compiler le module Tk:

tar xvzf Tk.num.version.tar.gz
cd Tk.num.version
$perl Makefile.pl
$make
$make test
#make install

@+
0
Merci
merci de m'avoir repondu.

c'est ça se que j'ai fais pour la premiere fois.
il m'a donner une erreur en disant qu'il ne trouve pas le X .
donc j'ai compiler avec le chemin "/usr/X11R6" .
et il me donne encore l'erreur qu(il ne trouve pas des fichiers dans include et des librairies dans lib...
0
Merci
Les bibliothèques X sont elles installées sur ton système?

@ +
0
Merci
la je ne sais plus !

j'ai deja un dossier X11R6 dans usr . je crois que c'est ça le dossier des bibliotheques X.
le dossier libs est pleins !
le dossiers include est a peu pres vide !! et c'est lui qui pose le probleme pendant l'installtion . les messages d'erreur concerne se dossier.
vous pouver me dire comment verifier si les bibliotheques sont installées ?
et le nom du pakage a installer en cas ou je trouve quellle ne sont pas deja installer dans un autre chemin?
0
Merci
Il faut installer XFree86-devel ou Xorg-devel selon le systeme X que tu utilise.
Quelle distribution linux utilises-tu?

@+
0
Merci
j'utilise mandrak10.1 .

pardon je ne t'es pas encore remercié de m'avoir repondu. merci
0
Merci
Il faut installer le paquet XFree86-devel ou Xorg-devel qui correspond à la version de X qui est installée sur ton systeme au moyen de rpmdrake ou de urpmi (je crois car je n'utilise pas Mandrake)

Ok?

@+

0
Merci
ok
merci de ton aide .
je vais installer les bibliotheques .
a+
0
Merci
voila !
j'ai trouvé une autre solution. j'ai pas pu installer les bibliotheques ; toujours il y un truc qui n'est pas satisfait.
donc j'ai telecharger ActivePerl et le perl/Tk marche tres bien.
quelle joie de voir les merveilleuses fenetres !
merci de votre aide mon ami.
Messages postés
2
Date d'inscription
mardi 17 mai 2011
Statut
Membre
Dernière intervention
17 mai 2011
0
Merci
bonjour,
moi j'ai un problème avec l'installation de perl TK sous windows a chaque fois que j'essaye de l'installer il m'affiche l'erreur suivante sur l'invite de commande:
>ppm install TK
ERROR installing package 'Tk' :could not locate a PPD file for package tk

merci de votre aide.