Unexpected end of MySQL [Résolu/Fermé]

Signaler
Messages postés
94
Date d'inscription
samedi 18 octobre 2008
Statut
Membre
Dernière intervention
25 août 2015
-
eyepcos
Messages postés
1
Date d'inscription
dimanche 3 janvier 2010
Statut
Membre
Dernière intervention
19 mars 2015
-
Bonjour, tout est dans le titre XD, blague à part, j'ai récemment installé easyPHP [car wampserver ne marche pas] et lorsque je le lance, un message d'erreur s'affiche en disant : "Unexpected end of MySQL", donc sans plus attendre je suis allez chercher sur internet, et j'ai trouvé des solutions mais toutes aussi mal expliquées les une que les autres :
1°) "Renomme ton fichier My.ini" ... ouai merci mais le renommer en quoi ? "mangedespoules.ini" ?
2°) "Tu as une ancienne version d'easyPHP" ... sauf que j'ai la 3 :/

Enfin voila si quelqu'un a des explications CLAIRE à fournir je lui en serait très reconnaissant.

5's

15 réponses

Messages postés
137
Date d'inscription
vendredi 28 novembre 2008
Statut
Membre
Dernière intervention
23 août 2013
58
Ca y est. Pour moi ça marche.
J'ai trouvé la solution sur http://ryan.rawswift.com/2009/09/20/easyphp-on-64-bit-windows-7-how-to-fix-apache-and-mysql-problem/

je vous traduit/résume la partie qui concerne mysql :

- ouvrir le dossier "C:\Program Files (x86)"
- faire bouton droit -> propriétés sur le dossier d'EasyPhp
- dans l'onglet sécurité, cliquer sur le bouton "Modifier..."
-dans la liste "Noms de groupes ou d'utilisateurs", sélectionner l'utilisateur actif : "Utilisateurs (Nom_de_mon_ordi\Utilisateurs)", puis dans la liste "Autorisations pour les Utilisateurs" cocher la case "Contrôle total" de la colonne "Autoriser" (ça doit tout cocher).
- cliquer sur "OK"

Vous pouvez alors redémarrer mysql. Ca devrait fonctionner
17
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86548 internautes nous ont dit merci ce mois-ci

on vous remerciiiiiiiiiiiii :)
merciiiiiiiiiiii bcp
Merci beaucoup mon ga je pas encore essayai mais d'apres le remerciment des colegues merci
je essaye mais il signale le meme probleme
Merci Beaucoup!! ca Marche Bien!
pour ceux qui ne souhaitent pas désactiver le contrôle des utilisateur, on peu lancer easyphp en mode administrateur : Clic droit sur l'icone --> executer en tant qu'administrateur

ca a marché pour moi ;)
merci petitwilly,
cela a fonctionne pour moi.
As tu une idee de la root cause ?
Oui, ok, c'est la seule bonne réponse pour les Windows Vista ou Seven

Serge
eyepcos
Messages postés
1
Date d'inscription
dimanche 3 janvier 2010
Statut
Membre
Dernière intervention
19 mars 2015

merci bcp
Bonjour,
J'ai eu le même message "Unexpected..."et impossible de démarrer mon serveur Mysql sous easyphp 3 et Vista. c'était simplement l'activiation du "controle de compte utilsateur" de Vista. Il suffit donc de le décocher dans le panneau de config/comptes d'utilsateurs/activer ou desactiver le controle des comptes.
A+
c génial merciii bcp ca a marché
Messages postés
94
Date d'inscription
samedi 18 octobre 2008
Statut
Membre
Dernière intervention
25 août 2015
2
Effectivement le problème était bien là ... Merci beaucoup ^^
Messages postés
375
Date d'inscription
mercredi 18 février 2009
Statut
Membre
Dernière intervention
7 août 2009
50
décidément Esope tu l'aimes bien ce forum ;)
Messages postés
94
Date d'inscription
samedi 18 octobre 2008
Statut
Membre
Dernière intervention
25 août 2015
2
Bah c'est surtout très pratique quand on débute :)

Mais je vois que tu l'aimes bien aussi tu as 430 messages en 1 mois :p
elanore31
Messages postés
375
Date d'inscription
mercredi 18 février 2009
Statut
Membre
Dernière intervention
7 août 2009
50
je confirme ;) moi je poste pas trop de sujet. je répond en général ... et puis j'apprend en lisant les réponses :)
Bonjour,

Perso je suis sous Windows Seven et les paramettres donné par pseudosb si dessus je ne les retrouve pas.

Donc j'ai executé la réponse de petitwilly (juste au dessus de la mienne) et quand je veux aller sur phpmyadmin j'ai l'erreur ci-dessous.

Erreur

MySQL a répondu:Documentation
#2003 - Can't connect to MySQL server on 'localhost' (10061)


Merci de votre aide

Bruno
merci a pseudosb tu m'as vraiment aider
et a tous les autre bon chance
Messages postés
137
Date d'inscription
vendredi 28 novembre 2008
Statut
Membre
Dernière intervention
23 août 2013
58
Salut.

Je remonte le post, parce que, comme byters, je suis sous windows 7, et les tuyaux donnés pour Vista ne s'appliquent pas à ce système.

Quelqu'un aura-t-il une solution pour Seven ? (Je peux vous copier le rapport de log de mysql si vous voulez)

Je suis sous Windows 7 64 bits. Ce forum m'a bien aidé et voici mon retour d'expérience pour les mêmes problèmes avec EasyPhp 5.3.0
1/ Apache ne se lançait pas à cause de Skype qui utilisait le même port.
Solution : Dans Skype (4.1.0.179) cliquer sur Outils>Options>Avancées>Connexion : décocher la case "utiliser les ports 80 et 443 comme alternative"

2/ MySQL ne se lançait pas non plus à cause du contrôle de compte d'utilisateur (comme cité ci-dessus)
J'ai été dans le répertoire d'installation de easyphp puis clic droit sur l'executable Propriété>Compatibilité puis j'ai coché dans "Niveau de privilège" la case "Exécuter ce programme en tant qu'administrateur"

Et maintenant tout roule...
merciiiiiiiiiiiiiiiiii bcp juanou
Pour moi aussi ça ne fonctionnait pas sous Windows 7 x64 avec EasyPHP 5.3.0.

En voulant appliquer la solution de TheExcalibur dans l'onglet Compatibilité des propriétés de EasyPHP-5.3.0.exe, j'ai remarqué l'autre option : Mode de comptabilité.
J'ai coché "Exécuter ce programme en mode de compatibilité pour" et gardé le choix proposé par défaut "Windows XP (Service Pack 3)".
Et là, sans cocher la case dans "Niveau de privilège", ça marche aussi !

Cela dit, quelque chose est étonnant : j'ai Win7 Home, et il a toujours été dit que le mode de compatibilité XP n'est disponible qu'à partir de Win7 Enterprise ; d'ailleurs, sur d'autres .exe, ça reste grisé !
Allez dans "Poste de travail", ouvert / Voir le lecteur C, puis double-cliquez sur "Program Files (x86)".
Faites un clic droit sur "EasyPHP5.3.0 dossier" puis cliquez sur "Propriétés".
Sur "Sécurité" cliquez sur l'onglet "Modifier ..." .
Sélectionnez l'utilisateur que vous utilisez actuellement.
Sous la rubrique «Autorisations pour utilisateurs", cochez "Contrôle total" sur "Autoriser" .
Et puis cliquez sur "OK" pour appliquer les modifications.
Maintenant, vous serez en mesure de démarrer le serveur MySQL en cliquant sur "MySQL" bouton de la boîte de dialogue EasyPHP, puis cliquez sur "Démarrer".

Hope this helps!
Geniallll merci beaucoup!!!!!!!! effectivement fallait mettre les bons droits sur l'exe là tout fonctionne sous windows 7.

Fallait le savoir!!!

Merci à TheExcalibur
Merci ! Impec sous Seven cette astuce