Signaler

3 conditions et message d'erreur [Résolu]

Posez votre question Decapo78 3Messages postés lundi 2 octobre 2017Date d'inscription 2 octobre 2017 Dernière intervention - Dernière réponse le 2 oct. 2017 à 17:43 par diablo13800
Bonjour à tous
je n'arrive pas à utiliser la fonction si avec 3 conditions.
je souhaite créer une condition qui me permet :
à partir d'une date limite Exemple le 15/09/2017
si je saisi une date inférieur ou égal à cette date je suis dans les temps
si je saisi une date supérieur a la date indiquer je ne suis plus dans les temps;
et si je saisi rien je ne suis pas conforme.

exemple
=SI(H$2>=H11;"à temps";SI(ET(H$2<H11;H$2<H11);"hors temps";"NOK"))
H$2 = date limite 15/09/2017
H11 = et la date de saisi
ce qui donne
si H11 est inférieur à la date limite "à temps"
si H11 est supérieur à la date limite "hors temps"
si je saisi aucune date je suis NOK " Non Ok"

J'ai essayer plusieurs fois et les résultats ne correspond que pour à temps et hors temps mais pas pour Nok.

dans un second temps

je souhaite introduire des messages d'erreur
par exemple si je saisi une autre information que la date alors j'ai un message d'erreur dans le cas contraire c'est bon.

J'espère que quelqu'un pourra éclairer ma lanterne s'il vous plait, merci d'avance
Utile
+1
plus moins
Bonjour,

Normal que NOK ne fonctionne pas... puisqu'il ne peut pas existait...
Vos conditions sont un peu bizarres... Et redondantes...

Faite plutot quelque chose comme ça :
=Si(H$2="";"NOK";Si(H$2<H11;"Hors Temps";"à temps))

C'est plus simple et ça reprend vos conditions

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
Decapo78 3Messages postés lundi 2 octobre 2017Date d'inscription 2 octobre 2017 Dernière intervention - 2 oct. 2017 à 17:26
Simple c'est toujours mieux merci
tu m'enlève une première épine du pied
Répondre
diablo13800 912Messages postés jeudi 2 juillet 2015Date d'inscription 11 octobre 2017 Dernière intervention - 2 oct. 2017 à 17:34
Concernant votre deuxième problème il existe des validations de données possible :
Sélectionner la case où vous voulez votre validation
Allez dans "Données => Validation des données => validation des données".
Sélectionner que seul les date sont autorisé

Si cette solution ne vous parait pas correcte, il vous faudra passé par du VBA ( en espérant qu'un meilleur que moi puisse passé pour un début de solution :) )
Répondre
Decapo78 3Messages postés lundi 2 octobre 2017Date d'inscription 2 octobre 2017 Dernière intervention - 2 oct. 2017 à 17:42
je te remercie Diablo13800
pour ton aide ça fonctionne
Répondre
diablo13800 912Messages postés jeudi 2 juillet 2015Date d'inscription 11 octobre 2017 Dernière intervention - 2 oct. 2017 à 17:43
N'oublie pas de passer le sujet en résolu , ça pourrait en aider plus d'un :)
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !