Signaler

Problème plutôt bizarre en SSH ^^

Posez votre question bibou55 69Messages postés jeudi 4 septembre 2014Date d'inscription 7 octobre 2017 Dernière intervention - Dernière réponse le 3 juin 2017 à 20:46 par mamiemando
Bonjour,
J'ai à ma disposition 1 portable sous ubuntu, et un raspberry pi 3 sous raspbian (debian optimisé)
Pour me connecter depuis ma freebox vers n'importe quel serveur, aucun problème (je recherche un site sur google, je tape "host lenomdusite.com", une IP ressort, je fais ssh root@ip et tout fonctionne bien. Le terminal me demande d'accepter la key fingerprint ou pas puis me demande le mot de passe etc)

Si je fais cette manipulation depuis mon Raspberry, même résultat, cela fonctionne (fin du moins, la procédure normale, puisque j'ai pas le code hein ^^)


Bon, maintenant, je souhaite me connecter à mon raspberry pi en SSH depuis mon pc, je configure mon DNS, mes redirections de port etc (je l'avait deja fait il y a environ un an avec ma tour de pc)
Un petit "root@localhost" devrait faire l'affaire
et bim : ssh: connect to host localhost port 22: Connection refused

je décide de mettre mon pc portable hors connexion juste pour voir, et j'ai exactement le même resultat...

Maintenant, je refais la même manipulation mais cette fois ci, de mon raspberry pi vers mon pc en SSH pour voir d'ou pourrait venir le problème, et j'ai encore cette foutue erreur...

J'appèle un ami pour qu'il configure son pc sous ubuntu de manière à ce que je puissey acceder en SSH depuis chez moi, et là, ca fonctionne...

Le problème vient donc ET de mon pc ET de mon raspberry, même en hors connexion avec n'importe quel utilisateur

Que faire svp, j'ai vraiment besoin d'aide, j'ai un projet à terminer avant fin septembre, il est même pas encore commencé que ca merde déjà x)

Help please :)
cdt
Utile
+1
plus moins
Bonjour

Un petit "root@localhost" devrait faire l'affaire
et bim : ssh: connect to host localhost port 22: Connection refused


Deux choses :
-
ssh root@localhost
signifie que ton client ssh se connecte au serveur ssh localhost, c'est-à-dire la même machine.
- en ssh on ne se connecte jamais en root : d'une part c'est un login qui existe sur toute les machines linux et de plus, c'est le profil administrateur. Autant dire que c'est le profil qu'il est le plus tentant d'attaquer. C'est la raison pour laquelle les authentifications en root par ssh sont une mauvaise idée. Par défaut, sur les systèmes récents, les serveurs ssh sont configurés pour rejeter de telles authentifications.

Ensuite pour ta question, il faudrait qu'on ait une vision plus claire des différents scénarios que tu as testé. A priori si le client et le serveur ssh correspondent à deux machines dans ton réseau domestique, il n'y a pas besoin de faire de redirection de port. Ceci ne sert que si quelqu'un souhaite se connecter à un serveur (ici ssh) depuis l'extérieur de ton réseau domestique.

Tu pourrais aussi regarder avec
ssh -vvv login@adresse
ce qui ne va pas. Les messages révéleront sans doute des choses...

Bonne chance
Cette réponse vous a-t-elle aidé ?  
Donnez votre avis
Utile
+0
plus moins
quelle est ta configuration du fichier /etc/ssh/sshd_conf ?
bibou55 69Messages postés jeudi 4 septembre 2014Date d'inscription 7 octobre 2017 Dernière intervention - 31 mai 2017 à 21:32
yohann@ldlcaurore:~$ cd /etc/ssh/
yohann@ldlcaurore:/etc/ssh$ ls
moduli ssh_config

Il n'existe pas ^^
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour,
Alors voici les étapes :

-Depuis mon pc :
Ouverture du terminal (ma session s'appelle "yohann")
--> sudo su
--> mdp
Je suis maintenant en root
--> ssh -vvv yohann@localhost
résultat :

root@ldlcaurore:/home/yohann# ssh -vvv yohann@localhost
OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: connect to address 127.0.0.1 port 22: Connection refused
ssh: connect to host localhost port 22: Connection refused




J'essaye maitenant de me connecter à mon raspberry, toujours depuis mon pc en session root :

root@ldlcaurore:/home/yohann# ssh -vvv pi@localhost
OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: connect to address 127.0.0.1 port 22: Connection refused
ssh: connect to host localhost port 22: Connection refused


A noter que dans les 2 cas, c'est la même IP locale qui ressort"127.0.0.1"



J'essaye maintenant de me connecter à un serveur trouvé au hasard sur internet :

yohann@ldlcaurore:~$ ssh -vvv root@kpourkatrine.com
OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to kpourkatrine.com [162.210.100.197] port 22.
debug1: Connection established.


Que faire svppp x) je comprends plus rien ^^
zipe31 35055Messages postés dimanche 7 novembre 2010Date d'inscription ContributeurStatut 18 octobre 2017 Dernière intervention - 1 juin 2017 à 20:37
Salut,

Déjà, pourquoi passer en root pour faire un
ssh -vvv yohann@localhost
?

Ensuite,
ssh -vvv pi@localhost
ne peut aboutir car localhost représente ta propre machine d'où tu lances la connexion ;-\

Si le fichier ssh_config n'existe pas, c'est qu'il y a une c*uille dans le potage ;-((

$ apt-file list openssh
openssh-client: /etc/ssh/moduli
openssh-client: /etc/ssh/ssh_config
openssh-client: /usr/bin/scp
openssh-client: /usr/bin/sftp
openssh-client: /usr/bin/slogin
openssh-client: /usr/bin/ssh
openssh-client: /usr/bin/ssh-add
openssh-client: /usr/bin/ssh-agent
openssh-client: /usr/bin/ssh-argv0
openssh-client: /usr/bin/ssh-copy-id
openssh-client: /usr/bin/ssh-keygen
openssh-client: /usr/bin/ssh-keyscan
openssh-client: /usr/lib/openssh/ssh-keysign
openssh-client: /usr/lib/openssh/ssh-pkcs11-helper
openssh-client: /usr/share/apport/package-hooks/openssh-client.py
openssh-client: /usr/share/doc/openssh-client/NEWS.Debian.gz
openssh-client: /usr/share/doc/openssh-client/OVERVIEW.gz
openssh-client: /usr/share/doc/openssh-client/README
openssh-client: /usr/share/doc/openssh-client/README.Debian.gz
openssh-client: /usr/share/doc/openssh-client/README.dns
openssh-client: /usr/share/doc/openssh-client/README.tun.gz
openssh-client: /usr/share/doc/openssh-client/changelog.Debian.gz
openssh-client: /usr/share/doc/openssh-client/copyright
openssh-client: /usr/share/doc/openssh-client/faq.html
openssh-client: /usr/share/lintian/overrides/openssh-client
openssh-client: /usr/share/man/man1/scp.1.gz
openssh-client: /usr/share/man/man1/sftp.1.gz
openssh-client: /usr/share/man/man1/slogin.1.gz
openssh-client: /usr/share/man/man1/ssh-add.1.gz
openssh-client: /usr/share/man/man1/ssh-agent.1.gz
openssh-client: /usr/share/man/man1/ssh-argv0.1.gz
openssh-client: /usr/share/man/man1/ssh-copy-id.1.gz
openssh-client: /usr/share/man/man1/ssh-keygen.1.gz
openssh-client: /usr/share/man/man1/ssh-keyscan.1.gz
openssh-client: /usr/share/man/man1/ssh.1.gz
openssh-client: /usr/share/man/man5/moduli.5.gz
openssh-client: /usr/share/man/man5/ssh_config.5.gz
openssh-client: /usr/share/man/man8/ssh-keysign.8.gz
openssh-client: /usr/share/man/man8/ssh-pkcs11-helper.8.gz
openssh-client: /usr/share/upstart/sessions/ssh-agent.conf
openssh-server: /etc/default/ssh
openssh-server: /etc/init.d/ssh
openssh-server: /etc/init/ssh.conf
openssh-server: /etc/network/if-up.d/openssh-server
openssh-server: /etc/pam.d/sshd
openssh-server: /etc/ufw/applications.d/openssh-server
openssh-server: /lib/systemd/system/ssh.service
openssh-server: /lib/systemd/system/ssh.socket
openssh-server: /lib/systemd/system/ssh@.service
openssh-server: /usr/lib/tmpfiles.d/sshd.conf
openssh-server: /usr/sbin/sshd
openssh-server: /usr/share/apport/package-hooks/openssh-server.py
openssh-server: /usr/share/doc/openssh-client/examples/sshd_config
openssh-server: /usr/share/doc/openssh-server
openssh-server: /usr/share/lintian/overrides/openssh-server
openssh-server: /usr/share/man/man5/authorized_keys.5.gz
openssh-server: /usr/share/man/man5/sshd_config.5.gz
openssh-server: /usr/share/man/man8/sshd.8.gz
openssh-sftp-server: /usr/lib/openssh/sftp-server
openssh-sftp-server: /usr/lib/sftp-server
openssh-sftp-server: /usr/share/doc/openssh-sftp-server
openssh-sftp-server: /usr/share/man/man8/sftp-server.8.gz
Répondre
bibou55 69Messages postés jeudi 4 septembre 2014Date d'inscription 7 octobre 2017 Dernière intervention - 1 juin 2017 à 23:27
le fichier ssh_config existe, mais pas le sshd_config
Répondre
Flachy Joe 2111Messages postés jeudi 16 septembre 2004Date d'inscription 2 octobre 2017 Dernière intervention - 2 juin 2017 à 09:08
Salut,
Le fichier
/etc/ssh/ssh_config
gère le client ssh alors que
/etc/ssh/sshd_config
gère le serveur.
Tu n'as pas sans doute pas installé le serveur ssh sur ton PC, d'où la réponse à ta tentative de connexion.

Le nom de domaine à indiquer dans la commande est bien celui de l'ordi sur lequel on veux se connecter, donc
ssh bidule@localhost
, ce connectera sur l'ordi sur lequel est lancé la commande.
Autrement dit si tu tapes cette commande sur le pi tu ouvriras une session sur le pi, si tu tapes cette commande sur le pc, tu te loggeras sur le pc (ça n'a aucun intérêt quoi).

Donc pour te connecter au pi depuis le pc :
ssh pi@nom_ou_ip_du_pi
(Sous réserve que le serveur ssh soit activé sur le pi, à vérifier avec la commande
sudo raspi-config
doc ici : https://www.raspberrypi.org/documentation/configuration/raspi-config.md )

Pour te connecter au pc depuis le pi : Installe le serveur ssh sur le PC puis
ssh user@nom_ou_ip_du_pc


Comme déjà indiquer (j'enfonce le clou) les connexions en root sont fortement déconseillées (que ce soit via sudo -i ou en ssh) et sont désactivées par défaut en ssh.
Répondre
mamiemando 27988Messages postés jeudi 12 mai 2005Date d'inscription ModérateurStatut 17 octobre 2017 Dernière intervention - 3 juin 2017 à 20:46
Entièrement d'accord avec Flachy Joe :
http://www.commentcamarche.net/forum/affich-34627606-probleme-plutot-bizarre-en-ssh#8
Répondre
Donnez votre avis
Utile
+0
plus moins
UP
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !