Signaler

INDEX EQUIV ou RECHERCHEV [Résolu]

Posez votre question olis8319 52Messages postés samedi 21 janvier 2017Date d'inscription 17 mai 2017 Dernière intervention - Dernière réponse le 17 mai 2017 à 12:56 par olis8319
Bonjour,
je vous joint un fichier qui a en colonne A 15003 références possible (une note a 3 décimales)
et en fonction de cette note un nombre de points Championnat est attribué colonne B. En cellule F2 et G2 j'ai 2 essais de formule RECHERCHEV et INDEX EQUIV mais rien ne fonctionne !!
Quelqu'un connaîtrait il la cause de ce dysfonctionnement ?

La règle exacte d'attribution des points est la suivante: si le candidat a une note
<= 55.000 il obtient 0 point au championnat,
si le candidat a une note comprise entre
55.001 et 70.000 les points au championnat sont calculés dans la colonne B
Si le candidat a une note
>= 70.001 il obtient 61 points au championnat

Merci d'avance

http://www.cjoint.com/c/GErgF3sR387
Afficher la suite 
Utile
+0
plus moins
Bonjour
Il devrait y avoir une option calculer sur la valeur affichée car il y a des décimales "lointaines" non à zéro.

Pour voir augmenter les décimales dans le format

exemple dernière ligne 70,001 donne 70,00100000001

ou en A2
=ARRONDI(A2+0,001;3)



aide
olis8319 52Messages postés samedi 21 janvier 2017Date d'inscription 17 mai 2017 Dernière intervention - 17 mai 2017 à 09:31
Merci ça marche super
J ai coller =ARRONDI(A2+0,001;3) sur toute la colonne A et tout fonctionne.

Dernière chose aurait tu une proposition pour que les notes <= a 55.000 donne 0 points championnat
et pour que les notes >= 70.001 donne 61 points au championnat

En tout cas encore merci yclik
Répondre
yclik 1057Messages postés vendredi 25 juillet 2014Date d'inscription 21 juin 2017 Dernière intervention - 17 mai 2017 à 09:50
=SI(E2<=55;0;SI(E2>=70,001;61;INDEX(B2:B15003;EQUIV(E2;A2:A15003;0))))
Répondre
olis8319 52Messages postés samedi 21 janvier 2017Date d'inscription 17 mai 2017 Dernière intervention - 17 mai 2017 à 12:56
Nickel ça fonctionne parfaitement.
cela montre toute la différence entre un novice et un expert.

Encore Merci yclik

Cdt Olis
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !