Posez votre question Signaler

Excel si ma cellule contient tel texte [Résolu]

caba_44 89Messages postés lundi 14 décembre 2009Date d'inscription 10 juillet 2013 Dernière intervention - Dernière réponse le 26 juin 2015 à 18:17
Bonjour à tous,
J'ai un léger soucis que je souhaiterais pouvoir faciliter par une formule.
Si ma cellule A1 contient le texte "NBR" alors écrire NBR en cellule B1
Sachant que la cellule A1 = O'Ring NBR 70 Shore A.
Comment faire ?
En attendant de vous lire,
Mathieu
Lire la suite 
Réponse
+75
moins plus
Bonjour
en B1
=SI(NB.SI(A1;"*NBR*");"NBR";"")
attention aux signes
crdlmnt
Ricky38 4406Messages postés samedi 15 mars 2008Date d'inscription ContributeurStatut 29 décembre 2014 Dernière intervention - 3 avril 2013 à 13:56
Salut,

regarde du coté des SI imbriqués
exemple: =SI(A1=1;"ok";SI(A1=2;"Super";SI(A1=3;"excellent";"")))
Répondre
MP- 25 sept. 2013 à 11:47
Super solution, j'aimerais juste comprendre pourquoi on utilise le nb.si dans ce cas.
J'ai essayé la même formule sans le nb.si et ca ne fonctionne pas.

Pouvez-vous m'epxliquer la logique derrière cette formule ? (le nb.si et normalement fait pour "compter" le nombre d'occures non ? :)
Répondre
Delegation- 7 oct. 2013 à 14:19
MERCIIIIIII !!!!!!!!! Au fin j'ai trouvé la solution pour m'aider :)
Répondre
AudreyBdo 2Messages postés lundi 7 avril 2014Date d'inscription 9 avril 2014 Dernière intervention - 9 avril 2014 à 14:37
NB permet d'indiquer le nombre d'occures effectivement, et dans le cas présent avec la fonction si, permet de dire s'il y a au moins 1 fois le Nombre/terme cité.
Répondre
Colle- 20 janv. 2015 à 16:53
Bonjour,

Dans la même lignée, je souhaite savoir s'il est possible, pour reprendre l'exemple tout en haut, que dans la formule =SI(NB.SI(A1;"*NBR*");"NBR";"")
"*NBR*" soit un renvoi vers une cellule mais que la formule agisse comme "contient".
Ex : =SI(NB.SI(A1;B1);B1;"") où B1 est par exemple "NBR" et qu'excel aille rechercher tous les textes contenant "NBR"
Répondre
Ajouter un commentaire
Réponse
+1
moins plus
une idée

=DROITE(SUPPRESPACE(GAUCHE($A$1;CHERCHE(CONCATENER(CAR(78);CAR(66);CAR(82));$A$1;1)+NBCAR($A$2)));NBCAR(A2))

ou CAR(78) = N
CAR(66) = B
CAR(82) = R
NBCAR(A2) = le nombre de caratère rechercher
cherche(CONCATENER(assemble les trois caratéres et donne la position de départ)
SUPPRESPACE enléve les espaces inutiles
Gauche prend un nombre de caratéres à partir de la gauche, ce nombre est défini par la fonction chercher dans A1
Droite prend un nombre de caractéres à partir de la droite défini par NBCAR A2
Ajouter un commentaire
Réponse
+0
moins plus
Super ca fonctionne...

Je vous remercie pour votre retour

A très bientôt :)

Mathieu
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,

Dans la même lignée, comment faire :

Si cellule A1 contient "Dimanche" alors calculer "A2*1,2"

Ceci ne marche pas:
=SI(NB.SI(A1;"*dimanche*");"=A2*1,2";"")


Merci d'avance
Ajouter un commentaire
Réponse
+0
moins plus
Salut Amaury,

=SI(NB.SI(A1;"*dimanche*");A2*1,2;"")

Voila
Tof- 9 déc. 2014 à 11:19
bonjour,
j'ai le même soucis, sauf que mon "samedi" vient d'une case qui comprend une formule qui permet d'afficher "samedi"

Case 1 = 13-12-2014 (sur feuil2)
Case 2 = =SI(Feuil2!A5="";"";Feuil2!A5) affichage de la cellule en [$-80C]jjjj
Case 3 = =SI(NB.SI(A15;"*samedi*");"40";"30")

Un grand merci si vous savez répondre.
Répondre
Pullin- 4 juin 2015 à 14:04
Bonjour, tu as essayé de copier/coller ta cellule "samedi" en valeur ?
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,

Et si je veux que quand ma colonne A1 affiche FRANCE, ma colonne A2 mette FR, si elle n'affiche pas France, A2 affiche INT et si elle est vide, A2 reste vide?

Merci beaucoup
clemar- 25 avril 2014 à 16:36
Bonjour Roxane,

Je pense que la réponse à ta question c'est les condition imbriquée comme précisait Ricky38.
=Si(A1="FRANCE";"FR";si(A1="";"";si(A1<>"FRANCE";"INT";)))

Quant à moi ma question serait :

Je veux faire : SI A1 = "TXT" ALORS A2 SINON 0
Et le TXT serait une case dans laquelle se trouve une liste déroulante. Est ce possible?

Merci par avance!
Répondre
clemar- 25 avril 2014 à 16:45
Réponse à ma propre question:
=SI(A1=K1;A2;0)
j'avais juste fait l'erreur d'écrire
=SI(A1="K1";A2;0)
Répondre
GeGe75- 6 mai 2014 à 10:14
Bonjour,

Je cherche une formule imbriquée qui me permette de saisir automatiquement l'adresse mail en me basant sur le prénom et nom des destinataires...

Si vs m'avais compris merci de m'aider :-)

Cordialement,
Répondre
lalla- 28 mai 2014 à 10:05
Salut tout le monde,
j'ai un problème aussi sur Excel c'est que il faut que je parcours chaque colone et vérifier si le contenu de chaque celulle contient des caractères spéciaux si oui, il le remplace par des caractères normaux. aidez moi svp
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
Salut,

J'ai un problème, je souhaiterais quand j'ai 2 mots dans une cellule diviser le cout associé en 2.

Par exemple, j'ai BE + LIO pour un cout de 500 comment je peux faire pour avoir en A1 BE avec en A2 250 et en B1 LIO avec en B2 250
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,
Je viens de lire les différentes informations et j'aurai besoin d'un renseignement,
Comment dois je m'y prendre pour dire : Si le mot de la colonne A2 et dans le texte de la colonne A1 alors c'est ok sinon rien. SVP merci.
Ajouter un commentaire
Réponse
+0
moins plus
Bonjour,

Je recherche une formule qui me permette de compter le nombre de case contenant une info exemple

SS AQ 010
SS AQ 011
SS AS 009
SS AT 003
SS AU 002
SS AU 008

La formule me permettrai de déterminer qu'il y'a 2 cellule contenant les lettre AQ, 1 cellule contenant les lettres AS etc

en espérant avoir bien exposé ma demande
Ajouter un commentaire
Réponse
+0
moins plus
Imaginons :
A1 SS AQ 010
A2 SS AQ 011
A3 SS AS 009
A4 SS AT 003
A5 SS AU 002
A6 SS AU 008


=COUNTIF(A1:A6;"*AQ*") 2 cellulles contiennent AQ

Utiliser "* TEXT*" signifie que je ne cherche pas un text exact mais bien dès que AQ apparait
Ajouter un commentaire
Réponse
+0
moins plus
Tu devrais pouvoir trouver ce que tu cherchers la :
http://www.yvoz.net/2010/09/excel-tester-chaine-caracteres-contient/
SSSS- 26 juin 2015 à 17:54
J'ai un soucis pour la première formule j'aimerais récupérer le *NBR* a partir de l'extraction d'une chaîne.
exple : je parcourir une liste d'element dans la colonne A, et trouver le nombre de fois qu'elle les elements de la colonne b. e
Répondre
SSSS- 26 juin 2015 à 18:17
ssss pour compléter ma question
+NB.SI($H$12:$H$38;"*7*"),
la formule ci dessus pourrait répondre à mon besoin , mais "*7*" doit etre une variable qui est récupérer
dans une cellule.
Répondre
Ajouter un commentaire
Ce document intitulé «  Excel si ma cellule contient tel texte  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.