CommentCaMarche
Recherche
Posez votre question Signaler

SAMBA & Seven [Fermé]

olikamm 15Messages postés mardi 21 juillet 2009Date d'inscription 5 octobre 2013Dernière intervention - Dernière réponse le 21 juin 2011 à 14:04
Bonjour,
Je suis confronté à un problème avec SAMBA et Windows 7 RC:
J'ai installé samba 3.3.2 sur une CentOS5, avec un serveur LDAP sur une autre machine.
Lorsque j'essaye de ma connecter au domaine avec un Windows XP ou Vista, aucun problème, tout fonctionne parfaitement.
Lorsque j'essaye d'ajouter mon Windows Seven au domaine, il arrive a joindre le domaine et m'affiche bienvenu dans le domaine XXX
Mais lorsque je redémarre, et quelque soit l'ID/password que je tape (qui existe ou non) Seven me fait l'erreur suivante :
La relation d'approbation entre cette station de travail et le domaine principal à échoué.
Je précise que j'ai modifié le registre du Seven :
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]
"DomainCompatibilityMode"=dword:00000001
"DNSNameResolutionRequired"=dword:00000000
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Netlogon\Parameters]
"RequireStrongKey"=dword:00000000
"RequireSignOnSeal"=dword:00000000
Merci d'avance ...
Lire la suite 
Réponse
+4
moins plus
Il Faut disposer au minimum de la version 3.3.7 de Samba ou alors de la version 3.4.0
S'ils sont pas dispo, on peut les compiler

Un tuto est disponible à l'adresse http://www.badministrateur.com/fr/node/30

Réponse
+4
moins plus
Bonsoir (vers une solution ???)

Le problème étant donc de connecter un client SEVEN à un domaine géré par Samba. Voici ce que j'ai fait et qui semble marcher.

Install d'un serveur linux Ubuntu 10.04 avec install du paquet Samba (obligatoire pour avoir un version suffisament élevée de samba, ici la 3.4.7)

paramétrage du smb.conf et redémarrage du serveur samba

sur le client seven on paramètre comme suit
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Lanman­Workstation\Parameters]
"DomainCompatibilityMode"=dword:00000001
"DNSNameResolutionRequired"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Netlogon\Parameters]
"RequireStrongKey"=dword:00000000
"RequireSignOnSeal"=dword:00000000

on peut alors faire la connexion au domaine avec qd même une erreur sur l'impossibilité de modifier le nom dns ppal du client mais c'est pas grave

après redémarrage du client si l'on cherche à se connecter avec un identifiant connu de samba, on récupère une erreur d'approbation

il faut en fait se reconnecter en admin local du client et repasser à 1 les clefs suivantes
"RequireStrongKey"
"RequireSignOnSeal"

fermeture de session et réouverture avec un identifiant connu de samba et là miracle ça marche.

Bon courage à tous

nicotine- 22 juil. 2010 à 11:42
excellent ca fonctionne nikel je te remercie tu me retire une bonne épine du pied
merci
Réponse
+3
moins plus
Bonjour,

Je suis confronté à un problème avec SAMBA et Windows 7 RC:

J'ai installé samba 3.3.2 sur une CentOS5, avec un serveur LDAP sur une autre machine.

Lorsque j'essaye de ma connecter au domaine avec un Windows XP ou Vista, aucun problème, tout fonctionne parfaitement.

Lorsque j'essaye d'ajouter mon Windows Seven au domaine, il arrive a joindre le domaine et m'affiche bienvenu dans le domaine XXX
Mais lorsque je redémarre, et quelque soit l'ID/password que je tape (qui existe ou non) Seven me fait l'erreur suivante :

La relation d'approbation entre cette station de travail et le domaine principal à échoué.

Je précise que j'ai modifié le registre du Seven :

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Lanman­Workstation\Parameters]
"DomainCompatibilityMode"=dword:00000001
"DNSNameResolutionRequired"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Netlogon\Parameters]
"RequireStrongKey"=dword:00000000
"RequireSignOnSeal"=dword:00000000
----------------------

Bonjour,
Mes tests ont été réalisés avec la même modification de registre. Mais cela ne fonctionnait pas. (exepté la jointure au domaine qui semblait bien se passer puis message d'erreur.
Au redémarrage j'avais donc le choix d'ouvrir une session en locale ou sur le domaine.
La seconde était tout le temps voué à l'échec
J'ai donc fait les mêmes tests avec les clés suivantes.
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Lanman­Workstation\Parameters]
"DomainCompatibilityMode"=dword:00000001
"DNSNameResolutionRequired"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Netlogon\Parameters]
"RequireStrongKey"=dword:00000001
"RequireSignOnSeal"=dword:00000001

Miracle l'ouverture de session sur le domaine est une réussite.

Bon courage à tous

cf http://wiki.samba.org/index.php/Windows7

Réponse
+1
moins plus
Bonjour,

J'ai rencontré le même soucis sur une Debian Lenny que j'ai réglé en installant la version 3.4.4 de samba (depots squeeze). Attention dans HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Netlogon\Parameters ce n'est pas RequireSignOnSeal mais RequireSignOrSeal (l'autre n'existe pas et sa création ne change rien)

TP2415

Réponse
+1
moins plus
Hello,

Après quelque modification dans mon fichier de conf mes pc sous Windows 7 fonctionnent très bien avec un controleur de domaine SAMBA version 3.0.33.

Malheuresement j'avais fait ces modification en Aout dernier, je ne me rappel donc plus ce que j'avais fait, mais en tout cas cela ne dépend pas de la version de Samba mais plus de votre configuration.

Cordialement

kris92- 21 juin 2011 à 13:52
merci pour cette info tout à fait inutile...mais qui aurait pu l'être....dommage....
lami20j 21514Messages postés jeudi 4 novembre 2004Date d'inscription ModérateurStatut 8 octobre 2012Dernière intervention - 21 juin 2011 à 14:04
Salut,

merci pour cette info tout à fait inutile...
Déterrer un message de 2010 pour faire cette remarque c'est encore plus inutile.
Réponse
+1
moins plus
Hello,

Après de multiples essais (avec différentes versions de Debian) , voici les résultats auxquels je suis parvenu:

- la version de Samba à utiliser doit être au moins la 3.3.7 (comme indiqué officiellement sur le site du projet : http://wiki.samba.org/index.php/Windows7 )

- cela exclut donc la dernière version stable de Debian , qui n'a qu'un Samba 3.2.5 . Et effectivement (je l'ai vérifié) ça ne marche pas, même avec les modifs. de clés de registre indiquées par "Tux".

- J'ai pu obtenir un serveur qui fonctionne avec Seven, grâce aux packages fournis pas Sernet qui j'ai installés sur ma Debian Lenny:
http://ftp.sernet.de/pub/samba/3.3/debian/dists/ )

- pour intégrer le PC au domaine, une seule chose à faire au préalable : les clés "DomainCompatibilityMode" et "DNSNameResolutionRequired" .

- par contre , il est vrai que les clés "RequireStrongKey" et "RequireSignOnSeal" provoquent une erreur relative à la "relation d'approbation entre cette station de travail et le domaine". Il ne faut juste pas les mettre , car elles ne sont de toute façon pas nécessaires pour entrer dans le domaine.

- à noter , que l'erreur sur la relation d'approbation est également le résultat obtenu si le serveur est une Debian Etch ou Lenny avec les paquets d'origine . Dans ce cas , ce sont les paquets Samba sur le serveur qui sont à upgrader.

Voilà , si ces informations peuvent vous aider j'en suis heureux :)

Bon courage à tous.

Réponse
+0
moins plus
Bonjour a tous,

J'ai le même souci que tous le monde ici mon Windows seven ne rejoint pas mon domaine samba / ldap.

J'ai samba en version 3.4.7 et j'ai fais le changement dans le registre pour LanManWorkstation.

Mais toujours le même message après le demande de login mot de passe pour rejoindre.

le domaine n'existe pas ou est inaccessible.

Quelqu'un a t'il eu du nouveau de cela ?

Merci cordialement

Nico

Réponse
+0
moins plus
(au passage , j'ajoute quand même un grand merci à Tux , dont le post m'a quand même bien aidé sur le moment :) Thanks guy !

Tux1 1Messages postés mercredi 27 octobre 2010Date d'inscription 27 octobre 2010Dernière intervention - 27 oct. 2010 à 23:08
You're welcome ;-)

En attendant si qqu'un a mieux, je suis preneur car c'est &@##!!##@&!! de devoir bosser PC par PC pour modifier le registre. mais je crains qu'il faille attendre un bon upgrade du côté samba.
kkws- 8 avril 2011 à 18:26
Svp je pourai savoir si vos 7 sont professionels ou c son d editions familliales premium?Merci
Tux- 9 avril 2011 à 08:58
Ce sont des 7 pro
Ce document intitulé «  SAMBA & Seven  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.