Mise en forme conditionnelle avec NB.SI.ENS

Blueberry007 7 Messages postés dimanche 3 décembre 2017Date d'inscription 12 décembre 2017 Dernière intervention - 7 déc. 2017 à 22:58 - Dernière réponse : via55 8793 Messages postés mercredi 16 janvier 2013Date d'inscription 12 décembre 2017 Dernière intervention
- 9 déc. 2017 à 00:09
Bonjour,
Je suis en panne depuis un moment avec la fonction " =NB.SI.ENS($AN$4:$AN$16;AN$7)>0 " Je souhaite l'utiliser dans un planning (calendrier automatique) afin de faire apparaître les jours fériés en couleur en lien avec un tableau dynamique.
Je suis débutant ++ sur excel (2007) et j'ai trouvé dans un vieux topic cette formule associée à un tableau dynamique des jours fériés français.
Mais dans mon cas ça ne fonctionne pas et ça m'affiche toujours les 2 mêmes lignes (le 1er et le 4 du mois !) et comme je ne comprend pas totalement les différents éléments de la formule et leurs fonctions je n'arrive pas à comprendre ce qui ne va pas.
$AN$4:$AN$16 fait référence au champ sélectionné, mais je ne comprend pas pourquoi AN$7 qui pointe la case du 1er mai ( les différentes cellules contiennent les formules qui font apparaître les différentes dates en fonction de l'année)
Et comme j'aimerais utiliser un tableau dynamique pour les fêtes et jours férié de Genève que j'ai créé, je suis doublement embêté !

Si un âme charitable pouvait éclairer ma lanterne et me tirer de ce guêpier ! ?

Copies des documents excel concernés :
http://www.cjoint.com/c/GLhvYozqoEU
http://www.cjoint.com/c/GLhv1nulrFU

Merci




Afficher la suite 
7Messages postés dimanche 3 décembre 2017Date d'inscription 12 décembre 2017 Dernière intervention

6 réponses

Répondre au sujet
via55 8793 Messages postés mercredi 16 janvier 2013Date d'inscription 12 décembre 2017 Dernière intervention - 8 déc. 2017 à 00:16
0
Utile
Bonjour

Si tu veux de l'aide il faut poster un exemple de ton fichier (et pas une omage) sur cjoint.com, faire créer un lien le copier et revenir le coller ici

Cdlmnt
Via
Commenter la réponse de via55
DjiDji59430 1766 Messages postés samedi 19 avril 2008Date d'inscription 11 décembre 2017 Dernière intervention - 8 déc. 2017 à 00:23
0
Utile
Bonjour,

=NB.SI.ENS($AN$4:$AN$16;AN$7)>0
il manque des arguments a ta formule
Ça devrait etre
=NB.SI($AN$4:$AN$16;AN$7)>0
Mais ça ne veut rien dire, il y aura toujours un an7 entre an4 et an16 !
Si tu veux vérifier que c'est un jour férié, c'est ce jour que tu dois comparer a ton tableau
=NB.SI($AN$4:$AN$16;b9)>0 va matcher alors que
=NB.SI($AN$4:$AN$16;b21)>0 renverra 0
et a condition que ton tableau de fériés soit dans la même feuille que le calendrier
Le mieux est de mettre le fichier, pas des images (ou il n'y a même pas les entêtes)
Commenter la réponse de DjiDji59430
Blueberry007 7 Messages postés dimanche 3 décembre 2017Date d'inscription 12 décembre 2017 Dernière intervention - Modifié par Blueberry007 le 8/12/2017 à 21:46
0
Utile
Bonsoir,

Désolé pour les images à la place du fichier !
=> Lien impossible avec http://www.cjoint.com/ car limite = 15 Mo ( fichier = 50Mo)

Autre lien ci-dessous avec le ficher excel
https://wetransfer.com/downloads/d9a59ac89db54ced13e7cfbad8a3cf5c20171208203907/d5ddbef54f7d601f4213ea4bcd9bf66e20171208203907/bdb5d5
disponible 7 jours

Question supplémentaire :)) Comment inclure dans la macro "Masquer_jour" l'effacement des données contenues dans les colonnes masquées de la ligne 9 à 27 ?

Merci de vos réponses
Commenter la réponse de Blueberry007
via55 8793 Messages postés mercredi 16 janvier 2013Date d'inscription 12 décembre 2017 Dernière intervention - 8 déc. 2017 à 23:49
0
Utile
1
Bonsoir

Ton fichier avec les MFC , j'en ai mis 3 : l'une pour les fériés en France, l'autre pour ceux en Suisse et la dernière pour les fériés communs aux deux

Rajouté une ligne dans la macro pour effacer la colonne de 9 à 27

https://mon-partage.fr/f/cIUQUX4n/

Cdlmnt
Via
Blueberry007 7 Messages postés dimanche 3 décembre 2017Date d'inscription 12 décembre 2017 Dernière intervention - 9 déc. 2017 à 00:08
Merci beaucoup pour ton aide, c'est impeccable et du coup je comprend mieux à quoi sert "B$8" dans la formule NB SI !
Et pour la macro il me manquait la bonne formulation !

Merci encore pour le temps consacré :))
Commenter la réponse de via55
via55 8793 Messages postés mercredi 16 janvier 2013Date d'inscription 12 décembre 2017 Dernière intervention - 9 déc. 2017 à 00:09
0
Utile
De rien

On passe en résolu

Bonne continuation
Commenter la réponse de via55