Galère à n'en plus finir avec l'accès à mysql [Résolu/Fermé]

pristella 871 Messages postés samedi 23 octobre 2004Date d'inscriptionContributeurStatut 7 mai 2007 Dernière intervention - 11 mars 2007 à 20:32 - Dernière réponse :  balde
- 19 juil. 2017 à 21:57
bonjour,

Là je craque, je me donne une dernière chance après j'arrête les frais.

Depuis plusieurs jours j'essais d'avoir le guide TV sur mythtv, sans succès, jusqu'à tout à l'heure où j'ai lu sur ce forum :

http://mythtv-fr.info/index.php?file=Forum

qu'une solution existait mais pour ça il fallait reinstaller mythtv. Autant dire que j'etais angoissé à l'idée de le faire. Et pour cause, maintenant, je ne peux plus accéder à mysql. J'ai ce message quand je fais la commande "mysql -u root mysql" :




mythtv@PC-acer-ubuntu:~$ mysql -u root mysql
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)




J'ai suivi ce tuto qui donne des possibilités pour régler le problème :

http://help.ubuntu.com/...

Malheureusement, ça ne change rien

Par contre avec phpmyadmin, je peux me connecter ??? allez y comprendre quelquechose. Bref, mythtv-setup est inutilisable et je ne peux donc pas configurer mythtv.

Je suis dégouté

Peut-être que quelqu'un à une procedure pour régler ce problème.

J'ai vraiment pas de chance , que ce soit freevo ou mythtv, il manque toujours quelquechose pour que cela fonctionne bien
Afficher la suite 
871Messages postés samedi 23 octobre 2004Date d'inscription ContributeurStatut 7 mai 2007 Dernière intervention

72 réponses

lami20j 21513 Messages postés jeudi 4 novembre 2004Date d'inscriptionContributeur sécuritéStatut 8 octobre 2012 Dernière intervention - Modifié par jipicy le 18/12/2013 à 16:57
+202
Utile
50
Essaie ça :

# /etc/init.d/mysql stop
Shutting down MySQL..
# mysqld_safe --skip-grant-tables --skip-networking &
[1] 4983
# Starting mysqld daemon with databases from /var/lib/mysql

# mysql mysql
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 1 to server version: 5.0.21-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> update user set password=password('aaaaaaaa') where user="root" and host="localhost";
Query OK, 0 rows affected (0,00 sec)
Rows matched: 1 Changed: 0 Warnings: 0

mysql> exit
Bye
# mysqladmin shutdown
STOPPING server from pid file /var/lib/mysql/debian.pid
030811 14:38:40 mysqld ended

[1]+ Done /usr/local/mysql/bin/mysqld_safe --skip-grant-tables --skip-networking
# /etc/init.d/mysql start
Starting MySQL
# mysql -u root -p
lami20j
Cette réponse vous a-t-elle aidé ?  
Mais ou Je dois Coller cette commande
Clair, net et précis. Bravo !
PS : sur opensuse il faut utiliser "service mysql stop" et "service mysql start" (ou restart)
Merci beaucoup!!! ça vient de me sauver.
Grand merci :) :)
un grand merci a toi j avais vraiment galerer . tu m a sauve thanks a lot
lami20j 21513 Messages postés jeudi 4 novembre 2004Date d'inscriptionContributeur sécuritéStatut 8 octobre 2012 Dernière intervention - 11 mars 2007 à 20:54
+8
Utile
2
Salut,

essaie avec
mysql -u root -p
pristella 871 Messages postés samedi 23 octobre 2004Date d'inscriptionContributeurStatut 7 mai 2007 Dernière intervention - 11 mars 2007 à 22:57
Salut lami20j,

C'est vraiment la galère, la semaine dernière j'ai reussi à tout faire fonctionner sauf le guide des programme pour mythtv et sans avoir d'erreur de ce genre.

Pour remedier à mon problème du guide des programmes dans mythtv, il fallait que je reinstalle mythtv et mysql. Depuis ça M.... voilà pour le resultat de ta commande :

$ sudo /etc/init.d/mysql restart
Password:
 * Stopping MySQL database server mysqld                                 [ ok ] 
 * Starting MySQL database server mysqld                                 [ ok ] 
 * Checking for corrupt, not cleanly closed and upgrade needing tables.
acer@PC-acer-ubuntu:~$ mysql -u root -p
Enter password: 
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)


J'y comprend vraiment rien à mysql :(
j'ai eu le même bleme...et cette solution ma sauver ..Merciiiiiiiiii

Mon probeleme été dans la configuration de phpMyAdmin ou j'arrivais pas à me loger et aprè une recherche étendu cete solution ma permi de me connecté sur phpMyAdmin:
SET PASSWORD FOR root@localhost=PASSWORD(' monmotdepasse ');
mysql> GRANT ALL PRIVILEGES ON *.* TO root@localhost IDENTIFIED BY ' monmotdepasse ' WITH GRANT OPTION;

Sauf que quand j'ai esayer de lancer mysql depuis mon terminal il voulais plus et là j'ai cheché le belme et je uis tombé sur cette réponse qui m'a sauver Merci bcp

OS: Ubuntu 11.10
lami20j 21513 Messages postés jeudi 4 novembre 2004Date d'inscriptionContributeur sécuritéStatut 8 octobre 2012 Dernière intervention - 12 mars 2007 à 06:51
+4
Utile
4
Salut,

Peut être tu n'as pas de mot de passe pour root

acer@PC-acer-ubuntu:~$ mysql -u root -p
Enter password:

Quand il te demande le mot de passe ne mets rien et fait ENTRER
Je pense que tu essaies le mots de passe root pour ton système, mais ça ne marche pas. Ici il s'agit de mot de passe pour un utilisateur MySql, bien sûr que tu peux utilser le même mot de passe root mais d'abord il faut l'attribuer.

Si ça marche, mets un mot de passe root
lami20j@debian:~$ mysql -u root -p
Enter password: ICI TU FAIT ENTRER SANS RIEN SAISIR
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 3 to server version: 5.0.21-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> set password for root@localhost=password('**************');
Query OK, 0 rows affected (0,00 sec)

mysql>

Au lieu des étoiles saisie le mots de passe que tu veux établir.
Merci pour le coup du mot de passe vide :-)
c'est Sophie. Merci !!!
revérifier le mot de passe, moi j'ai eu ce message d'erreur jusqu'à trouver un fichier avec le mot de passe généré aléatoirement à l'install. Depuis j'ai accès à la base:-))
Bonjour, pourquoi avec "mysql -u root -p" tout va bien mais lorsque j'écris mysql ou mysql -u root j'ai l'erreur "'ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)"" ??
+1
Utile
yep, la première ligne c'est depuis 2.6.32-27-generic: service mysql stop
et plus tard: service mysql start
:) Le raisonnement marche, merci !!!
tufs 1279 Messages postés mercredi 1 décembre 2004Date d'inscriptionContributeurStatut 16 mars 2008 Dernière intervention - 11 mars 2007 à 21:37
0
Utile
salut

peut-etre un =>

sudo /etc/init.d/mysql restart

si tu n as pas configurer de mot de passe =>( pour MySQL )

mysql -u root

info =>

http://forum.apachefrance.com/
tufs 1279 Messages postés mercredi 1 décembre 2004Date d'inscriptionContributeurStatut 16 mars 2008 Dernière intervention - 11 mars 2007 à 23:42
pristella 871 Messages postés samedi 23 octobre 2004Date d'inscriptionContributeurStatut 7 mai 2007 Dernière intervention - 12 mars 2007 à 19:48
0
Utile
salut lami20j,

J'ai reinstallé mysql puis mythtv, et déjà à l'install de mythtv j'ai une erreur :

root@PC-acer-ubuntu:~# apt-get install mythtv
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture de l'information d'état... Fait
Paquets recommandés :
  mythtv-doc mythtv-themes
Les NOUVEAUX paquets suivants seront installés :
  mythtv
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/19,6ko dans les archives.
Après dépaquetage, 65,5ko d'espace disque supplémentaires seront utilisés.
Sélection du paquet mythtv précédemment désélectionné.
(Lecture de la base de données... 151113 fichiers et répertoires déjà installés.)
Dépaquetage de mythtv (à partir de .../mythtv_0.20-0.2ubuntu2_all.deb) ...
Paramétrage de mythtv-database (0.20-0.2ubuntu2) ...
Failed to connect to database: Access denied for user 'root'@'localhost' (using password: YES) at -e line 5, <> line 1.
Failed to create database (incorrect admin username/password?)
If you supplied incorrect information, try:
dpkg-reconfigure --force mythtv-database
dpkg : erreur de traitement de mythtv-database (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de mythtv :
 mythtv dépend de mythtv-database (= 0.20-0.2ubuntu2) ; cependant :
 Le paquet mythtv-database n'est pas encore configuré.
dpkg : erreur de traitement de mythtv (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 mythtv-database
 mythtv
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@PC-acer-ubuntu:~# 



ensuite avec cette commande :

acer@PC-acer-ubuntu:~$ mysql -u root -p
Enter password: 
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
acer@PC-acer-ubuntu:~$ 


que ce soit sans mot de passe ou avec l'ancien mot de passe

Je craaaaque !!!!!
pristella 871 Messages postés samedi 23 octobre 2004Date d'inscriptionContributeurStatut 7 mai 2007 Dernière intervention - 12 mars 2007 à 19:49
0
Utile
problème toujours non résolu
lami20j 21513 Messages postés jeudi 4 novembre 2004Date d'inscriptionContributeur sécuritéStatut 8 octobre 2012 Dernière intervention - 12 mars 2007 à 19:49
0
Utile
2
Affiche le contenu de fichier /etc/my.cnf
pristella 871 Messages postés samedi 23 octobre 2004Date d'inscriptionContributeurStatut 7 mai 2007 Dernière intervention - 12 mars 2007 à 20:53
voilà :

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "/var/lib/mysql/my.cnf" to set server-specific options or
# - "~/.my.cnf" to set user-specific options.
# 
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port		= 3306
socket		= /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket		= /var/run/mysqld/mysqld.sock
nice		= 0

[mysqld]
#
# * Basic Settings
#
user		= mysql
pid-file	= /var/run/mysqld/mysqld.pid
socket		= /var/run/mysqld/mysqld.sock
port		= 3306
basedir		= /usr
datadir		= /var/lib/mysql
tmpdir		= /tmp
language	= /usr/share/mysql/english
skip-external-locking
#
# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
old_passwords	= 1
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address		= 127.0.0.1
#
# * Fine Tuning
#
key_buffer		= 16M
max_allowed_packet	= 16M
thread_stack		= 128K
thread_cache_size	= 8
#
# * Query Cache Configuration
#
query_cache_limit	= 1048576
query_cache_size        = 16777216
query_cache_type        = 1
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log		= /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log_slow_queries	= /var/log/mysql/mysql-slow.log
#
# The following can be used as easy to replay backup logs or for replication.
#server-id		= 1
log_bin			= /var/log/mysql/mysql-bin.log
# WARNING: Using expire_logs_days without bin_log crashes the server! See README.Debian!
expire_logs_days	= 10
max_binlog_size         = 100M
#binlog_do_db		= include_database_name
#binlog_ignore_db	= include_database_name
#
# * BerkeleyDB
#
# According to an MySQL employee the use of BerkeleyDB is now discouraged
# and support for it will probably cease in the next versions.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
# You might want to disable InnoDB to shrink the mysqld process by circa 100MB.
#skip-innodb
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet	= 16M

[mysql]
#no-auto-rehash	# faster start of mysql but no tab completition

[isamchk]
key_buffer		= 16M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the ndbd storage daemons,
# not from the ndb_mgmd management daemon.
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1



mm!! je crois que je dois commenter cette ligne ? :

bind-address		= 127.0.0.1
pristella 871 Messages postés samedi 23 octobre 2004Date d'inscriptionContributeurStatut 7 mai 2007 Dernière intervention > pristella 871 Messages postés samedi 23 octobre 2004Date d'inscriptionContributeurStatut 7 mai 2007 Dernière intervention - 12 mars 2007 à 21:01
non ça change rien :(
0
Utile
4
Un grand merci !! ca marcheeeeee
GRAND MERCI !!!
un tres grand merci pour lami20j mmmmmmmmmmma7
Tj au top cette procédure, merci bien
mysqladmin -uroot password MonPassword