Menu

CPU incompatible avec la dernière ubuntu [Résolu/Fermé]

DRONE_DU_COLLECTIF 55 Messages postés lundi 28 mai 2012Date d'inscription 9 octobre 2017 Dernière intervention - 6 juin 2012 à 18:00 - Dernière réponse :  Will
- 11 avril 2018 à 21:25
Bonjour,
Je viens d'essayer d'installer la dernière version d'ubuntu (12.04) sur un ultra-portable (Sony VAIO série TR) qui a une dizaine d'années et qui est muni d'un CPU à 900 MHZ et d'1 Gigaoctet de RAM.
Au boot j'ai obtenu le message suivant :

"this kernel requires the following features not present on the CPU :
pae
Unable to boot - please use a kernel appropriate for your CPU."

Quelqu'un peut-il m'expliquer ce que ce "pae" signifie et quelle version de LINUX je puis installer sur ce portable à coup sûr sans gâcher à l'aveuglette un grand nombre de cd...

Merci pour toute aide !





Afficher la suite 

6 réponses

grrrrrrrrrrrr - 26 juil. 2015 à 22:49
+29
Utile
1
La solution est simple.
Utiliser virtualbox.
Dans virtualbox tu choisis ta machine. Ensuite tu vas dans "Configuration" -> "Système" -> "Processeur" et tu coches la case "Fonctions Avancées".

Et voila affaire résolu
+1
Utile
Salut,

Sinon, plus rapide: Xubuntu 12.04 embarque pour la dernière fois le noyau non pae (tranquille pour 3 ans - durée de la maintenance de cette version). A priori, les versions de Mint 13 également (je n'ai pas eu le message d'erreur non plus avec cette version: 5 ans de tranquillité).

voir ici

http://www.commentcamarche.net/forum/affich-25052714-installation-linux-lts-12-04#12

L'explication: http://www.quebecos.com/modules/news/article.php?com_mode=nest&com_order=1&storyid=4754
mamiemando 28292 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 avril 2018 Dernière intervention - Modifié par mamiemando le 7/06/2012 à 00:55
0
Utile
Signification de PAE :
http://fr.wikipedia.org/wiki/Extension_d%27adresse_physique

En gros c'est utile si tu as plus de 4Go de RAM et que tu utilises un noyau 32 bits (x86 pour un CPU de PC classique). Si ton CPU supporte le 64 bits (amd64, peu importe la marque du CPU), c'est à mon avis un meilleur choix. Dans l'absolu tu peux utiliser un noyau 32 bits "non pae". Le problème c'est qu'ubuntu ne propose que 32 bits pae (appelé dans leur terminologie noyaux "generic") et 64 bits pour autant que je sache.

Ainsi la solution consisterait à vérifier
1) si ton CPU supporte le 64 bits
2) si oui, à installer la version 64 bits

Pour le point (1) c'est très simple. Il suffit au moment d'installer de lancer un terminal et de taper la commande suivante :

grep flags /proc/cpuinfo


Si une ligne (au moins) contenant "lm" apparaît, ton CPU (à raison d'une ligne par coeur) supporte le 64 bits.

Exemple :

(mando@aldur) (~) $ grep flags /proc/cpuinfo | grep --color lm 
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow rep_good nopl pni lahf_lm cmp_legacy 
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext 3dnow rep_good nopl pni lahf_lm cmp_legacy


(ici ce CPU a deux coeurs qui supportent le 64 bits, donc c'est bon). Si ce n'est pas le cas, d'autre distributions (par exemple debian) te permettent d'installer des versions 32 bits de linux qui n'utilisent pas de noyau pae (appelés sous debian "bigmem").

Pour le point (2), il suffit de télécharger le CD d'installation approprié. Par exemple pour ubuntu, sur cette page, il suffit de cliquer sur "plus d'options" et choisir "Processeurs 64bits pour les ordinateurs récents (AMD64 ou EM64T)"
http://www.ubuntu-fr.org/telechargement

Bonne chance
DRONE_DU_COLLECTIF 55 Messages postés lundi 28 mai 2012Date d'inscription 9 octobre 2017 Dernière intervention - 9 juin 2012 à 18:35
0
Utile
Merci à vous !
Colonel Moutarde - 20 mai 2015 à 16:36
0
Utile
Pensez également à jeter un coup d'oeil au BIOS. J'ai eu ce même message d'erreur à l'install de la 15.04, et après avoir beaucoup navigué (et donc pas mal ramé) j'ai passé le "Intel Virtualization Technology" de disabled à enabled et plus de problème de pae.