Menu

Safari a changé de langue tout seul [Résolu]

-
Bonjour,
j'ai voulu installer une application via safari mais l'écran est devenu noir et mon macbook pro a redémarré en me demandant si je voulais ré-ouvrir mes pages et j'ai dis non comme à l'habitude. Je suis retournée dans safari mais je me suis rendu compte que safari ainsi que sa barre d'état était en anglais. J'ai essayé de changer la langue en allant dans " préférences système " mais la langue sélectionnée est le français. Je ne sais plus quoi faire pouvez vous m'aidez?



Configuration: Macintosh / Safari 10.1.2
Afficher la suite 

Votre réponse

10 réponses

Meilleure réponse
approuvée par Jean-François Pillou le 5 déc. 2018
Messages postés
19776
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
20 mars 2019
5007
94
Merci
Bonjour,

Tu peux tenter ceci:
  • quitter l'application Safari
  • ouvrir le dossier "Applications" -> "Utilitaires"
  • lancer "Terminal"
  • dans la fenêtre qui s'ouvre, taper la commande:
    defaults write com.apple.Safari AppleLanguages '(fr)'
  • appuyer sur la touche Entrée ( ↩︎ ) pour exécuter la commande
  • Redémarrer le Mac

Safari devrait être revenu en français

Autre possibilité: utiliser un outil comme Language Switcher qui te permet de faire basculer n'importe quelle application dans n'importe quelle langue, et donc de remettre Safari en français

Ritchi

Dire « Merci » 94

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 48807 internautes nous ont dit merci ce mois-ci

_Ritchi_
Messages postés
19776
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
20 mars 2019
5007 -
Bonjour chach11,

Saurais-tu ouvrir une fenêtre Terminal et lancer les commandes afin de connaître l'ordre de préférences des langues mémorisées par ton Mac ?
Vérification des langues:
- lance la commande
defaults read -g AppleLanguages

- presse la touche "Entrée" (↩︎) du clavier pour activer la commande

Si tu voies que "en-FR" ou "en-US" dans la réponse:

Alors fais ceci:
- lance la commande
defaults write -g AppleLanguages '("fr-FR", "en-US")'

- presse la touche "Entrée" (↩︎) du clavier pour activer la commande
Il faut ensuite redémarrer le Mac : menu Pomme () puis "Redémarrer"

Note:
Si tu crains d'avoir un ou des malware(s), alors télécharge et installe dans les Applications Malwarebytes anti-malware (gratuit) puis lance-le et si le scan découvre des malwares alors active l'option de suppression puis redémarre le Mac

Ritchi
Waddle13
Messages postés
1
Date d'inscription
jeudi 3 janvier 2019
Dernière intervention
3 janvier 2019
-
Bonsoir, j'ai fait toutes les manipulations comme tu as pu nous indiquer, mais mon safari est toujours en anglais. J'ai même fait la manipulation MAJ + CONTROL + COMMAND + R au démarrage et sélectionner le 2e choix de la liste pour tout reconfigurer d'origine mais rien n'y fait. Je me suis fait avoir avec une MAJ d'adobe flasher également.


Je suis tout nouveau sur MAC donc c'est vraiment galère et ces débuts difficiles ne me facilitent pas la tache .

Merci pour ton aide
Je suis exactement dans le même cas que toi : maj d'adobe et depuis safari est passé en anglais... J'ai tout tenté et rien de fonctionne. Je vais tenter l'ultime solution de réinstaller macOS, je te dirai si ça marche...
_Ritchi_
Messages postés
19776
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
20 mars 2019
5007 -
Bonjour,
Avant de tout réinstaller, tu pourrais tenter de supprimer Flash Player (voir ICI) puis de refaire les commandes qui remettent en français Safari.
Ritchi
_Ritchi_
Messages postés
19776
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
20 mars 2019
5007 -
Commenter la réponse de _Ritchi_
Natthh
Messages postés
2
Date d'inscription
dimanche 20 janvier 2019
Dernière intervention
20 janvier 2019
-
bonjour,
pourriez vous me dire comment avez-vous fait pour résoudre le problème ?
Merci
Commenter la réponse de alex
1
Merci
Pour info pour ceux qui galèrent encore, j'ai réussi en faisant un copier/coller de la manip à faire dans le terminal.
Commenter la réponse de Flower
Messages postés
36386
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
20 mars 2019
10783
0
Merci
Bonjour,

C'était quoi comme application exactement ? Il se peut qu'il s'agisse d'une application prise sur un site douteux et contenant un malware. Faites un contrôle avec MalwareBytes :
https://www.commentcamarche.com/faq/42627-supprimer-adwares-publicite-indesirable-scams-mackeeper-sous-mac-os-x



Bonjour,
Je me suis faite avoir avec une MAJ Adobe Flash player et j'ai depuis éliminé le virus weknow.ac.
Malwarebytes a fait un scann et nettoyé les menaces détectées. Je suis allée vérifier dans les applications et Prefadmin, je n'ai plus rien de malveillant qui apparait.
Mais la barre Safari reste en anglais...
Des conseils pour revenir au français ou approfondir la détection d'autre application douteuse ?
> Giulia -
Pareil ! Mon problème a été solutionné par Apple. Il suffit de rentrer un code dans la fonction "Terminal" de ton Mac. Je n'ai pas pensé a le recopier, mais mon soucis est rentré dans l'ordre.
Je suis dans le même cas que toi, impossible de remettre le français alors que j'ai enfin réussi à supprimer weknow.ac. Qu'as tu fait finalement?
Comment as tu fais ? Je n'arrive vraiment pas a le supprimer...
_Ritchi_
Messages postés
19776
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
20 mars 2019
5007 -
Bonjour Pseudo...
Je ne comprends pas:
- le 14 août 2018 à 23:26 tu dis que "la première solution a bien fonctionné" (ndlr: voir ligne de commande citée ici)
- le 15 août 2018 à 23:37 soit le lendemain tu dis "Je n'arrive vraiment pas a le supprimer..."

Pourrais-tu en dire plus ?
Ritchi
Commenter la réponse de *_Francis_*
0
Merci
Bonsoir merci infiniment pour votre aide

le problème est résolu
Natthh
Messages postés
2
Date d'inscription
dimanche 20 janvier 2019
Dernière intervention
20 janvier 2019
-
bonjour,
pourriez vous me dire comment avez-vous fait pour résoudre le problème s'il vous plait ?
Merci
_Ritchi_
Messages postés
19776
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
20 mars 2019
5007 > Natthh
Messages postés
2
Date d'inscription
dimanche 20 janvier 2019
Dernière intervention
20 janvier 2019
-
Bonjour natthh
En appliquant ce qui est indiqué ici : https://www.commentcamarche.net/forum/affich-35446135-safari-a-change-de-langue-tout-seul#4
Ritchi
Hello, bon bah j'ai fait comme indiqué mais safari toujours en anglais depuis maj adobe flash player... grrrr
Commenter la réponse de Fatihi
0
Merci
Bonjours j'ai le même soucis Avec mon Mac quand je vais dans l'application safari tout est en Anglais
j'ai essayer les conseils donne avec le terminal mais rien de change ..
_Ritchi_
Messages postés
19776
Date d'inscription
samedi 17 mars 2007
Statut
Contributeur
Dernière intervention
20 mars 2019
5007 -
Bonjour Sammmm,
Même réponse qu'à toutes les personnes pour lequel cela n'a pas marché: fais une capture d'écran ou une photo (lisible!!) afin que je vois la raison de cet échec.
Au cas où, voici une aide sur:
- Comment faire une capture d'écran
- Comment partager une capture d'écran ou une photo
Note1: Sélectionner la partie intéressante et pas l'écran entier sinon l'image sera trop grande et les textes seront illisibles.
Note2: La capture d'écran doit être au format PNG afin que l'on puisse cliquer dessus pour zoomer dessus: voir explications dans la partie "Images cliquables" du second lien donné ci-dessus.
Ritchi
Commenter la réponse de Sammmm
0
Merci
Ayant connu le pb de Safari en Anglais, après avoir bcp galéré, la meilleure solution pour ce qui me concerne a été " Language Switcher " signalé par _Ritchi_ : Simple d'usage, efficace. Merci _Ritchi_
geswann
Messages postés
2
Date d'inscription
mardi 5 février 2019
Dernière intervention
5 février 2019
-
bonjour,
J'ai essayé Language switcher qui effectivement me lance Safari en Français. Sauf que...lorsque je ferme et réouvre safari, il est de nouveau en anglais.
Pour info, j'ai essayé toutes les astuces proposées ici...

Merci par avance.
Commenter la réponse de dede71
Messages postés
2
Date d'inscription
mardi 5 février 2019
Dernière intervention
5 février 2019
0
Merci
Bonjour,
J'ai essayé Language switcher qui effectivement me lance Safari en Français. Sauf que...lorsque je ferme et réouvre safari, il est de nouveau en anglais.
Pour info, j'ai essayé toutes les astuces proposées ici...

Merci par avance.
Commenter la réponse de geswann
0
Merci
La seule méthode qui a fonctionné pour moi est d'utiliser le logiciel Language Switcher. Le reste n'a pas fonctionné, mais c'est loin d'être parfait. J'ai en gros 2 safaris à présent qui s'affichent et le safari en français est bourré de SPAM. Ca va être pratique. Je vais retourner à ma version en anglais, tant pis.
Merci quand même...
Commenter la réponse de Sam
Messages postés
1
Date d'inscription
jeudi 14 février 2019
Dernière intervention
14 février 2019
0
Merci
Bonsoir,
Une méthode qui fonctionne c'est d'éliminer toutes les préférences de Safari sans oublier les dossiers qui se trouvent dans la Bibliothèque/Applications Support.

Après élimination Safari revient en Français.
Bonjour,
J'ai déjà essayé et ça ne fonctionne pas.
Par contre, j'ai fait quelques essais supplémentaires.
J'ai créé un nouvel utilisateur et me suis connecté sous cette nouvelle session.
Le problème de Safari n'est pas présent.
Peut-être une solution de contournement pour certains à qui on a dit de réinitialiser leur Mac et que finalement ça n'a pas résolu le problème.
geswann : Pour info, j'ai trouvé le fichier de préférence Safari qui est vérolé par le weknow sous Mojave (2 min pour supprimer les 2 profils systèmes créés par Weknow, 2h pour la langue Safari a écumer le net...) :

- Quitte Safari
- Sous Macintosh HD⁩ ▸ ⁨Utilisateurs⁩ ▸ ⁨(USER) ▸ ⁨Bibliothèque⁩ ▸ ⁨Containers⁩ ▸ ⁨com.apple.Safari⁩ ▸ ⁨Data⁩ ▸ ⁨Library⁩ ▸ ⁨Preferences
- Supprime le fichier "com.apple.safari.plist"
- Relance, normalement c'est ok

En espérant que ça t'aide :)
A+ Gugli
cervin41_3852
Messages postés
2
Date d'inscription
mardi 19 mars 2019
Dernière intervention
19 mars 2019
-
Allez dans le Finder puis cliquer sur "Aller" en haut et si vous ne voyez pas apparaitre la rubrique Bibliothèque cliquer en même temps sur la touche Alt et de là cliquer sur Bibliothèque et aller dans Containers et retrouver le fichier com.apple.safari.plist" et supprimer le puis redémarrer votre PC et normalement safari sera revenu en Français pour moi cela a fonctionner. Par contre j'ai la meme chose avec google et je ne sais pas quel fichier supprimer :(
cervin41_3852
Messages postés
2
Date d'inscription
mardi 19 mars 2019
Dernière intervention
19 mars 2019
-
Bon avec un peu de mal j'ai enfin réussi la meme chose pour chrome qui était devenu en Anglais. c'est ok c'est revenu en français comme avant.
Commenter la réponse de Philou1338